aboutsummaryrefslogtreecommitdiff
path: root/devel/cxref/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1997-01-02 10:20:44 +0000
committerThomas Gellekum <tg@FreeBSD.org>1997-01-02 10:20:44 +0000
commit6d4994ee2b613bd0891304b1bce5bd019ca39b2b (patch)
tree0f11f02580dbb17b504fe8860bc87cc62748f28d /devel/cxref/Makefile
parent1af0ec6bf0a3d415ee54dbab20734a97602c95c2 (diff)
downloadports-6d4994ee2b613bd0891304b1bce5bd019ca39b2b.tar.gz
ports-6d4994ee2b613bd0891304b1bce5bd019ca39b2b.zip
Notes
Diffstat (limited to 'devel/cxref/Makefile')
-rw-r--r--devel/cxref/Makefile39
1 files changed, 5 insertions, 34 deletions
diff --git a/devel/cxref/Makefile b/devel/cxref/Makefile
index 54b438089a68..9b98fa8701c6 100644
--- a/devel/cxref/Makefile
+++ b/devel/cxref/Makefile
@@ -1,49 +1,20 @@
# New ports collection makefile for: cxref
-# Version required: 1.2b
+# Version required: 1.3
# Date created: 23 October 1996
# Whom: Thomas Gellekum <tg@freebsd.org>
#
-# $Id: Makefile,v 1.2 1996/10/25 06:11:05 tg Exp $
+# $Id: Makefile,v 1.3 1996/11/18 11:22:40 asami Exp $
#
-DISTNAME= cxref-1.2
-PKGNAME= cxref-1.2b
+DISTNAME= cxref-1.3
CATEGORIES= devel
MASTER_SITES= ftp://ftp.demon.co.uk/pub/unix/unix/tools/
EXTRACT_SUFX= .tgz
-PATCHFILES= cxref-1.2-1.2a.diff.gz cxref-1.2a-1.2b.diff.gz
-PATCH_SITES= ${MASTER_SITES}
-
MAINTAINER= tg@freebsd.org
-WRKSRC= ${WRKDIR}/cxref
USE_GMAKE= yes
-ALL_TARGET= program
-PATCH_DIST_STRIP= -p1
-
-DOCDIR= ${PREFIX}/share/doc/cxref
-
-do-install:
- @mkdir -p ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/cxref ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/query/cxref-query ${PREFIX}/bin
- @mkdir -p ${DOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/cxref.sty ${DOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/fonts.sty ${DOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/page.sty ${DOCDIR}
-.if !defined(NOPORTDOCS)
- ${INSTALL_DATA} ${WRKSRC}/README.c ${DOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCDIR}/README.cxref
- ${INSTALL_DATA} ${WRKSRC}/query/README ${DOCDIR}/README.query
- @${ECHO_MSG}
- @${ECHO_MSG} "Unfortunately, there's no man page."
- @${ECHO_MSG} "Please see ${DOCDIR}/README* for documentation."
-.endif
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to use the LaTeX output from cxref,"
- @${ECHO_MSG} "you should copy ${DOCDIR}/*.sty"
- @${ECHO_MSG} "to a directory where TeX looks for its input files."
- @${ECHO_MSG}
+ALL_TARGET= cxref-inst cxref-query
+MAN1= cxref.1 cxref-query.1
.include <bsd.port.mk>