aboutsummaryrefslogtreecommitdiff
path: root/devel/cxxtest/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-07 23:36:26 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-07 23:36:26 +0000
commit3b966e1629bbaac2a3184848f10e189811e352d5 (patch)
tree39dab10e0107d3b992859f726a555a7d4a108272 /devel/cxxtest/Makefile
parent88568d177e8c2bec08bee33c645fc6c1df8af89f (diff)
downloadports-3b966e1629bbaac2a3184848f10e189811e352d5.tar.gz
ports-3b966e1629bbaac2a3184848f10e189811e352d5.zip
Notes
Diffstat (limited to 'devel/cxxtest/Makefile')
-rw-r--r--devel/cxxtest/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/devel/cxxtest/Makefile b/devel/cxxtest/Makefile
index 8d43e0f0b6d4..016c3c173fec 100644
--- a/devel/cxxtest/Makefile
+++ b/devel/cxxtest/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cxxtest
-PORTVERSION= 3.7.1
+PORTVERSION= 3.9.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,8 +19,8 @@ NO_BUILD= yes
USE_PERL5_RUN= yes
DOCS= README TODO docs/*.html docs/*.png
-EXAMPLES= sample/*.cpp sample/*.h sample/*.tpl \
- sample/Construct sample/Makefile.unix \
+EXAMPLES= sample/*.cpp sample/*.h sample/*.tpl sample/Construct \
+ sample/Makefile.unix sample/gui/GreenYellowRed.h
do-install:
# scripts
@@ -34,15 +34,13 @@ do-install:
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
@${ECHO_MSG} "* Documentation has been installed in ${DOCSDIR}"
.endif
- @${MKDIR} ${EXAMPLESDIR}/test
+ @${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
- cd ${WRKSRC}/test && ${TAR} -cf - * | \
- (cd ${EXAMPLESDIR}/test && ${TAR} -xf -)
@${ECHO_MSG} "* Samples have been installed in ${EXAMPLESDIR}"
- @${ECHO_MSG} "* Beware that the sample makefiles aren't compatible with FreeBSD's make,"
- @${ECHO_MSG} "* use ${GMAKE} instead."
@${ECHO_MSG} "* The CxxTest scripts have been installed into ${PREFIX}/bin/."
@${ECHO_MSG} "* The include files are in ${PREFIX}/include/cxxtest/"
+ @${ECHO_MSG} "* Beware that the sample makefiles aren't compatible with FreeBSD's make,"
+ @${ECHO_MSG} "* use ${GMAKE} instead."
@${ECHO_MSG} "* The obvious reminder: don't forget to add ${PREFIX}/include to your include path."
.include <bsd.port.mk>