aboutsummaryrefslogtreecommitdiff
path: root/devel/cxxtools
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2011-06-22 22:53:57 +0000
committerJuergen Lock <nox@FreeBSD.org>2011-06-22 22:53:57 +0000
commit273695a47306eb442fdf5f7222952d8152d5568a (patch)
tree8d3ca18a970e727abee918ad582653fd8804032a /devel/cxxtools
parent23dd509befa0f427d86df13fd1c61ef078f94cff (diff)
downloadports-273695a47306eb442fdf5f7222952d8152d5568a.tar.gz
ports-273695a47306eb442fdf5f7222952d8152d5568a.zip
Notes
Diffstat (limited to 'devel/cxxtools')
-rw-r--r--devel/cxxtools/Makefile1
-rw-r--r--devel/cxxtools/files/patch-clang128
2 files changed, 129 insertions, 0 deletions
diff --git a/devel/cxxtools/Makefile b/devel/cxxtools/Makefile
index aae85a8c13b1..e868d495499d 100644
--- a/devel/cxxtools/Makefile
+++ b/devel/cxxtools/Makefile
@@ -15,6 +15,7 @@ COMMENT= Collection of general-purpose C++ classes
PATCH_STRIP= -p1
USE_ICONV= yes
+USE_CSTD= gnu89
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}"
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
diff --git a/devel/cxxtools/files/patch-clang b/devel/cxxtools/files/patch-clang
new file mode 100644
index 000000000000..7781b7bce960
--- /dev/null
+++ b/devel/cxxtools/files/patch-clang
@@ -0,0 +1,128 @@
+--- a/include/cxxtools/iostream.h
++++ b/include/cxxtools/iostream.h
+@@ -56,7 +56,7 @@ class BasicIStream : public std::basic_i
+ {
+ BasicStreamBuffer<CharT>* tmp = _buffer;
+ _buffer = buffer;
+- rdbuf(buffer);
++ this->rdbuf(buffer);
+ return tmp;
+ }
+
+@@ -106,7 +106,7 @@ class BasicOStream : public std::basic_o
+ {
+ BasicStreamBuffer<CharT>* tmp = _buffer;
+ _buffer = buffer;
+- rdbuf(buffer);
++ this->rdbuf(buffer);
+ return tmp;
+ }
+
+@@ -152,7 +152,7 @@ class BasicIOStream : public std::basic_
+ {
+ BasicStreamBuffer<CharT>* tmp = _buffer;
+ _buffer = buffer;
+- rdbuf(buffer);
++ this->rdbuf(buffer);
+ return tmp;
+ }
+
+--- a/include/cxxtools/textstream.h
++++ b/include/cxxtools/textstream.h
+@@ -84,14 +84,14 @@ class BasicTextIStream : public std::bas
+ : std::basic_istream<intern_type>(0)
+ , _buffer( &is, codec )
+ {
+- init(&_buffer);
++ this->init(&_buffer);
+ }
+
+ explicit BasicTextIStream(CodecType* codec)
+ : std::basic_istream<intern_type>(0)
+ , _buffer( 0, codec )
+ {
+- init(&_buffer);
++ this->init(&_buffer);
+ }
+
+ //! @brief Deletes to codec.
+@@ -170,12 +170,12 @@ class BasicTextOStream : public std::bas
+ BasicTextOStream(StreamType& os, CodecType* codec)
+ : std::basic_ostream<intern_type>(0)
+ , _buffer( &os , codec )
+- { init(&_buffer); }
++ { this->init(&_buffer); }
+
+ explicit BasicTextOStream(CodecType* codec)
+ : std::basic_ostream<intern_type>(0)
+ , _buffer( 0 , codec )
+- { init(&_buffer); }
++ { this->init(&_buffer); }
+
+ //! @brief Deletes to codec.
+ ~BasicTextOStream()
+@@ -253,12 +253,12 @@ class BasicTextStream : public std::basi
+ BasicTextStream(StreamType& ios, CodecType* codec)
+ : std::basic_iostream<intern_type>(0)
+ , _buffer( &ios, codec)
+- { init(&_buffer); }
++ { this->init(&_buffer); }
+
+ explicit BasicTextStream(CodecType* codec)
+ : std::basic_iostream<intern_type>(0)
+ , _buffer(0, codec)
+- { init(&_buffer); }
++ { this->init(&_buffer); }
+
+ //! @brief Deletes the codec.
+ ~BasicTextStream()
+--- a/include/cxxtools/streamcounter.h
++++ b/include/cxxtools/streamcounter.h
+@@ -69,7 +69,7 @@ namespace cxxtools
+ BasicStreamcounter()
+ : std::basic_ostream<CharType, Traits>(0)
+ {
+- init(&streambuf);
++ this->init(&streambuf);
+ }
+
+ unsigned getCount() const { return streambuf.getCount(); }
+--- a/include/cxxtools/smartptr.h
++++ b/include/cxxtools/smartptr.h
+@@ -249,14 +249,14 @@ namespace cxxtools
+ { ownershipPolicyType::link(ptr, ptr.object); }
+ ~SmartPtr()
+ { if (ownershipPolicyType::unlink(object))
+- destroy(object); }
++ this->destroy(object); }
+
+ SmartPtr& operator= (const SmartPtr& ptr)
+ {
+ if (object != ptr.object)
+ {
+ if (ownershipPolicyType::unlink(object))
+- destroy(object);
++ this->destroy(object);
+
+ object = ptr.object;
+
+--- a/include/cxxtools/query_params.h
++++ b/include/cxxtools/query_params.h
+@@ -231,7 +231,7 @@ class QueryParams
+ : unnamed_params(src.unnamed_params),
+ named_params(src.named_params),
+ parent(src.parent),
+- use_parent_values(use_parent_values)
++ use_parent_values(src.use_parent_values)
+ { }
+
+ /// returns the parent-object
+@@ -339,7 +339,7 @@ class QueryParams
+ if (i != named_params.end() && n < i->second.size())
+ return i->second[n];
+ else if (!useParentValues())
+- return def;
++ return std::string(def);
+ else
+ {
+ if (i != named_params.end())