aboutsummaryrefslogtreecommitdiff
path: root/devel/cxxtools
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2012-05-30 17:05:48 +0000
committerJuergen Lock <nox@FreeBSD.org>2012-05-30 17:05:48 +0000
commit9d2f45c991179fde26b0e286f628be4c6d670cf9 (patch)
tree6b03d12e1e6669712e4727304fac9c81348209c6 /devel/cxxtools
parentf8091dcb4659f2a05fb759d1e7d75c1be26825dd (diff)
downloadports-9d2f45c991179fde26b0e286f628be4c6d670cf9.tar.gz
ports-9d2f45c991179fde26b0e286f628be4c6d670cf9.zip
Notes
Diffstat (limited to 'devel/cxxtools')
-rw-r--r--devel/cxxtools/Makefile16
-rw-r--r--devel/cxxtools/pkg-plist5
2 files changed, 19 insertions, 2 deletions
diff --git a/devel/cxxtools/Makefile b/devel/cxxtools/Makefile
index dfd81ccc19f2..7f5db7482a3f 100644
--- a/devel/cxxtools/Makefile
+++ b/devel/cxxtools/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cxxtools
PORTVERSION= 2.1
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.tntnet.org/download/
@@ -26,5 +27,20 @@ MAKE_JOBS_SAFE= yes
.if ${ARCH} == "sparc64"
BROKEN= Does not configure on sparc64
.endif
+.if ${ARCH} == "amd64"
+PLIST_SUB+= X86_64_ONLY=""
+.else
+PLIST_SUB+= X86_64_ONLY="@comment "
+.endif
+.if ${ARCH} == "i386"
+PLIST_SUB+= I386_ONLY=""
+.else
+PLIST_SUB+= I386_ONLY="@comment "
+.endif
+.if (${ARCH} == "amd64") || (${ARCH} == "i386")
+PLIST_SUB+= X86_ONLY=""
+.else
+PLIST_SUB+= X86_ONLY="@comment "
+.endif
.include <bsd.port.post.mk>
diff --git a/devel/cxxtools/pkg-plist b/devel/cxxtools/pkg-plist
index d884dbf62ed9..4bf9ca3c5866 100644
--- a/devel/cxxtools/pkg-plist
+++ b/devel/cxxtools/pkg-plist
@@ -33,7 +33,8 @@ include/cxxtools/application.h
include/cxxtools/arg.h
include/cxxtools/argin.h
include/cxxtools/argout.h
-include/cxxtools/atomicity.gcc.x86_64.h
+%%X86_64_ONLY%%include/cxxtools/atomicity.gcc.x86_64.h
+%%I386_ONLY%%include/cxxtools/atomicity.gcc.x86.h
include/cxxtools/atomicity.h
include/cxxtools/base64codec.h
include/cxxtools/base64stream.h
@@ -124,7 +125,7 @@ include/cxxtools/md5.h
include/cxxtools/md5stream.h
include/cxxtools/membar.gcc.h
include/cxxtools/membar.gcc.nosmp.h
-include/cxxtools/membar.gcc.x86.h
+%%X86_ONLY%%include/cxxtools/membar.gcc.x86.h
include/cxxtools/membar.h
include/cxxtools/method.h
include/cxxtools/method.tpp