aboutsummaryrefslogtreecommitdiff
path: root/devel/dbus-glib
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
commitf1bb12de8e50bf76ae21f37debda60994ec7fd99 (patch)
tree1671d4beef381f12d939e34b344eb385a3af4f19 /devel/dbus-glib
parent29adee7bb42244f34736c5c24ed18a9b269d0925 (diff)
Notes
Diffstat (limited to 'devel/dbus-glib')
-rw-r--r--devel/dbus-glib/Makefile35
-rw-r--r--devel/dbus-glib/distinfo3
-rw-r--r--devel/dbus-glib/files/dbus-bus-introspect.xml77
-rw-r--r--devel/dbus-glib/files/patch-tools_run-with-tmp-session-bus.sh15
-rw-r--r--devel/dbus-glib/pkg-descr3
-rw-r--r--devel/dbus-glib/pkg-plist11
6 files changed, 144 insertions, 0 deletions
diff --git a/devel/dbus-glib/Makefile b/devel/dbus-glib/Makefile
new file mode 100644
index 000000000000..8644bd1c0800
--- /dev/null
+++ b/devel/dbus-glib/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: dbus-glib
+# Date Created: 07 October 2006
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dbus
+PORTVERSION= 0.71
+CATEGORIES= devel gnome
+MASTER_SITES= http://dbus.freedesktop.org/releases/dbus-glib/
+PKGNAMESUFFIX= -glib
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GLib bindings for the D-BUS messaging system
+
+LIB_DEPENDS= dbus-1.3:${PORTSDIR}/devel/dbus
+
+USE_GNOME= gnomehack glib20
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+CONFIGURE_ARGS= --with-test-socket-dir=${WRKDIR} \
+ --disable-doxygen-docs \
+ --disable-xml-docs
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
+PLIST_SUB= VERSION="1.0"
+
+pre-build:
+ @${CP} ${FILESDIR}/dbus-bus-introspect.xml ${WRKSRC}/tools
+
+.include <bsd.port.mk>
diff --git a/devel/dbus-glib/distinfo b/devel/dbus-glib/distinfo
new file mode 100644
index 000000000000..77979418b298
--- /dev/null
+++ b/devel/dbus-glib/distinfo
@@ -0,0 +1,3 @@
+MD5 (dbus-glib-0.71.tar.gz) = 4e1e7348b26ee8b6485452113f4221cc
+SHA256 (dbus-glib-0.71.tar.gz) = b58a489fdd35a70d241f512bc08f3b6d9d8e05110f4a1d5341cff6a0b7d854b7
+SIZE (dbus-glib-0.71.tar.gz) = 566889
diff --git a/devel/dbus-glib/files/dbus-bus-introspect.xml b/devel/dbus-glib/files/dbus-bus-introspect.xml
new file mode 100644
index 000000000000..889d1cfafc04
--- /dev/null
+++ b/devel/dbus-glib/files/dbus-bus-introspect.xml
@@ -0,0 +1,77 @@
+ <!DOCTYPE node PUBLIC "-//freedesktop//DTD D-BUS Object Introspection 1.0//EN"
+"http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd">
+<node>
+ <interface name="org.freedesktop.DBus.Introspectable">
+ <method name="Introspect">
+ <arg name="data" direction="out" type="s"/>
+ </method>
+ </interface>
+ <interface name="org.freedesktop.DBus">
+ <method name="RequestName">
+ <arg direction="in" type="s"/>
+ <arg direction="in" type="u"/>
+ <arg direction="out" type="u"/>
+ </method>
+ <method name="ReleaseName">
+ <arg direction="in" type="s"/>
+ <arg direction="out" type="u"/>
+ </method>
+ <method name="StartServiceByName">
+ <arg direction="in" type="s"/>
+ <arg direction="in" type="u"/>
+ <arg direction="out" type="u"/>
+ </method>
+ <method name="Hello">
+ <arg direction="out" type="s"/>
+ </method>
+ <method name="NameHasOwner">
+ <arg direction="in" type="s"/>
+ <arg direction="out" type="b"/>
+ </method>
+ <method name="ListNames">
+ <arg direction="out" type="as"/>
+ </method>
+ <method name="ListActivatableNames">
+ <arg direction="out" type="as"/>
+ </method>
+ <method name="AddMatch">
+ <arg direction="in" type="s"/>
+ </method>
+ <method name="RemoveMatch">
+ <arg direction="in" type="s"/>
+ </method>
+ <method name="GetNameOwner">
+ <arg direction="in" type="s"/>
+ <arg direction="out" type="s"/>
+ </method>
+ <method name="ListQueuedOwners">
+ <arg direction="in" type="s"/>
+ <arg direction="out" type="as"/>
+ </method>
+ <method name="GetConnectionUnixUser">
+ <arg direction="in" type="s"/>
+ <arg direction="out" type="u"/>
+ </method>
+ <method name="GetConnectionUnixProcessID">
+ <arg direction="in" type="s"/>
+ <arg direction="out" type="u"/>
+ </method>
+ <method name="GetConnectionSELinuxSecurityContext">
+ <arg direction="in" type="s"/>
+ <arg direction="out" type="ay"/>
+ </method>
+ <method name="ReloadConfig">
+ </method>
+ <signal name="NameOwnerChanged">
+ <arg type="s"/>
+ <arg type="s"/>
+ <arg type="s"/>
+ </signal>
+ <signal name="NameLost">
+ <arg type="s"/>
+ </signal>
+ <signal name="NameAcquired">
+ <arg type="s"/>
+ </signal>
+ </interface>
+</node>
diff --git a/devel/dbus-glib/files/patch-tools_run-with-tmp-session-bus.sh b/devel/dbus-glib/files/patch-tools_run-with-tmp-session-bus.sh
new file mode 100644
index 000000000000..4aa4e5a1893a
--- /dev/null
+++ b/devel/dbus-glib/files/patch-tools_run-with-tmp-session-bus.sh
@@ -0,0 +1,15 @@
+--- tools/run-with-tmp-session-bus.sh.orig Sat Oct 7 16:18:50 2006
++++ tools/run-with-tmp-session-bus.sh Sat Oct 7 16:19:24 2006
+@@ -1,10 +1,10 @@
+-#! /bin/bash
++#! /bin/sh
+
+ SCRIPTNAME=$0
+ WRAPPED_SCRIPT=$1
+ shift
+
+-function die()
++die()
+ {
+ if ! test -z "$DBUS_SESSION_BUS_PID" ; then
+ echo "killing message bus "$DBUS_SESSION_BUS_PID >&2
diff --git a/devel/dbus-glib/pkg-descr b/devel/dbus-glib/pkg-descr
new file mode 100644
index 000000000000..bc3c57d8fe62
--- /dev/null
+++ b/devel/dbus-glib/pkg-descr
@@ -0,0 +1,3 @@
+GLib bindings for the D-BUS interprocess messaging system.
+
+WWW: http://www.freedesktop.org/wiki/Software_2fDBusBindings
diff --git a/devel/dbus-glib/pkg-plist b/devel/dbus-glib/pkg-plist
new file mode 100644
index 000000000000..abc3049f93a5
--- /dev/null
+++ b/devel/dbus-glib/pkg-plist
@@ -0,0 +1,11 @@
+bin/dbus-binding-tool
+include/dbus-%%VERSION%%/dbus/dbus-glib-bindings.h
+include/dbus-%%VERSION%%/dbus/dbus-glib-error-enum.h
+include/dbus-%%VERSION%%/dbus/dbus-glib-lowlevel.h
+include/dbus-%%VERSION%%/dbus/dbus-glib.h
+include/dbus-%%VERSION%%/dbus/dbus-gtype-specialized.h
+lib/libdbus-glib-1.a
+lib/libdbus-glib-1.la
+lib/libdbus-glib-1.so
+lib/libdbus-glib-1.so.2
+libdata/pkgconfig/dbus-glib-1.pc