aboutsummaryrefslogtreecommitdiff
path: root/devel/dbus-qt4/Makefile
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-10-16 22:42:43 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-10-16 22:42:43 +0000
commit2300301988660bc50856e772eae46a2276b17ba4 (patch)
treefa03e2a64463a364674ce0e9ae16719e92fc6265 /devel/dbus-qt4/Makefile
parent4c23b4a38306f76e4313708936f3d277b200e9db (diff)
downloadports-2300301988660bc50856e772eae46a2276b17ba4.tar.gz
ports-2300301988660bc50856e772eae46a2276b17ba4.zip
Notes
Diffstat (limited to 'devel/dbus-qt4/Makefile')
-rw-r--r--devel/dbus-qt4/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/devel/dbus-qt4/Makefile b/devel/dbus-qt4/Makefile
index f0dc2c65a651..882cde4917c5 100644
--- a/devel/dbus-qt4/Makefile
+++ b/devel/dbus-qt4/Makefile
@@ -17,7 +17,7 @@ COMMENT= Qt4 bindings for the D-BUS messaging system
LIB_DEPENDS= dbus-1.3:${PORTSDIR}/devel/dbus
USE_QT_VER= 4
-QT_COMPONENTS= qmake_build moc_build rcc_build corelib gui xml
+QT_COMPONENTS= qmake_build moc_build rcc_build corelib xml
QT_NONSTANDARD= yes
QT_DIST= yes
MAKE_JOBS_UNSAFE= yes
@@ -48,9 +48,14 @@ INSTALL_WRKSRC= ${BUILD_WRKSRC}
EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
+.include <bsd.port.pre.mk>
+
+CONFIGURE_ARGS+= --no-gui \
+ --no-phonon
+
pre-configure:
- ${REINPLACE_CMD} -e 's|qdbusviewer||g' ${BUILD_WRKSRC}/qdbus.pro
- ${REINPLACE_CMD} -e 's|SUBDIRS = qdbus|SUBDIRS = ../../src/${PORTNAME} qdbus|g' ${BUILD_WRKSRC}/qdbus.pro
+ ${REINPLACE_CMD} -e 's|SUBDIRS = qdbus|SUBDIRS = ../../src/${PORTNAME} qdbus|g' \
+ ${BUILD_WRKSRC}/qdbus.pro
${REINPLACE_CMD} -e 's|"/moc"|"/moc-qt4"|' \
${BUILD_WRKSRC}/qdbuscpp2xml/qdbuscpp2xml.cpp
${MKDIR} ${WRKSRC}/mkspecs
@@ -64,4 +69,4 @@ post-configure:
-E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
${WRKSRC}/lib/pkgconfig/QtDBus.pc
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>