aboutsummaryrefslogtreecommitdiff
path: root/devel/dbus/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
commitf1bb12de8e50bf76ae21f37debda60994ec7fd99 (patch)
tree1671d4beef381f12d939e34b344eb385a3af4f19 /devel/dbus/Makefile
parent29adee7bb42244f34736c5c24ed18a9b269d0925 (diff)
Notes
Diffstat (limited to 'devel/dbus/Makefile')
-rw-r--r--devel/dbus/Makefile62
1 files changed, 16 insertions, 46 deletions
diff --git a/devel/dbus/Makefile b/devel/dbus/Makefile
index 47b86af15f4e..590c3fea87a4 100644
--- a/devel/dbus/Makefile
+++ b/devel/dbus/Makefile
@@ -6,88 +6,58 @@
#
PORTNAME= dbus
-PORTVERSION= 0.62
-PORTREVISION?= 1
-CATEGORIES?= devel gnome
+PORTVERSION?= 0.93
+PORTREVISION?= 2
+CATEGORIES= devel gnome
MASTER_SITES= http://dbus.freedesktop.org/releases/
-MAINTAINER?= gnome@FreeBSD.org
-COMMENT?= A message bus system for inter-application communication
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A message bus system for inter-application communication
-LIB_DEPENDS?= expat.6:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
-USE_GNOME?= gnomehack glib20 libxml2
+USE_GNOME= gnomehack gnometarget libxml2
USE_GMAKE= yes
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
-CONFIGURE_ARGS?=--disable-gtk \
- --disable-python \
- --disable-gcj \
- --disable-qt \
- --disable-mono \
- --disable-mono-docs \
- --localstatedir=/var \
+USE_LDCONFIG= yes
+CONFIGURE_ARGS=--localstatedir=/var \
+ --with-test-socket-dir=${WRKDIR} \
--with-system-pid-file=/var/run/dbus/dbus.pid \
--with-system-socket=/var/run/dbus/dbus.pipe \
--with-session-socket-dir=/var/tmp \
--disable-doxygen-docs \
--disable-xml-docs
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
.if !defined(DBUS_SLAVE)
USE_RC_SUBR= dbus
-OPTIONS= QT "Enable Qt client support" off
PLIST_SUB= VERSION="1.0"
MAN1= dbus-cleanup-sockets.1 dbus-daemon.1 dbus-launch.1 \
dbus-monitor.1 dbus-send.1
+
+.if !defined(WITHOUT_X11)
+USE_XLIB= yes
+.endif
.endif
.include <bsd.port.pre.mk>
-.if !defined(DBUS_SLAVE)
-.if defined(WITH_QT) && !defined(WITHOUT_QT)
-CONFIGURE_ARGS+=--enable-qt3
-CONFIGURE_ENV+= QTDIR=${X11BASE}
-LIB_DEPENDS+= qt-mt:${PORTSDIR}/x11-toolkits/qt33
-PLIST_SUB+= QT=""
-.else
-PLIST_SUB+= QT="@comment "
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|' \
${WRKSRC}/bus/session.conf.in \
${WRKSRC}/bus/system.conf.in
.if !defined(DBUS_SLAVE)
-pre-su-install:
- @for i in 15 9 ; do \
- if [ -f /var/run/dbus/dbus.pid ]; then \
- kill -$${i} $$(${CAT} /var/run/dbus/dbus.pid) 2>/dev/null || ${TRUE} ; \
- sleep 3 ; \
- fi ; \
- done
- @if [ -f /var/run/dbus/dbus.pid ]; then \
- ${RM} -f /var/run/dbus/dbus.pid ; \
- fi
-.endif
-
post-install:
.if !defined(PACKAGE_BUILDING)
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.endif
${MKDIR} ${X11BASE}/etc/dbus-1/system.d
${MKDIR} ${X11BASE}/share/dbus-1/services
-.else
-.if defined(PKGNAMEPREFIX)
-.if ${PKGNAMEPREFIX}==${PYTHON_PKGNAMEPREFIX} && ${OSVERSION} < 500000
-# Ignore for py-dbus
-IGNORE= does not build on 4.X
-.endif
-.endif
.endif