aboutsummaryrefslogtreecommitdiff
path: root/devel/dbus/Makefile
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2016-11-29 04:28:51 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2016-11-29 04:28:51 +0000
commit989e6d3b64b8b643f43cce66c7684be2b9690eb3 (patch)
tree41ff334ed2fbf344e84e893799dbe8e9fb681220 /devel/dbus/Makefile
parentdfda308daaa8607dc3bc165e144f934963026407 (diff)
downloadports-989e6d3b64b8b643f43cce66c7684be2b9690eb3.tar.gz
ports-989e6d3b64b8b643f43cce66c7684be2b9690eb3.zip
Notes
Diffstat (limited to 'devel/dbus/Makefile')
-rw-r--r--devel/dbus/Makefile23
1 files changed, 11 insertions, 12 deletions
diff --git a/devel/dbus/Makefile b/devel/dbus/Makefile
index 7ae49f128fc8..f01edbe23b15 100644
--- a/devel/dbus/Makefile
+++ b/devel/dbus/Makefile
@@ -2,29 +2,32 @@
# $FreeBSD$
PORTNAME= dbus
-PORTVERSION= 1.8.20
+PORTVERSION= 1.10.12
CATEGORIES= devel gnome
MASTER_SITES= http://dbus.freedesktop.org/releases/dbus/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Message bus system for inter-application communication
+LICENSE= GPLv2
+
LIB_DEPENDS= libexpat.so:textproc/expat2
PORTSCOUT= limitw:1,even
USE_GNOME= # empty but we need it for USE_GNOME_SUBR
-USES= cpe gmake libtool pathfix
+USES= cpe gmake libtool localbase pathfix
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS=--localstatedir=/var \
- --with-test-socket-dir=${WRKDIR} \
+CONFIGURE_ARGS= --localstatedir=/var \
+ --with-test-socket-dir=${WRKDIR} \
--with-system-pid-file=/var/run/dbus/dbus.pid \
--with-system-socket=/var/run/dbus/system_bus_socket \
--with-session-socket-dir=/tmp \
- --disable-doxygen-docs
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+ --disable-doxygen-docs \
+ --disable-selinux \
+ --disable-apparmor \
+ --disable-systemd
INSTALL_TARGET= install-strip
CPE_VENDOR= d-bus_project
@@ -57,15 +60,11 @@ post-patch:
${WRKSRC}/dbus/Makefile.in \
${WRKSRC}/tools/Makefile.in
@${REINPLACE_CMD} '/^SUBDIRS/,/^$$/ s|test||g' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's|THREAD_LIBS -lrt|THREAD_LIBS|g ; \
- s|dummy man2html|dummy man2html_disable|g' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|install-data-am: install-data-local|install-data-am:|g' \
- ${WRKSRC}/tools/Makefile.in
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/share/dbus-1/interfaces
@${MKDIR} ${STAGEDIR}/var/run/dbus
@${MKDIR} ${STAGEDIR}/var/db/dbus
+ @${RMDIR} ${STAGEDIR}/var/lib/dbus ${STAGEDIR}/var/lib
.include <bsd.port.mk>