aboutsummaryrefslogtreecommitdiff
path: root/devel/dbus
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2009-09-06 21:18:50 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2009-09-06 21:18:50 +0000
commit80ce349ead781fafb5528d69310848254d4afbf8 (patch)
tree9e4543908f3bf06a3af78267b4523928d41925b9 /devel/dbus
parent082f117cfc49edb878d4e17e43719ab6e461af0b (diff)
Notes
Diffstat (limited to 'devel/dbus')
-rw-r--r--devel/dbus/Makefile5
-rw-r--r--devel/dbus/pkg-install27
2 files changed, 4 insertions, 28 deletions
diff --git a/devel/dbus/Makefile b/devel/dbus/Makefile
index 6b9dffbe4eb5..39c8a33cf3f1 100644
--- a/devel/dbus/Makefile
+++ b/devel/dbus/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dbus
PORTVERSION?= 1.2.4.6
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= devel gnome
MASTER_SITES= http://dbus.freedesktop.org/releases/dbus/
DISTNAME= dbus-${PORTVERSION}permissive
@@ -36,6 +36,9 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
USE_RC_SUBR= dbus
USE_GNOME_SUBR= yes
+USERS= messagebus
+GROUPS= messagebus
+
PLIST_SUB= VERSION="1.0"
MAN1= dbus-cleanup-sockets.1 dbus-daemon.1 dbus-launch.1 \
diff --git a/devel/dbus/pkg-install b/devel/dbus/pkg-install
index 4ed46afa771a..5ad0a1f8429c 100644
--- a/devel/dbus/pkg-install
+++ b/devel/dbus/pkg-install
@@ -4,33 +4,6 @@ case $2 in
POST-INSTALL)
USER=messagebus
GROUP=${USER}
- UID=556
- GID=${UID}
- PW=/usr/sbin/pw
-
- if ${PW} group show "${GROUP}" 2>/dev/null; then
- echo "You already have a group \"${GROUP}\", so I will use it."
- else
- if ${PW} groupadd ${GROUP} -g ${GID}; then
- echo "Added group \"${GROUP}\"."
- else
- echo "Adding group \"${GROUP}\" failed..."
- exit 1
- fi
- fi
-
- if ${PW} user show "${USER}" 2>/dev/null; then
- echo "You already have a user \"${USER}\", so I will use it."
- else
- if ${PW} useradd ${USER} -u ${UID} -g ${GROUP} -h - \
- -d "/nonexistent" -s /sbin/nologin -c "D-BUS Daemon User"
- then
- echo "Added user \"${USER}\"."
- else
- echo "Adding user \"${USER}\" failed..."
- exit 1
- fi
- fi
/usr/bin/install -d -o ${USER} -g ${GROUP} /var/run/dbus
/usr/bin/install -d -o ${USER} -g ${GROUP} /var/db/dbus