aboutsummaryrefslogtreecommitdiff
path: root/devel/dbus
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-08-08 18:01:16 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-08-08 18:01:16 +0000
commit29a2d8d1ee54d35a673419e4a947bf4c16d324ea (patch)
treeb16f647b70d2a63e0aae6739c47343df3ba1c3cc /devel/dbus
parent2a6028f8bebe86bb61d803503843a75ba58d1f67 (diff)
downloadports-29a2d8d1ee54d35a673419e4a947bf4c16d324ea.tar.gz
ports-29a2d8d1ee54d35a673419e4a947bf4c16d324ea.zip
Notes
Diffstat (limited to 'devel/dbus')
-rw-r--r--devel/dbus/Makefile2
-rw-r--r--devel/dbus/files/patch-python_Makefile.in8
-rw-r--r--devel/dbus/files/patch-python_dbus_bindings.pyx.in6
3 files changed, 9 insertions, 7 deletions
diff --git a/devel/dbus/Makefile b/devel/dbus/Makefile
index 5d80cbbb76f9..8a1cb0649de4 100644
--- a/devel/dbus/Makefile
+++ b/devel/dbus/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dbus
PORTVERSION= 0.21
-PORTREVISION= 2
+PORTREVISION?= 2
CATEGORIES?= devel gnome
MASTER_SITES= http://freedesktop.org/Software/dbus/releases/
diff --git a/devel/dbus/files/patch-python_Makefile.in b/devel/dbus/files/patch-python_Makefile.in
index 7f0b73baeec3..dc0843814061 100644
--- a/devel/dbus/files/patch-python_Makefile.in
+++ b/devel/dbus/files/patch-python_Makefile.in
@@ -1,11 +1,11 @@
---- python/Makefile.in.orig Sun Jul 25 03:19:00 2004
-+++ python/Makefile.in Sun Jul 25 03:19:40 2004
+--- python/Makefile.in.orig Sun Aug 8 13:53:50 2004
++++ python/Makefile.in Sun Aug 8 13:57:05 2004
@@ -237,7 +237,7 @@
dbusbindings_LTLIBRARIES = dbus_bindings.la
dbus_bindings_la_LDFLAGS = -module -avoid-version -fPIC -export-symbols-regex initdbus_bindings
-dbus_bindings_la_LIBADD = $(top_builddir)/dbus/libdbus-1.la $(top_builddir)/glib/libdbus-glib-1.la
-+dbus_bindings_la_LIBADD =
++dbus_bindings_la_LIBADD = -ldbus-1 -ldbus-glib-1
nodist_dbus_bindings_la_SOURCES = dbus_bindings.c
EXTRA_DIST = \
@@ -15,7 +15,7 @@
-dbus_bindings_la_DEPENDENCIES = $(top_builddir)/dbus/libdbus-1.la \
- $(top_builddir)/glib/libdbus-glib-1.la
-+dbus_bindings_la_DEPENDENCIES =
++dbus_bindings_la_DEPENDENCIES = -ldbus-1 -ldbus-glib-1
nodist_dbus_bindings_la_OBJECTS = dbus_bindings.lo
dbus_bindings_la_OBJECTS = $(nodist_dbus_bindings_la_OBJECTS)
diff --git a/devel/dbus/files/patch-python_dbus_bindings.pyx.in b/devel/dbus/files/patch-python_dbus_bindings.pyx.in
index 821eb96d3698..4b3d4232c3ab 100644
--- a/devel/dbus/files/patch-python_dbus_bindings.pyx.in
+++ b/devel/dbus/files/patch-python_dbus_bindings.pyx.in
@@ -1,10 +1,12 @@
--- python/dbus_bindings.pyx.in.orig Tue Oct 28 19:06:07 2003
-+++ python/dbus_bindings.pyx.in Sun Jul 25 03:17:42 2004
-@@ -1,5 +1,11 @@
++++ python/dbus_bindings.pyx.in Sun Aug 8 13:52:34 2004
+@@ -1,5 +1,13 @@
# -*- Mode: Python -*-
+cdef extern from "sys/types.h":
+ ctypedef size_t
++ ctypedef __int64_t
++ ctypedef __uint64_t
+
+cdef extern from "sys/cdefs.h":
+ ctypedef __signed