aboutsummaryrefslogtreecommitdiff
path: root/devel/dbus
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-12-31 18:43:11 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-12-31 18:43:11 +0000
commita669dc1c3c9825a7841a83b8b367054abdffe961 (patch)
treeca805ad00c1432766c34b583349bf3f1cf269b75 /devel/dbus
parentdff72ba61fa8f0a32f615f06dbeafd7362681abc (diff)
downloadports-a669dc1c3c9825a7841a83b8b367054abdffe961.tar.gz
ports-a669dc1c3c9825a7841a83b8b367054abdffe961.zip
Notes
Diffstat (limited to 'devel/dbus')
-rw-r--r--devel/dbus/Makefile9
-rw-r--r--devel/dbus/distinfo6
-rw-r--r--devel/dbus/files/dbus.in1
-rw-r--r--devel/dbus/files/dbus.sh1
-rw-r--r--devel/dbus/files/patch-configure49
-rw-r--r--devel/dbus/files/patch-dbus_dbus-sysdeps.c26
-rw-r--r--devel/dbus/pkg-plist6
7 files changed, 48 insertions, 50 deletions
diff --git a/devel/dbus/Makefile b/devel/dbus/Makefile
index 087851ffaa27..4a34b55e8064 100644
--- a/devel/dbus/Makefile
+++ b/devel/dbus/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= dbus
-PORTVERSION= 0.50
-PORTREVISION?= 1
+PORTVERSION= 0.60
+PORTREVISION?= 0
CATEGORIES?= devel gnome
MASTER_SITES= http://dbus.freedesktop.org/releases/
@@ -26,6 +26,7 @@ USE_REINPLACE= yes
CONFIGURE_ARGS?=--disable-gtk \
--disable-python \
--disable-gcj \
+ --disable-qt \
--disable-mono \
--disable-mono-docs \
--with-system-pid-file=/var/run/dbus.pid \
@@ -50,12 +51,11 @@ MAN1= dbus-cleanup-sockets.1 dbus-daemon.1 dbus-launch.1 \
.if !defined(DBUS_SLAVE)
.if defined(WITH_QT) && !defined(WITHOUT_QT)
-CONFIGURE_ARGS+=--enable-qt
+CONFIGURE_ARGS+=--enable-qt3
CONFIGURE_ENV+= QTDIR=${X11BASE}
LIB_DEPENDS+= qt-mt:${PORTSDIR}/x11-toolkits/qt33
PLIST_SUB+= QT=""
.else
-CONFIGURE_ARGS+=--disable-qt
PLIST_SUB+= QT="@comment "
.endif
@@ -76,6 +76,7 @@ post-install:
.else
.if defined(PKGNAMEPREFIX)
.if ${PKGNAMEPREFIX}==${PYTHON_PKGNAMEPREFIX} && ${OSVERSION} < 500000
+# Ignore for py-dbus
IGNORE= Does not build on 4.X
.endif
.endif
diff --git a/devel/dbus/distinfo b/devel/dbus/distinfo
index 1f7aa4914318..e4fdce7137ec 100644
--- a/devel/dbus/distinfo
+++ b/devel/dbus/distinfo
@@ -1,3 +1,3 @@
-MD5 (dbus-0.50.tar.gz) = 1addd5b600a8a4550766005d1f59401b
-SHA256 (dbus-0.50.tar.gz) = 3a8375c935f0c7b87cdd25f0408da963836fdce23390bb1b81cc6bd6ee7951c5
-SIZE (dbus-0.50.tar.gz) = 1610305
+MD5 (dbus-0.60.tar.gz) = da9561b5e579cedddc34f53427e99a93
+SHA256 (dbus-0.60.tar.gz) = 32ff1b1c7388cd2bfd4a23d4b9f460b2265579f1e097f0d4c0261c7e00adf8a8
+SIZE (dbus-0.60.tar.gz) = 1674899
diff --git a/devel/dbus/files/dbus.in b/devel/dbus/files/dbus.in
index a9b4ff8085fd..704cb1d7eb92 100644
--- a/devel/dbus/files/dbus.in
+++ b/devel/dbus/files/dbus.in
@@ -4,7 +4,6 @@
#
# PROVIDE: dbus
# REQUIRE: DAEMON
-# KEYWORD: FreeBSD
#
# Add the following lines to /etc/rc.conf to enable the D-BUS messaging system:
#
diff --git a/devel/dbus/files/dbus.sh b/devel/dbus/files/dbus.sh
index a9b4ff8085fd..704cb1d7eb92 100644
--- a/devel/dbus/files/dbus.sh
+++ b/devel/dbus/files/dbus.sh
@@ -4,7 +4,6 @@
#
# PROVIDE: dbus
# REQUIRE: DAEMON
-# KEYWORD: FreeBSD
#
# Add the following lines to /etc/rc.conf to enable the D-BUS messaging system:
#
diff --git a/devel/dbus/files/patch-configure b/devel/dbus/files/patch-configure
index 939993882fef..1384e3e1acd9 100644
--- a/devel/dbus/files/patch-configure
+++ b/devel/dbus/files/patch-configure
@@ -1,14 +1,14 @@
---- configure.orig Sun Sep 11 15:30:46 2005
-+++ configure Sun Sep 11 15:30:46 2005
-@@ -1059,6 +1059,7 @@
- optimize for fast installation [default=yes]
- --disable-libtool-lock avoid locking (might break parallel builds)
- --disable-dnotify Disable using dnotify on Linux
-+ --disable-kqueue Disable using kqueue on FreeBSD
-
- Optional Packages:
- --with-PACKAGE[=ARG] use PACKAGE [ARG=yes]
-@@ -4485,7 +4486,7 @@
+--- configure.orig Sat Dec 31 13:22:23 2005
++++ configure Sat Dec 31 13:30:51 2005
+@@ -1053,6 +1053,7 @@
+ --enable-python build python bindings
+ --enable-selinux build with SELinux support
+ --enable-dnotify build with dnotify support (linux only)
++ --enable-kqueue build with kqueue support (FreeBSD only)
+ --enable-shared[=PKGS]
+ build shared libraries [default=yes]
+ --enable-static[=PKGS]
+@@ -4500,7 +4501,7 @@
case " $CFLAGS " in
*[\ \ ]-Wfloat-equal[\ \ ]*) ;;
@@ -17,7 +17,7 @@
esac
case " $CFLAGS " in
-@@ -28088,6 +28089,32 @@
+@@ -28240,6 +28241,31 @@
cat >>confdefs.h <<\_ACEOF
#define DBUS_BUS_ENABLE_DNOTIFY_ON_LINUX 1
@@ -29,21 +29,20 @@
+case "${target_os}" in
+ freebsd*)
+ # Check whether --enable-kqueue or --disable-kqueue was given.
-+if test "${enable_kqueue+set}" = set; then
-+ enableval="$enable_kqueue"
-+ case "${enableval}" in
-+ yes) kqueue=false ;;
-+ no) kqueue=true ;;
-+ *) { { echo "$as_me:$LINENO: error: bad value ${enableval} for --disable-kqueue" >&5
-+echo "$as_me: error: bad value ${enableval} for --disable-kqueue" >&2;}
-+ { (exit 1); exit 1; }; } ;;
-+ esac
-+else
-+ kqueue=true
-+fi;
++ if test "${enable_kqueue+set}" = set; then
++ enableval="$enable_kqueue"
++ enable_kqueue=$enableval
++ else
++ enable_kqueue=auto
++ fi;
++ if test x$enable_kqueue = xno ; then
++ have_kqueue=no;
++ else
++ have_kqueue=yes;
++ fi
+;;
+esac
-+if test x$kqueue = xtrue; then
++if test x$have_kqueue = xyes; then
+
+cat >>confdefs.h <<\_ACEOF
+#define DBUS_BUS_ENABLE_KQUEUE_ON_FREEBSD 1
diff --git a/devel/dbus/files/patch-dbus_dbus-sysdeps.c b/devel/dbus/files/patch-dbus_dbus-sysdeps.c
index 66c5480d7908..d7182118603b 100644
--- a/devel/dbus/files/patch-dbus_dbus-sysdeps.c
+++ b/devel/dbus/files/patch-dbus_dbus-sysdeps.c
@@ -1,6 +1,6 @@
---- dbus/dbus-sysdeps.c.orig Wed Aug 3 13:42:56 2005
-+++ dbus/dbus-sysdeps.c Wed Aug 24 00:36:20 2005
-@@ -742,16 +742,16 @@ write_credentials_byte (int
+--- dbus/dbus-sysdeps.c.orig Tue Nov 22 15:37:00 2005
++++ dbus/dbus-sysdeps.c Sat Dec 31 13:08:04 2005
+@@ -781,16 +781,16 @@ write_credentials_byte (int
{
int bytes_written;
char buf[1] = { '\0' };
@@ -21,7 +21,7 @@
iov.iov_base = buf;
iov.iov_len = 1;
-@@ -759,10 +759,10 @@ write_credentials_byte (int
+@@ -798,10 +798,10 @@ write_credentials_byte (int
msg.msg_iov = &iov;
msg.msg_iovlen = 1;
@@ -35,7 +35,7 @@
cmsg.hdr.cmsg_level = SOL_SOCKET;
cmsg.hdr.cmsg_type = SCM_CREDS;
#endif
-@@ -771,7 +771,7 @@ write_credentials_byte (int
+@@ -810,7 +810,7 @@ write_credentials_byte (int
again:
@@ -44,7 +44,7 @@
bytes_written = sendmsg (server_fd, &msg, 0);
#else
bytes_written = write (server_fd, buf, 1);
-@@ -829,9 +829,10 @@ _dbus_read_credentials_unix_socket (int
+@@ -868,9 +868,10 @@ _dbus_read_credentials_unix_socket (int
char buf;
#ifdef HAVE_CMSGCRED
@@ -57,7 +57,7 @@
} cmsg;
#endif
-@@ -847,7 +848,7 @@ _dbus_read_credentials_unix_socket (int
+@@ -886,7 +887,7 @@ _dbus_read_credentials_unix_socket (int
_dbus_credentials_clear (credentials);
@@ -66,7 +66,7 @@
/* Set the socket to receive credentials on the next message */
{
int on = 1;
-@@ -868,8 +869,8 @@ _dbus_read_credentials_unix_socket (int
+@@ -907,8 +908,8 @@ _dbus_read_credentials_unix_socket (int
#ifdef HAVE_CMSGCRED
memset (&cmsg, 0, sizeof (cmsg));
@@ -77,7 +77,7 @@
#endif
again:
-@@ -892,7 +893,8 @@ _dbus_read_credentials_unix_socket (int
+@@ -931,7 +932,8 @@ _dbus_read_credentials_unix_socket (int
}
#ifdef HAVE_CMSGCRED
@@ -87,7 +87,7 @@
{
dbus_set_error (error, DBUS_ERROR_FAILED,
"Message from recvmsg() was not SCM_CREDS");
-@@ -920,9 +922,10 @@ _dbus_read_credentials_unix_socket (int
+@@ -959,9 +961,10 @@ _dbus_read_credentials_unix_socket (int
cr_len, (int) sizeof (cr), _dbus_strerror (errno));
}
#elif defined(HAVE_CMSGCRED)
@@ -98,6 +98,6 @@
+ credentials->pid = cred->cmcred_pid;
+ credentials->uid = cred->cmcred_euid;
+ credentials->gid = cred->cmcred_groups[0];
- #else /* !SO_PEERCRED && !HAVE_CMSGCRED */
- _dbus_verbose ("Socket credentials not supported on this OS\n");
- #endif
+ #elif defined(HAVE_GETPEEREID)
+ uid_t euid;
+ gid_t egid;
diff --git a/devel/dbus/pkg-plist b/devel/dbus/pkg-plist
index fb1e7e23a440..54bedc86c8cf 100644
--- a/devel/dbus/pkg-plist
+++ b/devel/dbus/pkg-plist
@@ -33,13 +33,13 @@ include/dbus-%%VERSION%%/dbus/dbus.h
include/dbus-%%VERSION%%/include/dbus/dbus-arch-deps.h
lib/libdbus-1.a
lib/libdbus-1.so
-lib/libdbus-1.so.1
+lib/libdbus-1.so.2
lib/libdbus-glib-1.a
lib/libdbus-glib-1.so
-lib/libdbus-glib-1.so.1
+lib/libdbus-glib-1.so.2
%%QT%%lib/libdbus-qt-1.a
%%QT%%lib/libdbus-qt-1.so
-%%QT%%lib/libdbus-qt-1.so.1
+%%QT%%lib/libdbus-qt-1.so.2
libdata/pkgconfig/dbus-1.pc
libdata/pkgconfig/dbus-glib-1.pc
@exec mkdir -p %D/etc/dbus-1/system.d