aboutsummaryrefslogtreecommitdiff
path: root/devel/dep
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-01-14 17:24:54 +0000
committerSteve Wills <swills@FreeBSD.org>2018-01-14 17:24:54 +0000
commit96c93430c459b6dacf22a004a03092f6fa952b67 (patch)
tree55706a105575192aeec374e20dafcd038cb916d6 /devel/dep
parentb0c363fe934b59698233b8808cd0b53e2033322d (diff)
downloadports-96c93430c459b6dacf22a004a03092f6fa952b67.tar.gz
ports-96c93430c459b6dacf22a004a03092f6fa952b67.zip
Notes
Diffstat (limited to 'devel/dep')
-rw-r--r--devel/dep/Makefile24
-rw-r--r--devel/dep/distinfo3
-rw-r--r--devel/dep/pkg-descr9
3 files changed, 36 insertions, 0 deletions
diff --git a/devel/dep/Makefile b/devel/dep/Makefile
new file mode 100644
index 000000000000..9bcd3d78a08e
--- /dev/null
+++ b/devel/dep/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= dep
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.3.2
+CATEGORIES= devel
+
+MAINTAINER= sam.gwydir@joyent.com
+COMMENT= Prototype dependency management tool for Go
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go
+
+USE_GITHUB= yes
+GH_ACCOUNT= golang
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
+GO_TARGET= github.com/${GH_ACCOUNT}/${PORTNAME}/cmd/dep
+
+PLIST_FILES= bin/dep
+
+.include <bsd.port.mk>
diff --git a/devel/dep/distinfo b/devel/dep/distinfo
new file mode 100644
index 000000000000..d3515af06462
--- /dev/null
+++ b/devel/dep/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1512082160
+SHA256 (golang-dep-v0.3.2_GH0.tar.gz) = 327124953d76293eaba6001e17bb8a31371313ab39eed1fa9eac01f8b5c1de21
+SIZE (golang-dep-v0.3.2_GH0.tar.gz) = 4683014
diff --git a/devel/dep/pkg-descr b/devel/dep/pkg-descr
new file mode 100644
index 000000000000..3fe28e4fa553
--- /dev/null
+++ b/devel/dep/pkg-descr
@@ -0,0 +1,9 @@
+Dep is a Go tool for managing vendor dependencies (not to be confused
+with godep, a different, deprecated tool). dep updates the vendor/
+directory contents based on a manifest, prunes unnecessary dependencies,
+and adds missing dependencies to vendor/ as necessary.
+
+dep is the heir-apparent for vendor management and is being actively
+driven by the Go core team with an eye toward inclusion in the Go tool.
+
+WWW: https://github.com/golang/dep