aboutsummaryrefslogtreecommitdiff
path: root/devel/deputy/files
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-04-11 13:23:05 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-04-11 13:23:05 +0000
commitc6762e80516b169cd71a8d7e68d0ed5b308f7e55 (patch)
treef23cbb8b9252353d844bff7e183b8b588e997854 /devel/deputy/files
parent3b03d918066c823f39536b8d108d1145c833a3dd (diff)
Notes
Diffstat (limited to 'devel/deputy/files')
-rw-r--r--devel/deputy/files/patch-cil-Makefile.in27
1 files changed, 25 insertions, 2 deletions
diff --git a/devel/deputy/files/patch-cil-Makefile.in b/devel/deputy/files/patch-cil-Makefile.in
index 3133b4902f04..5ade88951148 100644
--- a/devel/deputy/files/patch-cil-Makefile.in
+++ b/devel/deputy/files/patch-cil-Makefile.in
@@ -1,5 +1,14 @@
---- cil/Makefile.in.orig Fri Mar 16 17:10:11 2007
-+++ cil/Makefile.in Fri Mar 16 17:10:16 2007
+--- cil/Makefile.in.orig 2007-02-02 15:22:17.000000000 +0300
++++ cil/Makefile.in 2009-04-11 00:18:21.000000000 +0400
+@@ -210,7 +210,7 @@
+ # build two libraries
+ .PHONY: cillib libcil
+ ifeq ($(NATIVECAML),1)
+-cillib: $(OBJDIR)/cil.$(CMXA) $(OBJDIR)/libcil.a
++cillib: $(OBJDIR)/cil.$(CMXA) $(OBJDIR)/libcil.o
+ else
+ cillib: $(OBJDIR)/cil.$(CMXA)
+ endif
@@ -236,7 +236,7 @@
endif
# Now the extra features, with the first letter capitalized
@@ -9,3 +18,17 @@
$(foreach f,@EXTRAFEATURES@, \
"\n "`echo $f | cut -c 1 | tr "[a-z]" "[A-Z]"``echo $f | cut -c 2-`".feature;") >> $@
echo "]" >>$@
+@@ -267,11 +267,11 @@
+ # be called from C code; this is like the target above, except
+ # it is callable from C instead of from Ocaml
+ ifeq ($(NATIVECAML),1)
+-$(OBJDIR)/libcil.a: $(OCAML_CIL_LIB_CMODULES:%=$(OBJDIR)/lib%.a) \
++$(OBJDIR)/libcil.o: $(OCAML_CIL_LIB_CMODULES:%=$(OBJDIR)/lib%.a) \
+ $(OCAML_CIL_LIB_MODULES:%=$(OBJDIR)/%.$(CMO))
+ ocamlopt -output-obj -o $@ $(CILLY_LIBS:%=%.cmxa) $^
+ else
+-$(OBJDIR)/libcil.a:
++$(OBJDIR)/libcil.o:
+ @echo "Can only build $@ when NATIVECAML is 1."
+ exit 2
+ endif