aboutsummaryrefslogtreecommitdiff
path: root/devel/desktop-file-utils/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-07-25 06:30:39 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-07-25 06:30:39 +0000
commit17b081513772a5290fc7e7b58f02019a5805ed1e (patch)
tree3594c34f2ae17e80c51bc5fd77e99d37e29eb24b /devel/desktop-file-utils/Makefile
parentbf22500589c4855ebdfa9a82c5efad3d2224cdde (diff)
downloadports-17b081513772a5290fc7e7b58f02019a5805ed1e.tar.gz
ports-17b081513772a5290fc7e7b58f02019a5805ed1e.zip
Notes
Diffstat (limited to 'devel/desktop-file-utils/Makefile')
-rw-r--r--devel/desktop-file-utils/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/devel/desktop-file-utils/Makefile b/devel/desktop-file-utils/Makefile
index fc7294083a09..570a6895c23e 100644
--- a/devel/desktop-file-utils/Makefile
+++ b/devel/desktop-file-utils/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= desktop-file-utils
-PORTVERSION= 0.6
+PORTVERSION= 0.7
CATEGORIES= devel
MASTER_SITES= http://freedesktop.org/Software/desktop-file-utils/releases/
@@ -21,8 +21,10 @@ USE_X_PREFIX= yes
USE_GNOME= glib20
WANT_GNOME= yes
-GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_LIBTOOL_VER= 15
+CONFIGURE_ARGS= --with-lispdir=${PREFIX}/share/emacs/site-lisp
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -35,4 +37,14 @@ PLIST_SUB+= GNOME_VFS=""
PLIST_SUB+= GNOME_VFS="@comment "
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g ; \
+ s|%%X11BASE%%|${X11BASE}|g' \
+ ${WRKSRC}/src/eggdirfuncs.c
+
+post-install:
+.if !defined(PACKAGE_BUILDING)
+ -@${PREFIX}/bin/update-desktop-database -q
+.endif
+
.include <bsd.port.post.mk>