aboutsummaryrefslogtreecommitdiff
path: root/devel/dia2code
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-03-07 04:17:49 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-03-07 04:17:49 +0000
commit356b628722a89d486f4cf4b98799b603319cfd95 (patch)
treee9937428e2c876473bf9152808538af7e656fafe /devel/dia2code
parentc9f58b01cb81735fc2d7539f2e5e139809fa2a10 (diff)
downloadports-356b628722a89d486f4cf4b98799b603319cfd95.tar.gz
ports-356b628722a89d486f4cf4b98799b603319cfd95.zip
Notes
Diffstat (limited to 'devel/dia2code')
-rw-r--r--devel/dia2code/Makefile28
-rw-r--r--devel/dia2code/distinfo1
-rw-r--r--devel/dia2code/files/patch-dia2code::Makefile.in20
-rw-r--r--devel/dia2code/pkg-comment1
-rw-r--r--devel/dia2code/pkg-descr15
-rw-r--r--devel/dia2code/pkg-plist1
6 files changed, 66 insertions, 0 deletions
diff --git a/devel/dia2code/Makefile b/devel/dia2code/Makefile
new file mode 100644
index 000000000000..80235b596e06
--- /dev/null
+++ b/devel/dia2code/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# New ports collection makefile for: dia2code
+# Date created: Mar 7, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dia2code
+PORTVERSION= 0.5
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+LIB_DEPENDS= xml.5:${PORTSDIR}/textproc/libxml
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+
+XML_CONFIG= ${LOCALBASE}/bin/xml-config
+USE_GMAKE= yes
+
+post-patch:
+ @${PERL} -pi -e "s|%%XML_CONFIG%%|${XML_CONFIG}|g" ${WRKSRC}/dia2code/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/devel/dia2code/distinfo b/devel/dia2code/distinfo
new file mode 100644
index 000000000000..cebfbd1b8a63
--- /dev/null
+++ b/devel/dia2code/distinfo
@@ -0,0 +1 @@
+MD5 (dia2code-0.5.tar.gz) = 5cea69ebb58c3b5c262850a86cd98d9d
diff --git a/devel/dia2code/files/patch-dia2code::Makefile.in b/devel/dia2code/files/patch-dia2code::Makefile.in
new file mode 100644
index 000000000000..de86682c5a27
--- /dev/null
+++ b/devel/dia2code/files/patch-dia2code::Makefile.in
@@ -0,0 +1,20 @@
+--- dia2code/Makefile.in.orig Wed Jan 24 04:43:08 2001
++++ dia2code/Makefile.in Wed Mar 7 11:56:58 2001
+@@ -68,7 +68,7 @@
+ ####### kdevelop will overwrite this part!!! (end)############
+ bin_PROGRAMS = dia2code
+ dia2code_SOURCES = scan_tree.c generate_code_c.c parse_diagram.c dia2code.c generate_code_java.c generate_code_cpp.c main.c
+-dia2code_LDADD = -lxml
++dia2code_LDADD = `%%XML_CONFIG%% --libs`
+
+ SUBDIRS = docs
+
+@@ -79,7 +79,7 @@
+ PROGRAMS = $(bin_PROGRAMS)
+
+
+-DEFS = @DEFS@ -I. -I$(srcdir) -I..
++DEFS = @DEFS@ -I. -I$(srcdir) -I.. -I/usr/local/include
+ CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
diff --git a/devel/dia2code/pkg-comment b/devel/dia2code/pkg-comment
new file mode 100644
index 000000000000..3f4339dad70d
--- /dev/null
+++ b/devel/dia2code/pkg-comment
@@ -0,0 +1 @@
+Dia2Code is a small utility used to generate code from a Dia diagram
diff --git a/devel/dia2code/pkg-descr b/devel/dia2code/pkg-descr
new file mode 100644
index 000000000000..d7de8fa841f3
--- /dev/null
+++ b/devel/dia2code/pkg-descr
@@ -0,0 +1,15 @@
+Dia2Code is a small utility used to generate code from a Dia diagram.
+Dia is a program to make diagrams (ports/graphics/dia)
+
+ - Reads UML diagrams.
+ - Can handle UML - Generalization, UML - Realization and UML - Implements.
+ - Selective code generation.
+ - User-defined output directory.
+ - Stereotype handling: interfaces, abstract classes.
+ - "Import" and "include" based on the parent classes, the type of
+ attributes and return type of methods iff they're declared in the same
+ diagram.
+ - Support for JavaBeans(tm): will create automagically methods to access
+ and modify each attribute.
+
+WWW: http://dia2code.sourceforge.net/
diff --git a/devel/dia2code/pkg-plist b/devel/dia2code/pkg-plist
new file mode 100644
index 000000000000..c681af4d0b33
--- /dev/null
+++ b/devel/dia2code/pkg-plist
@@ -0,0 +1 @@
+bin/dia2code