aboutsummaryrefslogtreecommitdiff
path: root/devel/directfb
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-12-08 14:46:02 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-12-08 14:46:02 +0000
commit03073bc4da76524c553597c54279b1e6276175c5 (patch)
treecbfe11af4aaf0d0f6a0acb8180613e2efa26db6d /devel/directfb
parent00739148803059dc009150af583bf4ca56c34de8 (diff)
downloadports-03073bc4da76524c553597c54279b1e6276175c5.tar.gz
ports-03073bc4da76524c553597c54279b1e6276175c5.zip
Notes
Diffstat (limited to 'devel/directfb')
-rw-r--r--devel/directfb/Makefile51
-rw-r--r--devel/directfb/distinfo5
-rw-r--r--devel/directfb/files/patch-configure10
-rw-r--r--devel/directfb/files/patch-idirectfbimageprovider_png.c38
-rw-r--r--devel/directfb/files/patch-lib-direct-log.c8
-rw-r--r--devel/directfb/files/patch-lib-voodoo-client.c14
-rw-r--r--devel/directfb/files/patch-lib-voodoo-manager.c14
-rw-r--r--devel/directfb/files/patch-src-misc-conf.h11
-rw-r--r--devel/directfb/files/patch-tests__voodoo__voodoo_test.h13
-rw-r--r--devel/directfb/files/patch-tools-fusion_bench.c26
-rw-r--r--devel/directfb/pkg-plist19
11 files changed, 87 insertions, 122 deletions
diff --git a/devel/directfb/Makefile b/devel/directfb/Makefile
index 4436bab767e4..89c757058f6e 100644
--- a/devel/directfb/Makefile
+++ b/devel/directfb/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= directfb
-PORTVERSION= 1.4.3
+PORTVERSION= 1.4.11
CATEGORIES= devel
MASTER_SITES= http://www.directfb.org/downloads/Core/${DISTNAME:R}/
DISTNAME= DirectFB-${PORTVERSION}
@@ -17,6 +17,9 @@ COMMENT= Graphic development lightweight API
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
png.6:${PORTSDIR}/graphics/png
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
OPTIONS= FREETYPE2 "Enable Freetype support" on \
X11 "Enable X11 backend" on \
SDL "Enable SDL backend" on \
@@ -31,8 +34,8 @@ USE_GNOME= gnomehack
USE_LDCONFIG= yes
USE_PERL5_BUILD=yes
-DIRECTFB_SHLIB= 3 # LT_CURRENT
-DIRECTFB_BIN= 0 # LT_BINARY
+DIRECTFB_SHLIB= 5 # LT_CURRENT
+DIRECTFB_BIN= 5 # LT_BINARY
PLIST_SUB+= DIRECTFB_VERSION="${PORTVERSION}" \
DIRECTFB_RELEASE="${PORTVERSION:R}" \
DIRECTFB_SHLIB="${DIRECTFB_SHLIB}" \
@@ -41,9 +44,10 @@ PLIST_SUB+= DIRECTFB_VERSION="${PORTVERSION}" \
CONFIGURE_ARGS= --disable-osx --disable-extra-warnings --disable-profiling \
--disable-debug --enable-debug-support --disable-trace \
--enable-text --enable-gettid --enable-network \
- --disable-multi --enable-voodoo --enable-devmem \
- --disable-fbdev --disable-vnc --disable-sysfs --enable-jpeg \
- --enable-zlib --enable-png --enable-gif --disable-video4linux \
+ --disable-multi --enable-voodoo --disable-pure-voodoo \
+ --enable-devmem --disable-fbdev --disable-vnc --disable-sysfs \
+ --enable-jpeg --enable-zlib --enable-png --enable-gif \
+ --disable-linotype --disable-video4linux \
--disable-video4linux2 --with-gfxdrivers=all \
--with-inputdrivers=all --with-smooth-scaling \
--with-dither-rgb16=advanced
@@ -53,8 +57,6 @@ CONFIGURE_ARGS= --disable-osx --disable-extra-warnings --disable-profiling \
.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= man2html:${PORTSDIR}/textproc/man2html
PORTDOCS= *
-DOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README TODO \
- docs/README* docs/*.html docs/html/*.html docs/html/*.png
.endif
.if defined(WITH_FREETYPE2)
@@ -67,7 +69,7 @@ PLIST_SUB+= FREETYPE2="@comment "
.endif
.if defined(WITH_X11)
-USE_XORG+= x11 xproto
+USE_XORG+= x11 xext xproto
CONFIGURE_ARGS+= --enable-x11
PLIST_SUB+= X11=""
.else
@@ -109,11 +111,22 @@ MAN5= directfbrc.5
BROKEN= Does not compile on alpha
.endif
+.if ${ARCH} == "arm"
+PLIST_SUB+= ARCH_ARM=""
+.else
+PLIST_SUB+= ARCH_ARM="@comment "
+.endif
+
+.if ${ARCH} == "powerpc"
+PLIST_SUB+= ARCH_POWERPC=""
+.else
+PLIST_SUB+= ARCH_POWERPC="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
- 's|-lc_r|${PTHREAD_LIBS}|g ; s|-lpthread|${PTHREAD_LIBS}|g ; \
- s|%%LTMAIN%%|${LTMAIN}|g ; s|/usr/local|${LOCALBASE}|g ; \
- s|/usr/X11R6|${LOCALBASE}|g' \
+ 's|-lc_r|${PTHREAD_LIBS}|g ; s|%%LTMAIN%%|${LTMAIN}|g ; \
+ s|/usr/local|${LOCALBASE}|g ; s|/usr/X11R6|${LOCALBASE}|g' \
${WRKSRC}/configure
@${GREP} -lr alloca\.h ${WRKSRC} | ${XARGS} \
${REINPLACE_CMD} -e 's|<alloca\.h>|<stdlib.h>|g'
@@ -121,14 +134,12 @@ post-patch:
.if !defined(NOPORTDOCS)
post-install:
${MKDIR} ${DOCSDIR}/html
- cd ${WRKSRC} && \
- for f in ${DOCS}; do \
- if [ $${f##*/html/*} ]; then \
- ${INSTALL_DATA} $$f ${DOCSDIR}; \
- else \
- ${INSTALL_DATA} $$f ${DOCSDIR}/html; \
- fi; \
- done
+.for f in AUTHORS ChangeLog NEWS README TODO fb.modes docs/README.screenshots docs/*.html
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.for f in docs/html/*.html docs/html/*.png
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/html
+.endfor
.endif
.include <bsd.port.post.mk>
diff --git a/devel/directfb/distinfo b/devel/directfb/distinfo
index 7fd4f3e6dd68..acd281b6fa4f 100644
--- a/devel/directfb/distinfo
+++ b/devel/directfb/distinfo
@@ -1,3 +1,2 @@
-MD5 (DirectFB-1.4.3.tar.gz) = 223e036da906ceb4bd44708026839ff1
-SHA256 (DirectFB-1.4.3.tar.gz) = 1435aae4f0eb70252dc25ee50e51aecfdc4527f2651db5f35b34eb833fa7e978
-SIZE (DirectFB-1.4.3.tar.gz) = 2898215
+SHA256 (DirectFB-1.4.11.tar.gz) = 85e27aa6ab9e784689a803961724eb5674cb9f5153770e63f02bf3f75a573a02
+SIZE (DirectFB-1.4.11.tar.gz) = 3110010
diff --git a/devel/directfb/files/patch-configure b/devel/directfb/files/patch-configure
index 40df29c5b482..c3eca57fe5f5 100644
--- a/devel/directfb/files/patch-configure
+++ b/devel/directfb/files/patch-configure
@@ -1,16 +1,16 @@
---- configure.orig 2008-03-12 17:28:51.000000000 +0200
-+++ configure 2008-03-12 17:32:16.000000000 +0200
-@@ -19439,7 +19439,8 @@
+--- ./configure.orig 2010-12-03 16:44:12.000000000 +0100
++++ ./configure 2010-12-03 16:44:12.000000000 +0100
+@@ -8985,7 +8985,8 @@
# This can be used to rebuild libtool when needed
--LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+-LIBTOOL_DEPS="$ltmain"
+LIBTOOL_DEPS="--disable-ltlibs %%LTMAIN%%"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -22065,7 +22066,7 @@
+@@ -16443,7 +16444,7 @@
fi
diff --git a/devel/directfb/files/patch-idirectfbimageprovider_png.c b/devel/directfb/files/patch-idirectfbimageprovider_png.c
deleted file mode 100644
index fd27de995267..000000000000
--- a/devel/directfb/files/patch-idirectfbimageprovider_png.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- interfaces/IDirectFBImageProvider/idirectfbimageprovider_png.c.orig 2007-12-15 13:30:24.000000000 +0100
-+++ interfaces/IDirectFBImageProvider/idirectfbimageprovider_png.c 2010-03-29 21:00:24.000000000 +0200
-@@ -168,7 +168,7 @@
- static DFBResult
- Probe( IDirectFBImageProvider_ProbeContext *ctx )
- {
-- if (png_check_sig( ctx->header, 8 ))
-+ if (!png_sig_cmp( ctx->header, 0, 8 ))
- return DFB_OK;
-
- return DFB_UNSUPPORTED;
-@@ -636,7 +636,7 @@
- if (data->color_type == PNG_COLOR_TYPE_PALETTE) {
- u32 key;
- png_colorp palette = data->info_ptr->palette;
-- png_bytep trans = data->info_ptr->trans;
-+ png_bytep trans = data->info_ptr->trans_alpha;
- int num_colors = MIN( MAXCOLORMAPSIZE,
- data->info_ptr->num_palette );
- u8 cmap[3][num_colors];
-@@ -661,7 +661,7 @@
- }
- else {
- /* ...or based on trans rgb value */
-- png_color_16p trans = &data->info_ptr->trans_values;
-+ png_color_16p trans = &data->info_ptr->trans_color;
-
- data->color_key = (((trans->red & 0xff00) << 8) |
- ((trans->green & 0xff00)) |
-@@ -672,7 +672,7 @@
- switch (data->color_type) {
- case PNG_COLOR_TYPE_PALETTE: {
- png_colorp palette = data->info_ptr->palette;
-- png_bytep trans = data->info_ptr->trans;
-+ png_bytep trans = data->info_ptr->trans_alpha;
- int num_trans = data->info_ptr->num_trans;
- int num_colors = MIN( MAXCOLORMAPSIZE, data->info_ptr->num_palette );
-
diff --git a/devel/directfb/files/patch-lib-direct-log.c b/devel/directfb/files/patch-lib-direct-log.c
index b010cfaa8779..bd937965813a 100644
--- a/devel/directfb/files/patch-lib-direct-log.c
+++ b/devel/directfb/files/patch-lib-direct-log.c
@@ -1,11 +1,13 @@
---- lib/direct/log.c
-+++ lib/direct/log.c
-@@ -335,10 +335,12 @@ parse_host_addr( const char *hostport,
+--- ./lib/direct/log.c.orig 2010-11-15 22:12:08.000000000 +0100
++++ ./lib/direct/log.c 2010-12-03 16:44:12.000000000 +0100
+@@ -335,12 +335,14 @@
D_ERROR( "Direct/Log: Port %s is unreachable!\n", portstr );
return DR_FAILURE;
+/*
+ #ifdef EAI_ADDRFAMILY
case EAI_ADDRFAMILY:
+ #endif
case EAI_NODATA:
D_ERROR( "Direct/Log: Host found, but has no address!\n" );
return DR_FAILURE;
diff --git a/devel/directfb/files/patch-lib-voodoo-client.c b/devel/directfb/files/patch-lib-voodoo-client.c
index f820d6ed7f4d..0d129d711e92 100644
--- a/devel/directfb/files/patch-lib-voodoo-client.c
+++ b/devel/directfb/files/patch-lib-voodoo-client.c
@@ -1,15 +1,17 @@
---- lib/voodoo/client.c
-+++ lib/voodoo/client.c
-@@ -97,10 +97,12 @@ voodoo_client_create( const char *hostname,
- D_ERROR( "Direct/Log: Port 2323 is unreachable!\n" );
+--- ./lib/voodoo/client.c.orig 2010-11-15 22:13:05.000000000 +0100
++++ ./lib/voodoo/client.c 2010-12-03 16:44:12.000000000 +0100
+@@ -161,12 +161,14 @@
+ D_ERROR( "Direct/Log: Service is unreachable!\n" );
return DR_FAILURE;
-
+
+/*
+ #ifdef EAI_ADDRFAMILY
case EAI_ADDRFAMILY:
+ #endif
case EAI_NODATA:
D_ERROR( "Direct/Log: Host found, but has no address!\n" );
return DR_FAILURE;
+*/
-
+
case EAI_MEMORY:
return D_OOM();
diff --git a/devel/directfb/files/patch-lib-voodoo-manager.c b/devel/directfb/files/patch-lib-voodoo-manager.c
index 0b1a87c85b64..f6090cb570d6 100644
--- a/devel/directfb/files/patch-lib-voodoo-manager.c
+++ b/devel/directfb/files/patch-lib-voodoo-manager.c
@@ -1,17 +1,17 @@
---- lib/voodoo/manager.c.orig 2009-06-02 18:47:23.000000000 +0200
-+++ lib/voodoo/manager.c 2010-06-03 09:21:51.000000000 +0200
-@@ -40,6 +40,7 @@
+--- ./lib/voodoo/manager.c.orig 2010-11-02 00:11:20.000000000 +0100
++++ ./lib/voodoo/manager.c 2010-12-03 16:44:12.000000000 +0100
+@@ -41,6 +41,7 @@
#include <sys/socket.h>
#include <sys/time.h>
+#include <netinet/in_systm.h> /* for n_long, required for build on 7.x */
#include <netinet/in.h>
+ #if !VOODOO_BUILD_NO_SETSOCKOPT
#include <netinet/ip.h>
- #include <netinet/tcp.h>
-@@ -186,10 +187,10 @@
-
+@@ -193,10 +194,10 @@
D_DEBUG( "Voodoo/Manager: Creating manager at %p.\n", manager );
+ #if !VOODOO_BUILD_NO_SETSOCKOPT
- if (setsockopt( fd, SOL_IP, IP_TOS, &tos, sizeof(tos) ) < 0)
+ if (setsockopt( fd, IPPROTO_IP, IP_TOS, &tos, sizeof(tos) ) < 0)
D_PERROR( "Voodoo/Manager: Could not set IP_TOS!\n" );
@@ -19,5 +19,5 @@
- if (setsockopt( fd, SOL_TCP, TCP_NODELAY, &one, sizeof(one) ) < 0)
+ if (setsockopt( fd, IPPROTO_TCP, TCP_NODELAY, &one, sizeof(one) ) < 0)
D_PERROR( "Voodoo/Manager: Could not set TCP_NODELAY!\n" );
+ #endif
- DUMP_SOCKET_OPTION( SO_SNDLOWAT );
diff --git a/devel/directfb/files/patch-src-misc-conf.h b/devel/directfb/files/patch-src-misc-conf.h
deleted file mode 100644
index 8f6182059e4a..000000000000
--- a/devel/directfb/files/patch-src-misc-conf.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/misc/conf.c
-+++ src/misc/conf.c
-@@ -56,6 +56,8 @@
-
- D_DEBUG_DOMAIN( DirectFB_Config, "DirectFB/Config", "Runtime configuration options for DirectFB" );
-
-+typedef unsigned long ulong;
-+
- DFBConfig *dfb_config = NULL;
-
- static const char *config_usage =
diff --git a/devel/directfb/files/patch-tests__voodoo__voodoo_test.h b/devel/directfb/files/patch-tests__voodoo__voodoo_test.h
new file mode 100644
index 000000000000..8b122a32843f
--- /dev/null
+++ b/devel/directfb/files/patch-tests__voodoo__voodoo_test.h
@@ -0,0 +1,13 @@
+--- ./tests/voodoo/voodoo_test.h.orig 2010-12-03 16:44:12.000000000 +0100
++++ ./tests/voodoo/voodoo_test.h 2010-12-03 16:44:12.000000000 +0100
+@@ -0,0 +1,10 @@
++#ifndef __VOODOO_TEST_H__
++#define __VOODOO_TEST_H__
++
++typedef enum {
++ VOODOO_TEST_INCREASE,
++ VOODOO_TEST_QUERY
++} VoodooTestCall;
++
++#endif
++
diff --git a/devel/directfb/files/patch-tools-fusion_bench.c b/devel/directfb/files/patch-tools-fusion_bench.c
deleted file mode 100644
index 2970408e1a4b..000000000000
--- a/devel/directfb/files/patch-tools-fusion_bench.c
+++ /dev/null
@@ -1,26 +0,0 @@
---- tools/fusion_bench.c
-+++ tools/fusion_bench.c
-@@ -336,7 +336,11 @@ static void
- bench_mutex_threaded( void )
- {
- int i;
-+#if HAVE_DECL_PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP
- pthread_mutex_t lock = PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP;
-+#else
-+ pthread_mutex_t lock = PTHREAD_MUTEX_INITIALIZER;
-+#endif
-
-
- /* mutex lock/unlock (2-5 threads) */
-@@ -367,7 +371,11 @@ static void
- bench_mutex( void )
- {
- pthread_mutex_t mutex = PTHREAD_MUTEX_INITIALIZER;
-+#if HAVE_DECL_PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP
- pthread_mutex_t rmutex = PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP;
-+#else
-+ pthread_mutex_t rmutex = PTHREAD_MUTEX_INITIALIZER;
-+#endif
-
-
- /* pthread_mutex lock/unlock */
diff --git a/devel/directfb/pkg-plist b/devel/directfb/pkg-plist
index 3c77a7f42bb6..dc1b8c59683b 100644
--- a/devel/directfb/pkg-plist
+++ b/devel/directfb/pkg-plist
@@ -12,6 +12,8 @@ bin/dfbproxy
bin/dfbscreen
%%TESTS%%bin/dfbtest_blit
%%TESTS%%bin/dfbtest_blit2
+%%TESTS%%bin/dfbtest_fillrect
+%%TESTS%%bin/dfbtest_font
%%TESTS%%bin/dfbtest_mirror
%%TESTS%%bin/dfbtest_reinit
%%TESTS%%bin/dfbtest_scale
@@ -22,13 +24,16 @@ bin/dfbscreen
%%TESTS%%bin/direct_test
bin/directfb-config
bin/directfb-csource
+%%TESTS%%bin/fusion_call
%%TESTS%%bin/fusion_fork
%%TESTS%%bin/fusion_reactor
%%TESTS%%bin/fusion_skirmish
%%TESTS%%bin/fusion_stream
bin/mkdfiff
%%FREETYPE2%%bin/mkdgiff
+bin/mkdgifft
%%UNIQUE%%bin/uwmdump
+bin/voodooplay
include/directfb-internal/core/clipboard.h
include/directfb-internal/core/colorhash.h
include/directfb-internal/core/core.h
@@ -69,6 +74,7 @@ include/directfb-internal/display/idirectfbscreen.h
include/directfb-internal/display/idirectfbsurface.h
include/directfb-internal/display/idirectfbsurface_layer.h
include/directfb-internal/display/idirectfbsurface_window.h
+include/directfb-internal/dummy/dummy.h
include/directfb-internal/gfx/clip.h
include/directfb-internal/gfx/convert.h
include/directfb-internal/gfx/generic/generic.h
@@ -87,6 +93,7 @@ include/directfb-internal/windows/idirectfbwindow.h
include/directfb/dfb_types.h
include/directfb/dfiff.h
include/directfb/dgiff.h
+%%ARCH_ARM%%include/directfb/direct/armasm_memcpy.h
include/directfb/direct/build.h
include/directfb/direct/clock.h
include/directfb/direct/conf.h
@@ -97,10 +104,13 @@ include/directfb/direct/interface.h
include/directfb/direct/interface_implementation.h
include/directfb/direct/list.h
include/directfb/direct/log.h
+include/directfb/direct/map.h
include/directfb/direct/mem.h
include/directfb/direct/memcpy.h
include/directfb/direct/messages.h
include/directfb/direct/modules.h
+%%ARCH_POWERPC%%include/directfb/direct/ppc_asm.h
+%%ARCH_POWERPC%%include/directfb/direct/ppcasm_memcpy.h
include/directfb/direct/serial.h
include/directfb/direct/signals.h
include/directfb/direct/stream.h
@@ -112,6 +122,7 @@ include/directfb/direct/types.h
include/directfb/direct/utf8.h
include/directfb/direct/util.h
include/directfb/directfb.h
+include/directfb/directfb_build.h
include/directfb/directfb_keyboard.h
include/directfb/directfb_keynames.h
include/directfb/directfb_strings.h
@@ -154,6 +165,7 @@ include/directfb/voodoo/conf.h
include/directfb/voodoo/interface.h
include/directfb/voodoo/manager.h
include/directfb/voodoo/message.h
+include/directfb/voodoo/play.h
include/directfb/voodoo/server.h
include/directfb/voodoo/types.h
%%SDL%%lib/directfb-%%DIRECTFB_RELEASE%%-%%DIRECTFB_BIN%%/gfxdrivers/libdirectfb_sdlgraphics.a
@@ -186,9 +198,6 @@ lib/directfb-%%DIRECTFB_RELEASE%%-%%DIRECTFB_BIN%%/interfaces/IDirectFBEventBuff
lib/directfb-%%DIRECTFB_RELEASE%%-%%DIRECTFB_BIN%%/interfaces/IDirectFBEventBuffer/libidirectfbeventbuffer_requestor.a
lib/directfb-%%DIRECTFB_RELEASE%%-%%DIRECTFB_BIN%%/interfaces/IDirectFBEventBuffer/libidirectfbeventbuffer_requestor.la
lib/directfb-%%DIRECTFB_RELEASE%%-%%DIRECTFB_BIN%%/interfaces/IDirectFBEventBuffer/libidirectfbeventbuffer_requestor.so
-lib/directfb-%%DIRECTFB_RELEASE%%-%%DIRECTFB_BIN%%/interfaces/IDirectFBFont/libidirectfbfont_default.a
-lib/directfb-%%DIRECTFB_RELEASE%%-%%DIRECTFB_BIN%%/interfaces/IDirectFBFont/libidirectfbfont_default.la
-lib/directfb-%%DIRECTFB_RELEASE%%-%%DIRECTFB_BIN%%/interfaces/IDirectFBFont/libidirectfbfont_default.so
lib/directfb-%%DIRECTFB_RELEASE%%-%%DIRECTFB_BIN%%/interfaces/IDirectFBFont/libidirectfbfont_dgiff.a
lib/directfb-%%DIRECTFB_RELEASE%%-%%DIRECTFB_BIN%%/interfaces/IDirectFBFont/libidirectfbfont_dgiff.la
lib/directfb-%%DIRECTFB_RELEASE%%-%%DIRECTFB_BIN%%/interfaces/IDirectFBFont/libidirectfbfont_dgiff.so
@@ -255,6 +264,9 @@ lib/directfb-%%DIRECTFB_RELEASE%%-%%DIRECTFB_BIN%%/interfaces/IDirectFBWindow/li
lib/directfb-%%DIRECTFB_RELEASE%%-%%DIRECTFB_BIN%%/systems/libdirectfb_devmem.a
lib/directfb-%%DIRECTFB_RELEASE%%-%%DIRECTFB_BIN%%/systems/libdirectfb_devmem.la
lib/directfb-%%DIRECTFB_RELEASE%%-%%DIRECTFB_BIN%%/systems/libdirectfb_devmem.so
+lib/directfb-%%DIRECTFB_RELEASE%%-%%DIRECTFB_BIN%%/systems/libdirectfb_dummy.a
+lib/directfb-%%DIRECTFB_RELEASE%%-%%DIRECTFB_BIN%%/systems/libdirectfb_dummy.la
+lib/directfb-%%DIRECTFB_RELEASE%%-%%DIRECTFB_BIN%%/systems/libdirectfb_dummy.so
%%SDL%%lib/directfb-%%DIRECTFB_RELEASE%%-%%DIRECTFB_BIN%%/systems/libdirectfb_sdl.a
%%SDL%%lib/directfb-%%DIRECTFB_RELEASE%%-%%DIRECTFB_BIN%%/systems/libdirectfb_sdl.la
%%SDL%%lib/directfb-%%DIRECTFB_RELEASE%%-%%DIRECTFB_BIN%%/systems/libdirectfb_sdl.so
@@ -328,6 +340,7 @@ libdata/pkgconfig/voodoo.pc
@dirrm include/directfb-internal/input
@dirrm include/directfb-internal/gfx/generic
@dirrm include/directfb-internal/gfx
+@dirrm include/directfb-internal/dummy
@dirrm include/directfb-internal/display
@dirrm include/directfb-internal/devmem
@dirrm include/directfb-internal/core