aboutsummaryrefslogtreecommitdiff
path: root/devel/distcc
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-08-26 02:39:05 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-08-26 02:39:05 +0000
commit42c6a32a2e472cf65bd0356b90e93c7dd8d53d26 (patch)
treeaa99ac8cc303dc274f4e28c2bf6c68aefc04cabf /devel/distcc
parent890318e9965cb63c2f647b2ccbdce67e1b334063 (diff)
downloadports-42c6a32a2e472cf65bd0356b90e93c7dd8d53d26.tar.gz
ports-42c6a32a2e472cf65bd0356b90e93c7dd8d53d26.zip
Notes
Diffstat (limited to 'devel/distcc')
-rw-r--r--devel/distcc/Makefile1
-rw-r--r--devel/distcc/files/patch-src::arg.c20
2 files changed, 21 insertions, 0 deletions
diff --git a/devel/distcc/Makefile b/devel/distcc/Makefile
index 25e85df88abc..63de728362fb 100644
--- a/devel/distcc/Makefile
+++ b/devel/distcc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= distcc
PORTVERSION= 0.8
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://distcc.samba.org/ftp/distcc/
diff --git a/devel/distcc/files/patch-src::arg.c b/devel/distcc/files/patch-src::arg.c
new file mode 100644
index 000000000000..d5a319c554b6
--- /dev/null
+++ b/devel/distcc/files/patch-src::arg.c
@@ -0,0 +1,20 @@
+--- src/arg.c.orig Thu Aug 15 10:52:19 2002
++++ src/arg.c Sun Aug 25 23:32:17 2002
+@@ -200,12 +200,13 @@
+ /* FIXME: This doesn't handle a.out, but that doesn't matter.
+ */
+ char *ofile;
+- if (seen_opt_c) {
+- if (dcc_output_from_source(*input_file, ".o", &ofile))
+- return -1;
+- } else if (seen_opt_s) {
++ /* -S takes precedence over -c. */
++ if (seen_opt_s) {
+ if (dcc_output_from_source(*input_file, ".s", &ofile))
+ return -1;
++ } else if (seen_opt_c) {
++ if (dcc_output_from_source(*input_file, ".o", &ofile))
++ return -1;
+ } else {
+ rs_log_crit("this can't be happening(%d)!", __LINE__);
+ return -1;