aboutsummaryrefslogtreecommitdiff
path: root/devel/dmake/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2005-02-04 00:51:46 +0000
committerMikhail Teterin <mi@FreeBSD.org>2005-02-04 00:51:46 +0000
commit26caa714140a5a6508049450d7088d53cbcfa393 (patch)
tree8f381f87d13de971ff53b0e103f7e008313bd89d /devel/dmake/Makefile
parentcfae8997c751d279d25bba42dca968a7dc32e776 (diff)
downloadports-26caa714140a5a6508049450d7088d53cbcfa393.tar.gz
ports-26caa714140a5a6508049450d7088d53cbcfa393.zip
Notes
Diffstat (limited to 'devel/dmake/Makefile')
-rw-r--r--devel/dmake/Makefile29
1 files changed, 7 insertions, 22 deletions
diff --git a/devel/dmake/Makefile b/devel/dmake/Makefile
index 0df1a1f00b2c..34327fe9ca70 100644
--- a/devel/dmake/Makefile
+++ b/devel/dmake/Makefile
@@ -6,35 +6,20 @@
#
PORTNAME= dmake
-PORTVERSION= 4.1
-PORTREVISION= 1
+PORTVERSION= 4.3
CATEGORIES= devel
-MASTER_SITES= ftp://ftp.internat.freebsd.org/pub/FreeBSD/distfiles/
-DISTNAME= ${PORTNAME}-v${PORTVERSION}-src-export.all-unknown-all
+MASTER_SITES= http://people.debian.org/~rene/pkgs/dmake/
+DISTFILES= ${PORTNAME}_${PORTVERSION}.orig.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= Another hyper make utility
-WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_REINPLACE= yes
-USE_GMAKE= yes
-MAKE_ENV= CC=${CC}
-MAKEFILE= makefile
-ALL_TARGET= bsd43
+GNU_CONFIGURE= yes
+#CONFIGURE_ENV+= CFLAGS="${CFLAGS} -Wall -Werror"
+CONFIGURE_ARGS+=--datadir=${PREFIX}/share/${PORTNAME}
MAN1= dmake.1
-post-extract:
-.for f in limits.h string.h dirent.h
- @${RM} -f ${WRKSRC}/unix/bsd43/${f}
-.endfor
-
-post-patch:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/unix/startup.h
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/dmake ${PREFIX}/bin
+post-install:
${INSTALL_MAN} ${WRKSRC}/man/dmake.tf ${PREFIX}/man/man1/dmake.1
- @${MKDIR} ${PREFIX}/share/dmake/startup
- ${CP} -R ${WRKSRC}/startup/* ${PREFIX}/share/dmake/startup
.include <bsd.port.mk>