aboutsummaryrefslogtreecommitdiff
path: root/devel/dmake
diff options
context:
space:
mode:
authorDavid Thiel <lx@FreeBSD.org>2007-03-16 18:37:56 +0000
committerDavid Thiel <lx@FreeBSD.org>2007-03-16 18:37:56 +0000
commitd660af0a51d2f9926fa886296971a2727c81ddf4 (patch)
treeef5293fa4174c57c97db9c4b8d11e6180e5e8763 /devel/dmake
parent15182225238b4d896ce347b3bafb022095e0a76c (diff)
downloadports-d660af0a51d2f9926fa886296971a2727c81ddf4.tar.gz
ports-d660af0a51d2f9926fa886296971a2727c81ddf4.zip
Notes
Diffstat (limited to 'devel/dmake')
-rw-r--r--devel/dmake/Makefile2
-rw-r--r--devel/dmake/distinfo6
-rw-r--r--devel/dmake/files/patch-configure17
-rw-r--r--devel/dmake/files/patch-getinp.c11
-rw-r--r--devel/dmake/files/patch-make.c14
-rw-r--r--devel/dmake/files/patch-stat.c13
-rw-r--r--devel/dmake/files/patch-sysinf.c29
-rw-r--r--devel/dmake/files/patch-unix-arlib.c11
-rw-r--r--devel/dmake/files/patch-unix-runargv.c12
9 files changed, 4 insertions, 111 deletions
diff --git a/devel/dmake/Makefile b/devel/dmake/Makefile
index 5a63fdc857e8..e6514bac8c0b 100644
--- a/devel/dmake/Makefile
+++ b/devel/dmake/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dmake
-PORTVERSION= 4.6
+PORTVERSION= 4.7
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
diff --git a/devel/dmake/distinfo b/devel/dmake/distinfo
index 2abd72626607..9de837743eaa 100644
--- a/devel/dmake/distinfo
+++ b/devel/dmake/distinfo
@@ -1,3 +1,3 @@
-MD5 (dmake_4.6.orig.tar.gz) = e8051185b04dd100253c6945ac38277f
-SHA256 (dmake_4.6.orig.tar.gz) = b2d88065f0664b23d4a1d162d4193fa5839450b08d1920d3f7bff995a1f0e480
-SIZE (dmake_4.6.orig.tar.gz) = 664106
+MD5 (dmake_4.7.orig.tar.gz) = 47427671d056955cf7b573c9031f860e
+SHA256 (dmake_4.7.orig.tar.gz) = ba63d57790b815f568487abdce1deb4b5ca1b23a1582d6d79a45d53cad97564f
+SIZE (dmake_4.7.orig.tar.gz) = 700365
diff --git a/devel/dmake/files/patch-configure b/devel/dmake/files/patch-configure
deleted file mode 100644
index 595ca6ee27b7..000000000000
--- a/devel/dmake/files/patch-configure
+++ /dev/null
@@ -1,17 +0,0 @@
---- configure.old Thu Apr 20 22:28:24 2006
-+++ configure Thu Apr 20 22:32:50 2006
-@@ -6420,12 +6420,13 @@
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
- $ac_includes_default
-+#include <utime.h>
- int
- main ()
- {
- struct stat s, t;
- exit (!(stat ("conftest.data", &s) == 0
-- && utime ("conftest.data", (long *)0) == 0
-+ && utime ("conftest.data", (void *)0) == 0
- && stat ("conftest.data", &t) == 0
- && t.st_mtime >= s.st_mtime
- && t.st_mtime - s.st_mtime < 120));
diff --git a/devel/dmake/files/patch-getinp.c b/devel/dmake/files/patch-getinp.c
deleted file mode 100644
index 89566c61e69d..000000000000
--- a/devel/dmake/files/patch-getinp.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- getinp.c.orig Thu Apr 20 22:38:09 2006
-+++ getinp.c Thu Apr 20 22:39:39 2006
-@@ -497,7 +497,7 @@
- static short action[MAX_COND_DEPTH];
- static char ifcntl[MAX_COND_DEPTH];
- char *lhs, *expr, *expr_end;
-- char *lop;
-+ const char *lop;
- int result;
-
- DB_ENTER( "_handle_conditional" );
diff --git a/devel/dmake/files/patch-make.c b/devel/dmake/files/patch-make.c
deleted file mode 100644
index b1909ffed4a0..000000000000
--- a/devel/dmake/files/patch-make.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- make.c.orig Mon May 1 18:43:36 2006
-+++ make.c Mon May 1 18:45:08 2006
-@@ -341,8 +341,9 @@
- }
-
- if( Verbose & V_MAKE )
-- printf("%s: Time stamp of [%s] is %ld\n",Pname,tcp->CE_NAME,
-- tcp->ce_time);
-+ printf("%s: Time stamp of [%s] is %llu\n",Pname,tcp->CE_NAME,
-+ (unsigned long long)tcp->ce_time);
-+
- }
- }
- }
diff --git a/devel/dmake/files/patch-stat.c b/devel/dmake/files/patch-stat.c
deleted file mode 100644
index 27a681e89765..000000000000
--- a/devel/dmake/files/patch-stat.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- stat.c.orig Mon May 1 18:23:40 2006
-+++ stat.c Mon May 1 18:25:04 2006
-@@ -139,8 +139,8 @@
- }
-
- if( Verbose & V_MAKE )
-- printf( "%s: Checking library '%s' for member [%s], time %ld\n",
-- Pname, cp->ce_lib, name, cp->ce_time );
-+ printf( "%s: Checking library '%s' for member [%s], time %llu\n",
-+ Pname, cp->ce_lib, name, (unsigned long long)cp->ce_time );
- }
-
- FREE( tmp );
diff --git a/devel/dmake/files/patch-sysinf.c b/devel/dmake/files/patch-sysinf.c
deleted file mode 100644
index 0b38329f75a3..000000000000
--- a/devel/dmake/files/patch-sysinf.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- sysintf.c.orig Sun Oct 8 00:23:30 2006
-+++ sysintf.c Sun Oct 8 00:23:30 2006
-@@ -608,13 +608,12 @@
- if( tmpdir == NIL(char) )
- tmpdir = "/tmp";
-
-- while( --tries )
-- {
-+ do {
- if( (fd = Create_temp(tmpdir, path)) != -1)
- break;
-
- free(*path); /* free var if creating temp failed. */
-- }
-+ } while( --tries );
-
- if( fd != -1)
- {
-@@ -881,8 +880,8 @@
- }
-
- if( Verbose & V_MAKE )
-- printf( "%s: <<<< Set [%s] time stamp to %lu\n",
-- Pname, tcp->CE_NAME, tcp->ce_time );
-+ printf( "%s: <<<< Set [%s] time stamp to %llu\n",
-+ Pname, tcp->CE_NAME, (unsigned long long)tcp->ce_time );
-
- if( Measure & M_TARGET )
- Do_profile_output( "e", M_TARGET, tcp );
diff --git a/devel/dmake/files/patch-unix-arlib.c b/devel/dmake/files/patch-unix-arlib.c
deleted file mode 100644
index 84e7b1c8ecbc..000000000000
--- a/devel/dmake/files/patch-unix-arlib.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- unix/arlib.c.orig Mon May 1 18:35:44 2006
-+++ unix/arlib.c Mon May 1 18:37:16 2006
-@@ -421,7 +421,7 @@
- fseek(f, arhdroffset + (unsigned long)(((struct ar_hdr *)0)->ar_date), 0);
-
- #if ASCARCH
-- fprintf(f, "%lu", now);
-+ fprintf(f, "%llu", (unsigned long long)now);
- #else
- fwrite((char *)now, sizeof(now), 1, f);
- #endif
diff --git a/devel/dmake/files/patch-unix-runargv.c b/devel/dmake/files/patch-unix-runargv.c
deleted file mode 100644
index e48e18e96d48..000000000000
--- a/devel/dmake/files/patch-unix-runargv.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- unix/runargv.c.orig Mon May 1 18:38:28 2006
-+++ unix/runargv.c Mon May 1 18:38:58 2006
-@@ -66,6 +66,9 @@
- with runargv().
- */
-
-+#ifdef HAVE_CONFIG_H
-+# include "config.h"
-+#endif
- #include <signal.h>
-
- #include "extern.h"