aboutsummaryrefslogtreecommitdiff
path: root/devel/dmake
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-05-01 20:21:13 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-05-01 20:21:13 +0000
commitf22193f56ab531a1842f34d6aaec2d5c6d5bb749 (patch)
treeb108d25cf3e33d1b9302d0d68819386694303dcb /devel/dmake
parent8df0bf29eedf85e41685264e1f186583a343f94b (diff)
downloadports-f22193f56ab531a1842f34d6aaec2d5c6d5bb749.tar.gz
ports-f22193f56ab531a1842f34d6aaec2d5c6d5bb749.zip
Notes
Diffstat (limited to 'devel/dmake')
-rw-r--r--devel/dmake/Makefile6
-rw-r--r--devel/dmake/distinfo6
-rw-r--r--devel/dmake/files/patch-configure24
-rw-r--r--devel/dmake/files/patch-getinp.c11
-rw-r--r--devel/dmake/files/patch-make.c14
-rw-r--r--devel/dmake/files/patch-stat.c13
-rw-r--r--devel/dmake/files/patch-sysinf.c30
-rw-r--r--devel/dmake/files/patch-unix-arlib.c11
-rw-r--r--devel/dmake/files/patch-unix-runargv.c12
-rw-r--r--devel/dmake/files/patch-warnings128
-rw-r--r--devel/dmake/pkg-plist2
11 files changed, 101 insertions, 156 deletions
diff --git a/devel/dmake/Makefile b/devel/dmake/Makefile
index fad327ad729a..ff04b6a98f43 100644
--- a/devel/dmake/Makefile
+++ b/devel/dmake/Makefile
@@ -6,15 +6,15 @@
#
PORTNAME= dmake
-PORTVERSION= 4.3
-PORTREVISION= 1
+PORTVERSION= 4.4
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
-DISTFILES= ${PORTNAME}_${PORTVERSION}.orig.tar.gz
+DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
MAINTAINER= ports@FreeBSD.org
COMMENT= Another hyper make utility
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
#CONFIGURE_ENV+= CFLAGS="${CFLAGS} -Wall -Werror"
CONFIGURE_ARGS+=--datadir=${PREFIX}/share/${PORTNAME}
diff --git a/devel/dmake/distinfo b/devel/dmake/distinfo
index 8fe277a3b6d5..c9fd7e967ab1 100644
--- a/devel/dmake/distinfo
+++ b/devel/dmake/distinfo
@@ -1,3 +1,3 @@
-MD5 (dmake_4.3.orig.tar.gz) = c1dacc7684aff96a1cc198dcce5cc139
-SHA256 (dmake_4.3.orig.tar.gz) = a985f3722ecda826ec4f280b1f96e3a5795bee7ecb3ec42fa7c0ef0ee64ddf02
-SIZE (dmake_4.3.orig.tar.gz) = 614637
+MD5 (dmake_4.4.orig.tar.gz) = 0d082461caedcca10c3c56f1a587403d
+SHA256 (dmake_4.4.orig.tar.gz) = 873ec5908712df836415afea08ca847786b9788e1c12b82a14176f4e9de2d30b
+SIZE (dmake_4.4.orig.tar.gz) = 649098
diff --git a/devel/dmake/files/patch-configure b/devel/dmake/files/patch-configure
index 73c9b69f4500..595ca6ee27b7 100644
--- a/devel/dmake/files/patch-configure
+++ b/devel/dmake/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Tue Oct 12 21:47:46 2004
-+++ configure Fri Mar 24 22:06:28 2006
-@@ -6206,12 +6206,13 @@
+--- configure.old Thu Apr 20 22:28:24 2006
++++ configure Thu Apr 20 22:32:50 2006
+@@ -6420,12 +6420,13 @@
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
$ac_includes_default
@@ -15,21 +15,3 @@
&& stat ("conftest.data", &t) == 0
&& t.st_mtime >= s.st_mtime
&& t.st_mtime - s.st_mtime < 120));
-@@ -6669,7 +6670,7 @@
-
-
- if test "${prefix}" != NONE; then
-- DMAKEROOT=${prefix}/share/startup/startup.mk
-+ DMAKEROOT=${prefix}/share/dmake/startup/startup.mk
- export DMAKEROOT
- else
- DMAKEROOT=startup.mk
-@@ -8108,7 +8109,7 @@
-
- if test x$prefix != x; then
- if test x$OS_TYPE = xunix; then
-- echo '"DMAKEROOT := '$prefix'/share/startup",' >> $outfile
-+ echo '"DMAKEROOT := '$prefix'/share/dmake/startup",' >> $outfile
- fi
- echo '"OS := '${OS_VERSION}'",' >> $outfile
- fi
diff --git a/devel/dmake/files/patch-getinp.c b/devel/dmake/files/patch-getinp.c
new file mode 100644
index 000000000000..89566c61e69d
--- /dev/null
+++ b/devel/dmake/files/patch-getinp.c
@@ -0,0 +1,11 @@
+--- getinp.c.orig Thu Apr 20 22:38:09 2006
++++ getinp.c Thu Apr 20 22:39:39 2006
+@@ -497,7 +497,7 @@
+ static short action[MAX_COND_DEPTH];
+ static char ifcntl[MAX_COND_DEPTH];
+ char *lhs, *expr, *expr_end;
+- char *lop;
++ const char *lop;
+ int result;
+
+ DB_ENTER( "_handle_conditional" );
diff --git a/devel/dmake/files/patch-make.c b/devel/dmake/files/patch-make.c
new file mode 100644
index 000000000000..b1909ffed4a0
--- /dev/null
+++ b/devel/dmake/files/patch-make.c
@@ -0,0 +1,14 @@
+--- make.c.orig Mon May 1 18:43:36 2006
++++ make.c Mon May 1 18:45:08 2006
+@@ -341,8 +341,9 @@
+ }
+
+ if( Verbose & V_MAKE )
+- printf("%s: Time stamp of [%s] is %ld\n",Pname,tcp->CE_NAME,
+- tcp->ce_time);
++ printf("%s: Time stamp of [%s] is %llu\n",Pname,tcp->CE_NAME,
++ (unsigned long long)tcp->ce_time);
++
+ }
+ }
+ }
diff --git a/devel/dmake/files/patch-stat.c b/devel/dmake/files/patch-stat.c
new file mode 100644
index 000000000000..27a681e89765
--- /dev/null
+++ b/devel/dmake/files/patch-stat.c
@@ -0,0 +1,13 @@
+--- stat.c.orig Mon May 1 18:23:40 2006
++++ stat.c Mon May 1 18:25:04 2006
+@@ -139,8 +139,8 @@
+ }
+
+ if( Verbose & V_MAKE )
+- printf( "%s: Checking library '%s' for member [%s], time %ld\n",
+- Pname, cp->ce_lib, name, cp->ce_time );
++ printf( "%s: Checking library '%s' for member [%s], time %llu\n",
++ Pname, cp->ce_lib, name, (unsigned long long)cp->ce_time );
+ }
+
+ FREE( tmp );
diff --git a/devel/dmake/files/patch-sysinf.c b/devel/dmake/files/patch-sysinf.c
new file mode 100644
index 000000000000..9c4ad633daa7
--- /dev/null
+++ b/devel/dmake/files/patch-sysinf.c
@@ -0,0 +1,30 @@
+--- sysintf.c.orig Thu Feb 2 05:39:56 2006
++++ sysintf.c Mon May 1 18:33:02 2006
+@@ -596,13 +596,12 @@
+ if( tmpdir == NIL(char) )
+ tmpdir = "/tmp";
+
+- while( --tries )
+- {
++ do {
+ if( (fd = Create_temp(tmpdir, path, suff)) != -1)
+ break;
+
+ free(*path);
+- }
++ } while( --tries );
+
+ if( fd != -1)
+ {
+@@ -839,8 +838,9 @@
+ }
+
+ if( Verbose & V_MAKE )
+- printf( "%s: <<<< Set [%s] time stamp to %lu\n",
+- Pname, tcp->CE_NAME, tcp->ce_time );
++ printf( "%s: <<<< Set [%s] time stamp to %llu\n",
++ Pname, tcp->CE_NAME, (unsigned long long)tcp->ce_time );
++
+
+ if( Measure & M_TARGET )
+ Do_profile_output( "e", M_TARGET, tcp );
diff --git a/devel/dmake/files/patch-unix-arlib.c b/devel/dmake/files/patch-unix-arlib.c
new file mode 100644
index 000000000000..84e7b1c8ecbc
--- /dev/null
+++ b/devel/dmake/files/patch-unix-arlib.c
@@ -0,0 +1,11 @@
+--- unix/arlib.c.orig Mon May 1 18:35:44 2006
++++ unix/arlib.c Mon May 1 18:37:16 2006
+@@ -421,7 +421,7 @@
+ fseek(f, arhdroffset + (unsigned long)(((struct ar_hdr *)0)->ar_date), 0);
+
+ #if ASCARCH
+- fprintf(f, "%lu", now);
++ fprintf(f, "%llu", (unsigned long long)now);
+ #else
+ fwrite((char *)now, sizeof(now), 1, f);
+ #endif
diff --git a/devel/dmake/files/patch-unix-runargv.c b/devel/dmake/files/patch-unix-runargv.c
new file mode 100644
index 000000000000..e48e18e96d48
--- /dev/null
+++ b/devel/dmake/files/patch-unix-runargv.c
@@ -0,0 +1,12 @@
+--- unix/runargv.c.orig Mon May 1 18:38:28 2006
++++ unix/runargv.c Mon May 1 18:38:58 2006
+@@ -66,6 +66,9 @@
+ with runargv().
+ */
+
++#ifdef HAVE_CONFIG_H
++# include "config.h"
++#endif
+ #include <signal.h>
+
+ #include "extern.h"
diff --git a/devel/dmake/files/patch-warnings b/devel/dmake/files/patch-warnings
deleted file mode 100644
index b8e95b36da94..000000000000
--- a/devel/dmake/files/patch-warnings
+++ /dev/null
@@ -1,128 +0,0 @@
-Fix warnings to allow ``-Wall -Werror'' with gcc-3.4.2 on FreeBSD/i386.
-Most of these seemed fairly benign -- assumptions about time_t are the
-most common.
-
- -mi
-
---- state.c Fri Sep 22 11:33:25 2000
-+++ state.c Sun Jan 2 18:13:26 2005
-@@ -123,6 +123,6 @@
- fprintf( fp, "%s\n", sp->st_name );
- fprintf( fp, "%d\n", sp->st_count );
-- fprintf( fp, "%lu\n", sp->st_dkey );
-- fprintf( fp, "%lu\n", sp->st_key );
-+ fprintf( fp, "%lu\n", (unsigned long)sp->st_dkey );
-+ fprintf( fp, "%lu\n", (unsigned long)sp->st_key );
- }
- }
---- getinp.c Wed Apr 21 10:10:17 2004
-+++ getinp.c Sun Jan 2 18:16:37 2005 -- remove unused variables
-@@ -481,6 +481,6 @@
- static char ifcntl[MAX_COND_DEPTH];
- char *lhs, *expr, *expr_end;
-- char *lop, *partstr;
-- int result, n, m;
-+ const char *lop;
-+ int result;
-
- DB_ENTER( "_handle_conditional" );
-@@ -562,5 +562,7 @@
-
- /* uncomment to turn on expression debug statements */
--/*#define PARSE_DEBUG /* */
-+#if 0
-+# define PARSE_DEBUG /* */
-+#endif
- #define PARSE_SKIP_WHITE(A) while( *A && ((*A==' ') || (*A=='\t')) ) A++;
-
---- unix/arlib.c Wed Sep 8 12:08:45 2004
-+++ unix/arlib.c Sun Jan 2 18:20:44 2005
-@@ -399,5 +399,5 @@
- fseek( f, (long) _ar.ar_size, 0 );
- #else
-- fseek( f, arhdroffset + sizeof(arhdr) + (_ar.ar_size+1 & ~1L), 0 );
-+ fseek( f, arhdroffset + sizeof(arhdr) + ((_ar.ar_size+1) & ~1L), 0 );
- #endif
- }
-@@ -422,5 +422,5 @@
-
- #if ASCARCH
-- fprintf(f, "%lu", now);
-+ fprintf(f, "%llu", (unsigned long long)now);
- #else
- fwrite((char *)now, sizeof(now), 1, f);
---- unix/runargv.c Wed Sep 8 12:09:39 2004
-+++ unix/runargv.c Sun Jan 2 18:25:02 2005
-@@ -26,4 +26,7 @@
- */
-
-+#ifdef HAVE_CONFIG_H
-+# include "config.h"
-+#endif
- #include <signal.h>
- #ifdef HAVE_WAIT_H
---- make.c Wed Sep 8 12:06:46 2004
-+++ make.c Sun Jan 2 18:26:55 2005
-@@ -336,6 +336,6 @@
-
- if( Verbose & V_MAKE )
-- printf("%s: Time stamp of [%s] is %ld\n",Pname,tcp->CE_NAME,
-- tcp->ce_time);
-+ printf("%s: Time stamp of [%s] is %llu\n",Pname,tcp->CE_NAME,
-+ (unsigned long long)tcp->ce_time);
- }
- }
-@@ -590,6 +590,6 @@
-
- if( Verbose & V_MAKE )
-- printf( "%s: Updating [%s], (%ld > %ld)\n", Pname,
-- cp->CE_NAME, otime, cp->ce_time );
-+ printf( "%s: Updating [%s], (%llu > %llu)\n", Pname,
-+ cp->CE_NAME, (unsigned long long)otime, (unsigned long long)cp->ce_time );
-
- if( Touch ) {
---- stat.c Fri Sep 22 11:33:25 2000
-+++ stat.c Sun Jan 2 18:27:46 2005
-@@ -140,6 +140,6 @@
-
- if( Verbose & V_MAKE )
-- printf( "%s: Checking library '%s' for member [%s], time %ld\n",
-- Pname, cp->ce_lib, name, cp->ce_time );
-+ printf( "%s: Checking library '%s' for member [%s], time %llu\n",
-+ Pname, cp->ce_lib, name, (unsigned long long)cp->ce_time );
- }
-
---- sysintf.c Thu Oct 7 18:18:47 2004 -- change the loop to make it more
-+++ sysintf.c Sun Jan 2 18:30:33 2005 -- obvious, that fd *will* be set
-@@ -500,11 +500,10 @@
- tmpdir = "/tmp";
-
-- while( --tries )
-- {
-+ do {
- if( (fd = Create_temp(tmpdir, path, suff)) != -1)
- break;
-
- free(*path);
-- }
-+ } while( --tries );
-
- if( fd != -1)
-@@ -739,6 +738,6 @@
-
- if( Verbose & V_MAKE )
-- printf( "%s: <<<< Set [%s] time stamp to %lu\n",
-- Pname, tcp->CE_NAME, tcp->ce_time );
-+ printf( "%s: <<<< Set [%s] time stamp to %llu\n",
-+ Pname, tcp->CE_NAME, (unsigned long long)tcp->ce_time );
-
- Unlink_temp_files( tcp );
---- function.c Wed Sep 8 12:06:20 2004
-+++ function.c Sun Jan 2 18:33:09 2005 -- unused variable
-@@ -287,5 +287,5 @@
-
- if( file && *file ) {
-- char *newtmp;
-+ /* char *newtmp; */
-
- /* This call to Get_temp sets TMPFILE for subsequent expansion of file.
diff --git a/devel/dmake/pkg-plist b/devel/dmake/pkg-plist
index ee98edc713c9..867d0f510d14 100644
--- a/devel/dmake/pkg-plist
+++ b/devel/dmake/pkg-plist
@@ -1,6 +1,6 @@
bin/dmake
+share/dmake/startup/config.mk
share/dmake/startup/startup.mk
-share/dmake/startup/template.mk
share/dmake/startup/unix/linux/macros.mk
share/dmake/startup/unix/macros.mk
share/dmake/startup/unix/recipes.mk