aboutsummaryrefslogtreecommitdiff
path: root/devel/doctorj
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-03-23 20:55:51 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-03-23 20:55:51 +0000
commit32a55e6e2d9b81999602cd4b1ae57ee8cbff6089 (patch)
treefc36702a6df62c4fbb92cc1756542f9a72d930dd /devel/doctorj
parent856b5e758328e4006f2ca6dd9bb625d6947480ba (diff)
downloadports-32a55e6e2d9b81999602cd4b1ae57ee8cbff6089.tar.gz
ports-32a55e6e2d9b81999602cd4b1ae57ee8cbff6089.zip
Notes
Diffstat (limited to 'devel/doctorj')
-rw-r--r--devel/doctorj/Makefile22
-rw-r--r--devel/doctorj/distinfo6
-rw-r--r--devel/doctorj/files/patch-syntj_src_ErrorImproperSequence.h14
-rw-r--r--devel/doctorj/files/patch-util_src_Yagol.h32
-rw-r--r--devel/doctorj/pkg-descr26
5 files changed, 35 insertions, 65 deletions
diff --git a/devel/doctorj/Makefile b/devel/doctorj/Makefile
index 04750da4e66a..a8e506c19a16 100644
--- a/devel/doctorj/Makefile
+++ b/devel/doctorj/Makefile
@@ -7,17 +7,29 @@
#
PORTNAME= doctorj
-PORTVERSION= 4.0.2
-CATEGORIES= devel
+PORTVERSION= 5.1.2
+CATEGORIES= devel java
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemoliu@gmail.com
COMMENT= A tool for analyzing Java code and documentation
-GNU_CONFIGURE= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.3+
+USE_ANT= yes
+
+ALL_TARGET= jarfile
MAN1= doctorj.1
-PLIST_FILES= bin/doctorj
+PLIST_FILES= %%JAVAJARDIR%%/doctorj.jar
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/doctorj.jar..."
+ @${MKDIR} ${JAVAJARDIR}
+ @${INSTALL_DATA} ${WRKSRC}/share/doctorj/doctorj.jar ${JAVAJARDIR}/
+ @${ECHO_MSG} -n ">> Installing MANPAGE ..."
+ @${INSTALL_MAN} ${WRKSRC}/doc/doctorj.1 ${MAN1PREFIX}/man/man1
+ @${ECHO_MSG} " [ DONE ]"
.include <bsd.port.mk>
diff --git a/devel/doctorj/distinfo b/devel/doctorj/distinfo
index 7180e8d18e56..fbacd713fa6b 100644
--- a/devel/doctorj/distinfo
+++ b/devel/doctorj/distinfo
@@ -1,3 +1,3 @@
-MD5 (doctorj-4.0.2.tar.gz) = 612aac2fd1238fe0246e364e3f884c58
-SHA256 (doctorj-4.0.2.tar.gz) = 11c67f6edaf427200099d774d80927f221e8a1b433af287f1c6ac34d78e4a76a
-SIZE (doctorj-4.0.2.tar.gz) = 484287
+MD5 (doctorj-5.1.2.tar.gz) = 77d151d312b3a314286248d84d97cfee
+SHA256 (doctorj-5.1.2.tar.gz) = 8413d32d40462c23a1989b7d21f9eb3209296d5e3fac3e6c283861584a786b87
+SIZE (doctorj-5.1.2.tar.gz) = 1303680
diff --git a/devel/doctorj/files/patch-syntj_src_ErrorImproperSequence.h b/devel/doctorj/files/patch-syntj_src_ErrorImproperSequence.h
deleted file mode 100644
index 9bf3c90cc622..000000000000
--- a/devel/doctorj/files/patch-syntj_src_ErrorImproperSequence.h
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- syntj/src/ErrorImproperSequence.h.orig Tue Aug 10 16:09:36 2004
-+++ syntj/src/ErrorImproperSequence.h Tue Aug 10 16:09:51 2004
-@@ -49,7 +49,7 @@
- /**
- * The current item.
- */
-- AstItem* const current_;
-+ AstItem* current_;
-
- };
-
diff --git a/devel/doctorj/files/patch-util_src_Yagol.h b/devel/doctorj/files/patch-util_src_Yagol.h
deleted file mode 100644
index 8c809f972044..000000000000
--- a/devel/doctorj/files/patch-util_src_Yagol.h
+++ /dev/null
@@ -1,32 +0,0 @@
-
-$FreeBSD$
-
---- util/src/Yagol.h.orig Tue Aug 10 16:42:48 2004
-+++ util/src/Yagol.h Tue Aug 10 16:43:29 2004
-@@ -298,6 +298,8 @@
- template < class Type >
- string AboveRangeException<Type>::message() const
- {
-+ Type value;
-+ Type limit;
- return "value " + doctorj::StringUtilities::toString(value()) +
- " is above the upper bound " + doctorj::StringUtilities::toString(limit());
- }
-@@ -339,6 +341,8 @@
- template < class Type >
- string BelowRangeException<Type>::message() const
- {
-+ Type value;
-+ Type limit;
- return "value " + doctorj::StringUtilities::toString(value()) +
- " is below the lower bound " + doctorj::StringUtilities::toString(limit());
- }
-@@ -1991,7 +1995,7 @@
- vector<typename Container::value_type>* const values)
- {
- ArgCallback<vector< typename Container::value_type > >* validator =
-- new GroupValidator<vector< typename Container::value_type > >(value, valids, nValids);
-+ new GroupValidator<vector< typename Container::value_type > >(values, valids, nValids);
- return addOption(new OptionMultiValues<Container>(name, description, validator, strictArgs_));
- }
-
diff --git a/devel/doctorj/pkg-descr b/devel/doctorj/pkg-descr
index 4bec8d64e16a..f54d8a386965 100644
--- a/devel/doctorj/pkg-descr
+++ b/devel/doctorj/pkg-descr
@@ -1,12 +1,16 @@
-DoctorJ is a set of applications that analyze Java code. Documentation is
-verified for compliance with the standard and for accuracy against the
-code, beyond what javadoc does. Statistics for a file or project can be
-generated, including the number of lines of code per class and method,
-and the overall total. A syntax analyzer is in development.
+Beyond the level of what Javadoc does, DoctorJ compares documentation against
+code. Among what it detects:
+ * misspelled words
+ * parameter and exception names:
+ o missing
+ o misordered
+ o misspelled
+ * Javadoc tags:
+ o invalid
+ o misordered
+ o missing expected arguments
+ o invalid arguments
+ o missing descriptions
+ * undocumented classes, methods, fields, parameters
-
-WWW: http://doctorj.sourceforge.net/
-AUTHOR: Jeff Pace <jpace@incava.org>
-
- - Michael L. Hostbaek
- mich@FreeBSD.org
+WWW: http://doctorj.sourceforge.net/