aboutsummaryrefslogtreecommitdiff
path: root/devel/dotconf++
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-08 22:47:00 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-08 22:47:00 +0000
commitf15cceafbbfa700cb61f282949b40abad30a8f16 (patch)
treebbf777a11d9b86cc1b7c78008922892db9fa51fe /devel/dotconf++
parentb242f34f2635de8fbb5e15a15a9fd71a214a0e0e (diff)
downloadports-f15cceafbbfa700cb61f282949b40abad30a8f16.tar.gz
ports-f15cceafbbfa700cb61f282949b40abad30a8f16.zip
Notes
Diffstat (limited to 'devel/dotconf++')
-rw-r--r--devel/dotconf++/Makefile26
-rw-r--r--devel/dotconf++/distinfo2
-rw-r--r--devel/dotconf++/files/patch-src-Makefile.in20
-rw-r--r--devel/dotconf++/pkg-descr6
-rw-r--r--devel/dotconf++/pkg-plist6
5 files changed, 60 insertions, 0 deletions
diff --git a/devel/dotconf++/Makefile b/devel/dotconf++/Makefile
new file mode 100644
index 000000000000..f3c07db22e65
--- /dev/null
+++ b/devel/dotconf++/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: dotconf++
+# Date created: 7 July 2005
+# Whom: Mark Starovoytov <mark_sf@kikg.ifmo.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dotconfpp
+PORTVERSION= 0.0.4a
+CATEGORIES= devel
+MASTER_SITES= http://voodoo.com.ua/dotconf++/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Configuration file parser written in C++
+
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
+
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|<stdint.h>|<inttypes.h>|' \
+ ${WRKSRC}/src/dotconfpp.h ${WRKSRC}/src/mempool.h
+
+.include <bsd.port.mk>
diff --git a/devel/dotconf++/distinfo b/devel/dotconf++/distinfo
new file mode 100644
index 000000000000..7a7226f79ff0
--- /dev/null
+++ b/devel/dotconf++/distinfo
@@ -0,0 +1,2 @@
+MD5 (dotconfpp-0.0.4a.tar.gz) = 0c43f864f7115916e39c1e14599d053b
+SIZE (dotconfpp-0.0.4a.tar.gz) = 307253
diff --git a/devel/dotconf++/files/patch-src-Makefile.in b/devel/dotconf++/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..e85c55507119
--- /dev/null
+++ b/devel/dotconf++/files/patch-src-Makefile.in
@@ -0,0 +1,20 @@
+--- src/Makefile.in.orig Fri Jun 25 14:13:09 2004
++++ src/Makefile.in Thu Jul 7 15:16:26 2005
+@@ -116,7 +116,7 @@
+ host_cpu = @host_cpu@
+ host_os = @host_os@
+ host_vendor = @host_vendor@
+-includedir = /usr/local/include/dotconf++
++includedir = @prefix@/include/dotconf++
+ infodir = @infodir@
+ install_sh = @install_sh@
+ libdir = @libdir@
+@@ -132,7 +132,7 @@
+ target_alias = @target_alias@
+ EXTRA_DIST = dotconfpp.h mempool.h mempool.cc
+
+-LIBdir = /usr/local/lib
++LIBdir = @prefix@/lib
+ SUBDIRS = . example1 example2
+
+ INCLUDES = -I.
diff --git a/devel/dotconf++/pkg-descr b/devel/dotconf++/pkg-descr
new file mode 100644
index 000000000000..a0f1e3b7888a
--- /dev/null
+++ b/devel/dotconf++/pkg-descr
@@ -0,0 +1,6 @@
+dotconf++ is a dotconf like configuration file parser written in C++.
+It supports macro substitution from the environment or from the file
+itself, config file inclusion, easy handling of XML like tags,
+checking for required tags, and more.
+
+WWW: http://sourceforge.net/projects/dotconfpp/
diff --git a/devel/dotconf++/pkg-plist b/devel/dotconf++/pkg-plist
new file mode 100644
index 000000000000..9f2bd6efeb14
--- /dev/null
+++ b/devel/dotconf++/pkg-plist
@@ -0,0 +1,6 @@
+include/dotconf++/dotconfpp.h
+include/dotconf++/mempool.h
+lib/libdotconfpp.a
+lib/libdotconfpp.so
+lib/libdotconfpp.so.0
+@dirrm include/dotconf++