aboutsummaryrefslogtreecommitdiff
path: root/devel/dotconf++
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-13 18:23:36 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-13 18:23:36 +0000
commit73ce6ff2e8e65acbd35f3213866526cf8b0f8cae (patch)
tree6cc158adfe070ea1ac9d334192646ad2f31f29ff /devel/dotconf++
parentfa80014180872977a3e11add4ae53dcf60f6ba1f (diff)
downloadports-73ce6ff2e8e65acbd35f3213866526cf8b0f8cae.tar.gz
ports-73ce6ff2e8e65acbd35f3213866526cf8b0f8cae.zip
Notes
Diffstat (limited to 'devel/dotconf++')
-rw-r--r--devel/dotconf++/Makefile1
-rw-r--r--devel/dotconf++/files/patch-README14
-rw-r--r--devel/dotconf++/files/patch-doc-dotconfpp.html15
-rw-r--r--devel/dotconf++/files/patch-src-dotconfpp.cc11
-rw-r--r--devel/dotconf++/files/patch-src-dotconfpp.h20
-rw-r--r--devel/dotconf++/files/patch-src-example1.cc11
-rw-r--r--devel/dotconf++/files/patch-src-example2.cc11
7 files changed, 83 insertions, 0 deletions
diff --git a/devel/dotconf++/Makefile b/devel/dotconf++/Makefile
index f3c07db22e65..f09bc3bf1393 100644
--- a/devel/dotconf++/Makefile
+++ b/devel/dotconf++/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dotconfpp
PORTVERSION= 0.0.4a
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://voodoo.com.ua/dotconf++/
DISTNAME= ${PORTNAME}-${PORTVERSION}
diff --git a/devel/dotconf++/files/patch-README b/devel/dotconf++/files/patch-README
new file mode 100644
index 000000000000..21ee2fb8ddae
--- /dev/null
+++ b/devel/dotconf++/files/patch-README
@@ -0,0 +1,14 @@
+--- README.orig Fri May 16 12:25:35 2003
++++ README Thu Jul 7 17:01:27 2005
+@@ -80,9 +80,9 @@
+ 1. Opening configuration file
+ * Create configuration document object:
+
+- DOTCONFDocument * conf = new DOTCONFDocument(DOTCONFDocument::CASEINSENSETIVE);
++ DOTCONFDocument * conf = new DOTCONFDocument(DOTCONFDocument::CASEINSENSITIVE);
+ or
+- DOTCONFDocument * conf = new DOTCONFDocument(DOTCONFDocument::CASESENSETIVE);
++ DOTCONFDocument * conf = new DOTCONFDocument(DOTCONFDocument::CASESENSITIVE);
+ * [OPTIONAL] Set required options
+
+ const char * requiredOptions[] = {"Users", NULL};
diff --git a/devel/dotconf++/files/patch-doc-dotconfpp.html b/devel/dotconf++/files/patch-doc-dotconfpp.html
new file mode 100644
index 000000000000..31397771c61b
--- /dev/null
+++ b/devel/dotconf++/files/patch-doc-dotconfpp.html
@@ -0,0 +1,15 @@
+--- doc/dotconfpp.html.orig Fri May 16 12:26:05 2003
++++ doc/dotconfpp.html Thu Jul 7 17:06:38 2005
+@@ -133,10 +133,10 @@
+ <li>Create configuration document object:<br>
+ <br style="color: rgb(0, 0, 255);">
+ <span style="color: rgb(0, 0, 255);">DOTCONFDocument * conf =
+-new DOTCONFDocument(DOTCONFDocument::CASEINSENSETIVE);<br>
++new DOTCONFDocument(DOTCONFDocument::CASEINSENSITIVE);<br>
+ <span style="color: rgb(0, 0, 0);">or<br>
+ </span></span><span style="color: rgb(0, 0, 255);">DOTCONFDocument
+-* conf = new DOTCONFDocument(DOTCONFDocument::CASESENSETIVE);<br>
++* conf = new DOTCONFDocument(DOTCONFDocument::CASESENSITIVE);<br>
+ <br>
+ </span></li>
+ <li><span style="color: rgb(0, 0, 255);"><span
diff --git a/devel/dotconf++/files/patch-src-dotconfpp.cc b/devel/dotconf++/files/patch-src-dotconfpp.cc
new file mode 100644
index 000000000000..663040868b68
--- /dev/null
+++ b/devel/dotconf++/files/patch-src-dotconfpp.cc
@@ -0,0 +1,11 @@
+--- src/dotconfpp.cc.orig Fri Jun 25 14:03:20 2004
++++ src/dotconfpp.cc Thu Jul 7 17:03:58 2005
+@@ -53,7 +53,7 @@
+ mempool(NULL),
+ curParent(NULL), curPrev(NULL), curLine(0), file(NULL), fileName(NULL)
+ {
+- if(caseSensitivity == CASESENSETIVE){
++ if(caseSensitivity == CASESENSITIVE){
+ cmp_func = strcmp;
+ } else {
+ cmp_func = strcasecmp;
diff --git a/devel/dotconf++/files/patch-src-dotconfpp.h b/devel/dotconf++/files/patch-src-dotconfpp.h
new file mode 100644
index 000000000000..6d25d9bb0422
--- /dev/null
+++ b/devel/dotconf++/files/patch-src-dotconfpp.h
@@ -0,0 +1,20 @@
+--- src/dotconfpp.h.orig Wed May 14 19:10:26 2003
++++ src/dotconfpp.h Thu Jul 7 17:02:43 2005
+@@ -75,7 +75,7 @@
+ class DOTCONFDocument
+ {
+ public:
+- enum CaseSensitive { CASESENSETIVE, CASEINSENSETIVE };
++ enum CaseSensitive { CASESENSITIVE, CASEINSENSITIVE };
+ protected:
+ AsyncDNSMemPool * mempool;
+ private:
+@@ -103,7 +103,7 @@
+ virtual void error(int lineNum, const char * fileName, const char * fmt, ...);
+
+ public:
+- DOTCONFDocument(CaseSensitive caseSensitivity = CASESENSETIVE);
++ DOTCONFDocument(CaseSensitive caseSensitivity = CASESENSITIVE);
+ virtual ~DOTCONFDocument();
+
+ int setContent(const char * _fileName);
diff --git a/devel/dotconf++/files/patch-src-example1.cc b/devel/dotconf++/files/patch-src-example1.cc
new file mode 100644
index 000000000000..5428cdd9d9fc
--- /dev/null
+++ b/devel/dotconf++/files/patch-src-example1.cc
@@ -0,0 +1,11 @@
+--- src/example1/example1.cc.orig Sat Apr 10 15:22:00 2004
++++ src/example1/example1.cc Wed Jul 13 20:20:47 2005
+@@ -54,7 +54,7 @@
+
+ int main()
+ {
+- DOTCONFDocument *conf = new DOTCONFDocument(DOTCONFDocument::CASEINSENSETIVE);
++ DOTCONFDocument *conf = new DOTCONFDocument(DOTCONFDocument::CASEINSENSITIVE);
+ const DOTCONFDocumentNode * node = NULL;
+ const char * v = NULL;
+ char * fqdn = NULL;
diff --git a/devel/dotconf++/files/patch-src-example2.cc b/devel/dotconf++/files/patch-src-example2.cc
new file mode 100644
index 000000000000..5323d68ba424
--- /dev/null
+++ b/devel/dotconf++/files/patch-src-example2.cc
@@ -0,0 +1,11 @@
+--- src/example2/example2.cc.orig Wed May 14 17:10:26 2003
++++ src/example2/example2.cc Wed Jul 13 20:21:29 2005
+@@ -51,7 +51,7 @@
+
+ int main(int argc, char * argv[])
+ {
+- DOTCONFDocument conf(DOTCONFDocument::CASEINSENSETIVE);
++ DOTCONFDocument conf(DOTCONFDocument::CASEINSENSITIVE);
+
+ conf.setRequiredOptionNames(requiredOptions);
+