aboutsummaryrefslogtreecommitdiff
path: root/devel/dotconf
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-10-18 13:04:50 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-10-18 13:04:50 +0000
commit21ac43e1156ed79ea2d3ce367b5d6793bd6a5826 (patch)
tree2dec44174376855078c33d50c2b2d92425af0ad5 /devel/dotconf
parent20ca7e193692c26e268820b8435ccf2ad30e6d68 (diff)
Notes
Diffstat (limited to 'devel/dotconf')
-rw-r--r--devel/dotconf/Makefile24
-rw-r--r--devel/dotconf/distinfo4
-rw-r--r--devel/dotconf/files/patch-ltmain.sh25
-rw-r--r--devel/dotconf/pkg-descr2
-rw-r--r--devel/dotconf/pkg-plist138
5 files changed, 78 insertions, 115 deletions
diff --git a/devel/dotconf/Makefile b/devel/dotconf/Makefile
index a1a1a82e5ae2..0c73e0bb42a8 100644
--- a/devel/dotconf/Makefile
+++ b/devel/dotconf/Makefile
@@ -7,30 +7,34 @@
#
PORTNAME= dotconf
-PORTVERSION= 1.1.0
+PORTVERSION= 1.3
CATEGORIES= devel
-MASTER_SITES= http://www.azzit.de/dotconf/download/v1.1/
+MASTER_SITES= GENTOO/distfiles
MAINTAINER= ports@FreeBSD.org
COMMENT= A simple, powerful configuration-file parser
-USE_AUTOTOOLS= libtool
+LICENSE= LGPL21
+
USE_GNOME= gnomehack pkgconfig
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-pre-patch:
- @${REINPLACE_CMD} -e 's|-Wall -g||' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|-release $(LT_RELEASE)||' ${WRKSRC}/src/Makefile.in
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/^SUBDIR/s|=.*|= src|' ${WRKSRC}/Makefile.in
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/*.txt ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
- ${TAR} -C ${WRKSRC}/examples -cf - . | \
- ${TAR} -C ${EXAMPLESDIR} --unlink -xf -
- @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
+.for ex in README argdouble caseinsensitive context duplicates errorhandler \
+ fallback libpool maketest.sh modules noinline simple
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} ${ex} ${EXAMPLESDIR})
+.endfor
.endif
.include <bsd.port.mk>
diff --git a/devel/dotconf/distinfo b/devel/dotconf/distinfo
index 3951abb2c7b8..5901964f9489 100644
--- a/devel/dotconf/distinfo
+++ b/devel/dotconf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dotconf-1.1.0.tar.gz) = 84e2a0f2ddfcc5b4692a02cc9c5708d8dcb24205d9482cc016733fe297597806
-SIZE (dotconf-1.1.0.tar.gz) = 199548
+SHA256 (dotconf-1.3.tar.gz) = b0bccd7251df50b68b82888c5f9fa7932bd68ee3b9e880bce9456e692bf13e8e
+SIZE (dotconf-1.3.tar.gz) = 333301
diff --git a/devel/dotconf/files/patch-ltmain.sh b/devel/dotconf/files/patch-ltmain.sh
deleted file mode 100644
index da9a5a6f7534..000000000000
--- a/devel/dotconf/files/patch-ltmain.sh
+++ /dev/null
@@ -1,25 +0,0 @@
---- ltmain.sh.orig Thu Jul 26 18:28:06 2001
-+++ ltmain.sh Sun Jan 27 23:19:36 2002
-@@ -2408,6 +2408,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test $build_libtool_need_lc = "yes"; then
-@@ -4175,10 +4178,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/dotconf/pkg-descr b/devel/dotconf/pkg-descr
index af63577aa866..53dec89d6bc2 100644
--- a/devel/dotconf/pkg-descr
+++ b/devel/dotconf/pkg-descr
@@ -11,4 +11,4 @@ config files. Some behaviour can be toggled with flags at runtime.
To keep dotconf from printing out warnings, you can install your
own customized error handler.
-WWW: http://www.azzit.de/dotconf/
+WWW: http://github.com/williamh/dotconf
diff --git a/devel/dotconf/pkg-plist b/devel/dotconf/pkg-plist
index 9ae76f3b7e08..818d69581551 100644
--- a/devel/dotconf/pkg-plist
+++ b/devel/dotconf/pkg-plist
@@ -1,83 +1,67 @@
-@comment $FreeBSD$
-bin/dotconf-config
include/dotconf.h
-include/libpool.h
lib/libdotconf.a
lib/libdotconf.la
lib/libdotconf.so
lib/libdotconf.so.0
libdata/pkgconfig/dotconf.pc
-lib/libpool.a
-share/aclocal/dotconf.m4
-%%PORTDOCS%%%%DOCSDIR%%/dotconf-api.txt
-%%PORTDOCS%%%%DOCSDIR%%/dotconf-features.txt
-%%PORTDOCS%%%%EXAMPLESDIR%%/README
-%%PORTDOCS%%%%EXAMPLESDIR%%/argdouble/Makefile
-%%PORTDOCS%%%%EXAMPLESDIR%%/argdouble/argdouble.conf
-%%PORTDOCS%%%%EXAMPLESDIR%%/argdouble/example_argdouble.dsp
-%%PORTDOCS%%%%EXAMPLESDIR%%/argdouble/output
-%%PORTDOCS%%%%EXAMPLESDIR%%/argdouble/testoutput
-%%PORTDOCS%%%%EXAMPLESDIR%%/argdouble/argdouble.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/caseinsensitive/Makefile
-%%PORTDOCS%%%%EXAMPLESDIR%%/caseinsensitive/caseinsensitive.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/caseinsensitive/caseinsensitive.conf
-%%PORTDOCS%%%%EXAMPLESDIR%%/caseinsensitive/example_caseinsensitive.dsp
-%%PORTDOCS%%%%EXAMPLESDIR%%/context/Makefile
-%%PORTDOCS%%%%EXAMPLESDIR%%/context/context.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/context/context.conf
-%%PORTDOCS%%%%EXAMPLESDIR%%/context/example_context.dsp
-%%PORTDOCS%%%%EXAMPLESDIR%%/errorhandler/Makefile
-%%PORTDOCS%%%%EXAMPLESDIR%%/errorhandler/errorhandler.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/errorhandler/errorhandler.conf
-%%PORTDOCS%%%%EXAMPLESDIR%%/errorhandler/example_errorhandler.dsp
-%%PORTDOCS%%%%EXAMPLESDIR%%/modules/Makefile
-%%PORTDOCS%%%%EXAMPLESDIR%%/modules/include.conf
-%%PORTDOCS%%%%EXAMPLESDIR%%/modules/module.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/modules/my_module.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/modules/sample.conf
-%%PORTDOCS%%%%EXAMPLESDIR%%/modules/example_modules.dsp
-%%PORTDOCS%%%%EXAMPLESDIR%%/simple/Makefile
-%%PORTDOCS%%%%EXAMPLESDIR%%/simple/included.conf
-%%PORTDOCS%%%%EXAMPLESDIR%%/simple/linecat.conf
-%%PORTDOCS%%%%EXAMPLESDIR%%/simple/simple.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/simple/simple.conf
-%%PORTDOCS%%%%EXAMPLESDIR%%/simple/example_simple.dsp
-%%PORTDOCS%%%%EXAMPLESDIR%%/duplicates/Makefile
-%%PORTDOCS%%%%EXAMPLESDIR%%/duplicates/duplicate.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/duplicates/first_module.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/duplicates/sample.conf
-%%PORTDOCS%%%%EXAMPLESDIR%%/duplicates/second_module.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/fallback/Makefile
-%%PORTDOCS%%%%EXAMPLESDIR%%/fallback/fallback.conf
-%%PORTDOCS%%%%EXAMPLESDIR%%/fallback/fallback.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/noinline/Makefile
-%%PORTDOCS%%%%EXAMPLESDIR%%/noinline/noinline.conf
-%%PORTDOCS%%%%EXAMPLESDIR%%/caseinsensitive/output
-%%PORTDOCS%%%%EXAMPLESDIR%%/caseinsensitive/testoutput
-%%PORTDOCS%%%%EXAMPLESDIR%%/context/output
-%%PORTDOCS%%%%EXAMPLESDIR%%/context/testoutput
-%%PORTDOCS%%%%EXAMPLESDIR%%/errorhandler/output
-%%PORTDOCS%%%%EXAMPLESDIR%%/errorhandler/testoutput
-%%PORTDOCS%%%%EXAMPLESDIR%%/modules/output
-%%PORTDOCS%%%%EXAMPLESDIR%%/modules/testoutput
-%%PORTDOCS%%%%EXAMPLESDIR%%/simple/output
-%%PORTDOCS%%%%EXAMPLESDIR%%/simple/testoutput
-%%PORTDOCS%%%%EXAMPLESDIR%%/duplicates/output
-%%PORTDOCS%%%%EXAMPLESDIR%%/duplicates/testoutput
-%%PORTDOCS%%%%EXAMPLESDIR%%/fallback/output
-%%PORTDOCS%%%%EXAMPLESDIR%%/fallback/testoutput
-%%PORTDOCS%%%%EXAMPLESDIR%%/noinline/noinline.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/noinline/output
-%%PORTDOCS%%%%EXAMPLESDIR%%/noinline/testoutput
-%%PORTDOCS%%%%EXAMPLESDIR%%/maketest.sh
-%%PORTDOCS%%@dirrm share/doc/dotconf
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/argdouble
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/context
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/errorhandler
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/noinline
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/fallback
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/modules
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/simple
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/duplicates
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/caseinsensitive
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%DOCSDIR%%/dotconf-api.txt
+%%DOCSDIR%%/dotconf-features.txt
+%%EXAMPLESDIR%%/README
+%%EXAMPLESDIR%%/argdouble/Makefile
+%%EXAMPLESDIR%%/argdouble/argdouble.c
+%%EXAMPLESDIR%%/argdouble/argdouble.conf
+%%EXAMPLESDIR%%/argdouble/output
+%%EXAMPLESDIR%%/caseinsensitive/Makefile
+%%EXAMPLESDIR%%/caseinsensitive/caseinsensitive.c
+%%EXAMPLESDIR%%/caseinsensitive/caseinsensitive.conf
+%%EXAMPLESDIR%%/caseinsensitive/output
+%%EXAMPLESDIR%%/context/Makefile
+%%EXAMPLESDIR%%/context/context.c
+%%EXAMPLESDIR%%/context/context.conf
+%%EXAMPLESDIR%%/context/output
+%%EXAMPLESDIR%%/duplicates/Makefile
+%%EXAMPLESDIR%%/duplicates/duplicate.c
+%%EXAMPLESDIR%%/duplicates/first_module.c
+%%EXAMPLESDIR%%/duplicates/output
+%%EXAMPLESDIR%%/duplicates/sample.conf
+%%EXAMPLESDIR%%/duplicates/second_module.c
+%%EXAMPLESDIR%%/errorhandler/Makefile
+%%EXAMPLESDIR%%/errorhandler/errorhandler.c
+%%EXAMPLESDIR%%/errorhandler/errorhandler.conf
+%%EXAMPLESDIR%%/errorhandler/output
+%%EXAMPLESDIR%%/fallback/Makefile
+%%EXAMPLESDIR%%/fallback/fallback.c
+%%EXAMPLESDIR%%/fallback/fallback.conf
+%%EXAMPLESDIR%%/fallback/output
+%%EXAMPLESDIR%%/libpool/Makefile
+%%EXAMPLESDIR%%/libpool/libpool.h
+%%EXAMPLESDIR%%/libpool/pool.c
+%%EXAMPLESDIR%%/maketest.sh
+%%EXAMPLESDIR%%/modules/Makefile
+%%EXAMPLESDIR%%/modules/include.conf
+%%EXAMPLESDIR%%/modules/module.c
+%%EXAMPLESDIR%%/modules/my_module.c
+%%EXAMPLESDIR%%/modules/output
+%%EXAMPLESDIR%%/modules/sample.conf
+%%EXAMPLESDIR%%/noinline/Makefile
+%%EXAMPLESDIR%%/noinline/noinline.c
+%%EXAMPLESDIR%%/noinline/noinline.conf
+%%EXAMPLESDIR%%/noinline/output
+%%EXAMPLESDIR%%/simple/Makefile
+%%EXAMPLESDIR%%/simple/included.conf
+%%EXAMPLESDIR%%/simple/linecat.conf
+%%EXAMPLESDIR%%/simple/output
+%%EXAMPLESDIR%%/simple/simple.c
+%%EXAMPLESDIR%%/simple/simple.conf
+@dirrm %%EXAMPLESDIR%%/argdouble
+@dirrm %%EXAMPLESDIR%%/caseinsensitive
+@dirrm %%EXAMPLESDIR%%/context
+@dirrm %%EXAMPLESDIR%%/duplicates
+@dirrm %%EXAMPLESDIR%%/errorhandler
+@dirrm %%EXAMPLESDIR%%/fallback
+@dirrm %%EXAMPLESDIR%%/libpool
+@dirrm %%EXAMPLESDIR%%/modules
+@dirrm %%EXAMPLESDIR%%/noinline
+@dirrm %%EXAMPLESDIR%%/simple
+@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%