aboutsummaryrefslogtreecommitdiff
path: root/devel/doxygen/files
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-12-30 02:26:32 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-12-30 02:26:32 +0000
commit033d1bb401501f42baae874c20ecd197a07747d4 (patch)
tree1b3a9d28cefb468d9addc92d8b6d58d575d6aa38 /devel/doxygen/files
parent1406dcb4fa54f7e041690cac08585b6b514c5d23 (diff)
Notes
Diffstat (limited to 'devel/doxygen/files')
-rw-r--r--devel/doxygen/files/patch-addon-doxywizard-Makefile.in22
-rw-r--r--devel/doxygen/files/patch-configure37
2 files changed, 54 insertions, 5 deletions
diff --git a/devel/doxygen/files/patch-addon-doxywizard-Makefile.in b/devel/doxygen/files/patch-addon-doxywizard-Makefile.in
new file mode 100644
index 000000000000..af5da92cf1f8
--- /dev/null
+++ b/devel/doxygen/files/patch-addon-doxywizard-Makefile.in
@@ -0,0 +1,22 @@
+--- addon/doxywizard/Makefile.in.orig 2008-12-06 08:14:58.000000000 -0500
++++ addon/doxywizard/Makefile.in 2008-12-28 15:32:07.000000000 -0500
+@@ -10,16 +10,16 @@
+ # See the GNU General Public License for more details.
+ #
+
+-QMAKE = qmake
++QMAKE = qmake-qt4
+
+ all: Makefile.doxywizard
+ $(MAKE) -f Makefile.doxywizard
+
+ Makefile.doxywizard: doxywizard.pro
+- $(QTDIR)/bin/qmake doxywizard.pro -o Makefile.doxywizard
++ $(QTDIR)/bin/qmake-qt4 doxywizard.pro -o Makefile.doxywizard
+
+ qmake:
+- $(QTDIR)/bin/qmake doxywizard.pro -o Makefile.doxywizard
++ $(QTDIR)/bin/qmake-qt4 doxywizard.pro -o Makefile.doxywizard
+
+ clean: Makefile.doxywizard
+ $(MAKE) -f Makefile.doxywizard clean
diff --git a/devel/doxygen/files/patch-configure b/devel/doxygen/files/patch-configure
index 8ba6ca7fb6a0..2571300fd75b 100644
--- a/devel/doxygen/files/patch-configure
+++ b/devel/doxygen/files/patch-configure
@@ -1,6 +1,33 @@
---- configure.orig Sat Oct 28 18:20:11 2006
-+++ configure Sun Feb 25 15:23:52 2007
-@@ -525,7 +525,7 @@
+--- configure.orig 2008-12-26 14:22:39.000000000 -0500
++++ configure 2008-12-28 16:27:43.000000000 -0500
+@@ -269,7 +269,7 @@
+ echo " QTDIR environment variable not set!"
+ echo -n " Checking for Qt..."
+ for d in /usr/{lib,share,qt}/{qt-4,qt4,qt,qt*,4}; do
+- if test -x "$d/bin/qmake"; then
++ if test -x "$d/bin/qmake-qt4"; then
+ QTDIR=$d
+ fi
+ done
+@@ -280,7 +280,7 @@
+ if test -z "$QTDIR"; then
+ echo "QTDIR not set and Qt not found at standard locations!"
+ echo
+- echo "Set the QTDIR environment variable such that \$QTDIR/bin/qmake exists."
++ echo "Set the QTDIR environment variable such that \$QTDIR/bin/qmake-qt4 exists."
+ echo "check the Qt installation instructions!"
+ exit 2
+ fi
+@@ -565,7 +565,7 @@
+ fi
+ if test "$f_wizard" = YES; then
+ cat >> .tmakeconfig <<EOF
+-TMAKE_MOC = $QTDIR/bin/moc
++TMAKE_MOC = $QTDIR/bin/moc-qt4
+ EOF
+ fi
+
+@@ -575,7 +575,7 @@
EOF
fi
@@ -9,7 +36,7 @@
for i in $f_inmakefiles ; do
SRC=$i
-@@ -541,10 +541,8 @@
+@@ -591,10 +591,8 @@
if test $i = Makefile.in; then
echo "" >> $DST
echo "all: src/version.cpp " >> $DST
@@ -22,7 +49,7 @@
if test $f_wizard = YES; then
echo " \$(MAKE) -C addon/doxywizard" >> $DST
fi
-@@ -562,7 +560,7 @@
+@@ -616,7 +614,7 @@
echo " Created $DST from $SRC..."
done