aboutsummaryrefslogtreecommitdiff
path: root/devel/doxygen
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2001-09-25 14:50:04 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2001-09-25 14:50:04 +0000
commit1832790004cbbdf2e41acf82edba5f86567a064c (patch)
tree8dbee2afae35e7bef52c6752fdd6bca8f654d2d1 /devel/doxygen
parentf34c5a6947cb228279c54c18306ba55e173eeafa (diff)
downloadports-1832790004cbbdf2e41acf82edba5f86567a064c.tar.gz
ports-1832790004cbbdf2e41acf82edba5f86567a064c.zip
Notes
Diffstat (limited to 'devel/doxygen')
-rw-r--r--devel/doxygen/Makefile19
-rw-r--r--devel/doxygen/distinfo2
-rw-r--r--devel/doxygen/files/patch-af35
-rw-r--r--devel/doxygen/pkg-plist295
4 files changed, 332 insertions, 19 deletions
diff --git a/devel/doxygen/Makefile b/devel/doxygen/Makefile
index 25c30b0b03eb..8f9801e280fc 100644
--- a/devel/doxygen/Makefile
+++ b/devel/doxygen/Makefile
@@ -6,20 +6,20 @@
#
PORTNAME= doxygen
-PORTVERSION= 1.2.6
+PORTVERSION= 1.2.10
CATEGORIES= devel
MASTER_SITES= ftp://ftp.stack.nl/pub/users/dimitri/
EXTRACT_SUFX= .src.tar.gz
-MAINTAINER= joep@di.nl
+MAINTAINER= dchapes@ddm.wox.org
-USE_QT_VER= 1
+USE_QT_VER= 2
USE_PERL5= yes
-MAKE_ENV+= QTDIR="${X11BASE}" PCFLAGS="${CFLAGS}" PCXXFLAGS="${CXXFLAGS}"
HAS_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS+=--prefix ${PREFIX} --perl ${PERL5} --make ${GMAKE}
-CONFIGURE_ENV+= QTDIR=${X11BASE}
+QT_NONSTANDARD= yes # non-standard configure arguements
+CONFIGURE_ARGS+=--prefix ${PREFIX} --perl ${PERL} --make ${GMAKE} \
+ --with-doxywizard
ALL_TARGET= all docs
.ifdef HAVE_LATEX
ALL_TARGET+= ps
@@ -30,6 +30,10 @@ PLIST_SUB+= HAVE_LATEX="@comment "
pre-configure:
@${PERL} -pi -e "s:gcc:${CC}:g ; s:g\+\+:${CXX}:g ; \
+ s:%%LIBQT%%:-l${QTNAME}:g ; \
+ s:%%MOC%%:${MOC}:g ; \
+ s:%%QT_INC%%:${X11BASE}/include/qt2:g ; \
+ s:%%QT_LIB%%:${X11BASE}/lib:g ; \
s:%%CFLAGS%%:${CFLAGS}:g ; \
s:%%CXXFLAGS%%:${CXXFLAGS}:g" ${WRKSRC}/tmake/lib/freebsd-g++/tmake.conf
@@ -37,9 +41,12 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/doxygen ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/bin/doxytag ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/bin/doxysearch ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/doxywizard ${PREFIX}/bin
.ifndef NOPORTDOCS
${MKDIR} ${PREFIX}/share/doc/doxygen/html
${INSTALL_DATA} ${WRKSRC}/html/* ${PREFIX}/share/doc/doxygen/html
+ ${TAR} -C ${WRKSRC} --exclude '*/Makefile*' -cf - examples | \
+ ${TAR} -C ${PREFIX}/share/doc/doxygen --unlink -xf -
.ifdef HAVE_LATEX
${INSTALL_DATA} ${WRKSRC}/latex/doxygen_manual.dvi \
${PREFIX}/share/doc/doxygen
diff --git a/devel/doxygen/distinfo b/devel/doxygen/distinfo
index 0456eb62e8af..dc766ffd9aff 100644
--- a/devel/doxygen/distinfo
+++ b/devel/doxygen/distinfo
@@ -1 +1 @@
-MD5 (doxygen-1.2.6.src.tar.gz) = 3acf1bdb6477d62d4bc62d19f8876114
+MD5 (doxygen-1.2.10.src.tar.gz) = 16b6d5a2ceb9629f46695cb01069f115
diff --git a/devel/doxygen/files/patch-af b/devel/doxygen/files/patch-af
index 46f4467074e6..639794693aa3 100644
--- a/devel/doxygen/files/patch-af
+++ b/devel/doxygen/files/patch-af
@@ -1,13 +1,12 @@
---- tmake/lib/freebsd-g++/tmake.conf.orig Wed Jul 28 08:21:38 1999
-+++ tmake/lib/freebsd-g++/tmake.conf Fri Feb 25 13:22:51 2000
+--- tmake/lib/freebsd-g++/tmake.conf.orig Thu Jul 29 00:21:38 1999
++++ tmake/lib/freebsd-g++/tmake.conf Tue Sep 25 23:14:36 2001
@@ -8,16 +8,16 @@
CONFIG = qt warn_on release
TMAKE_CC = gcc
-TMAKE_CFLAGS = -pipe
--TMAKE_CFLAGS_WARN_ON = -Wall -W
+TMAKE_CFLAGS = %%CFLAGS%%
-+TMAKE_CFLAGS_WARN_ON =
+ TMAKE_CFLAGS_WARN_ON = -Wall -W
TMAKE_CFLAGS_WARN_OFF =
-TMAKE_CFLAGS_RELEASE = -O2
-TMAKE_CFLAGS_DEBUG = -g
@@ -29,14 +28,30 @@
-TMAKE_INCDIR_X11 = /usr/X11R6/include
-TMAKE_LIBDIR_X11 = /usr/X11R6/lib
-TMAKE_INCDIR_QT = $(QTDIR)/include
-+TMAKE_INCDIR_X11 = $(QTDIR)/include
-+TMAKE_LIBDIR_X11 = $(QTDIR)/lib
-+TMAKE_INCDIR_QT = $(QTDIR)/include/X11/qt
- TMAKE_LIBDIR_QT = $(QTDIR)/lib
+-TMAKE_LIBDIR_QT = $(QTDIR)/lib
-TMAKE_INCDIR_OPENGL = /usr/X11R6/include
-TMAKE_LIBDIR_OPENGL = /usr/X11R6/lib
-+TMAKE_INCDIR_OPENGL = $(QTDIR)/include
-+TMAKE_LIBDIR_OPENGL = $(QTDIR)/lib
++TMAKE_INCDIR_X11 = $(X11BASE)/include
++TMAKE_LIBDIR_X11 = $(X11BASE)/lib
++TMAKE_INCDIR_QT = %%QT_INC%%
++TMAKE_LIBDIR_QT = %%QT_LIB%%
++TMAKE_INCDIR_OPENGL = $(X11BASE)/include
++TMAKE_LIBDIR_OPENGL = $(X11BASE)/lib
TMAKE_LINK = g++
TMAKE_LINK_SHLIB = g++
+@@ -46,11 +46,11 @@
+
+ TMAKE_LIBS =
+ TMAKE_LIBS_X11 = -lXext -lX11 -lm
+-TMAKE_LIBS_QT = -lqt
+-TMAKE_LIBS_QT_OPENGL = -lqgl
++TMAKE_LIBS_QT = %%LIBQT%%
++TMAKE_LIBS_QT_OPENGL = -lqtgl
+ TMAKE_LIBS_OPENGL = -lMesaGL -lMesaGLU -lXmu
+
+-TMAKE_MOC = moc
++TMAKE_MOC = %%MOC%%
+
+ TMAKE_AR = ar cqs
+ TMAKE_RANLIB =
diff --git a/devel/doxygen/pkg-plist b/devel/doxygen/pkg-plist
index 705653811bde..cdacf23f4948 100644
--- a/devel/doxygen/pkg-plist
+++ b/devel/doxygen/pkg-plist
@@ -1,8 +1,254 @@
bin/doxygen
bin/doxytag
bin/doxysearch
-%%HAVE_LATEX%%share/doc/doxygen/doxygen_manual.dvi
-%%HAVE_LATEX%%share/doc/doxygen/doxygen_manual.ps
+bin/doxywizard
+%%PORTDOCS%%%%HAVE_LATEX%%share/doc/doxygen/doxygen_manual.dvi
+%%PORTDOCS%%%%HAVE_LATEX%%share/doc/doxygen/doxygen_manual.ps
+%%PORTDOCS%%share/doc/doxygen/examples/afterdoc.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/afterdoc.h
+%%PORTDOCS%%share/doc/doxygen/examples/afterdoc/html/afterdoc_8h-source.html
+%%PORTDOCS%%share/doc/doxygen/examples/afterdoc/html/annotated.html
+%%PORTDOCS%%share/doc/doxygen/examples/afterdoc/html/class_test-members.html
+%%PORTDOCS%%share/doc/doxygen/examples/afterdoc/html/class_test.html
+%%PORTDOCS%%share/doc/doxygen/examples/afterdoc/html/doxygen.css
+%%PORTDOCS%%share/doc/doxygen/examples/afterdoc/html/doxygen.gif
+%%PORTDOCS%%share/doc/doxygen/examples/afterdoc/html/files.html
+%%PORTDOCS%%share/doc/doxygen/examples/afterdoc/html/functions.html
+%%PORTDOCS%%share/doc/doxygen/examples/afterdoc/html/index.html
+%%PORTDOCS%%share/doc/doxygen/examples/author.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/author.cpp
+%%PORTDOCS%%share/doc/doxygen/examples/author/html/annotated.html
+%%PORTDOCS%%share/doc/doxygen/examples/author/html/bug.html
+%%PORTDOCS%%share/doc/doxygen/examples/author/html/class_windows_n_t.html
+%%PORTDOCS%%share/doc/doxygen/examples/author/html/doxygen.css
+%%PORTDOCS%%share/doc/doxygen/examples/author/html/doxygen.gif
+%%PORTDOCS%%share/doc/doxygen/examples/author/html/index.html
+%%PORTDOCS%%share/doc/doxygen/examples/author/html/pages.html
+%%PORTDOCS%%share/doc/doxygen/examples/autolink.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/autolink.cpp
+%%PORTDOCS%%share/doc/doxygen/examples/autolink/html/annotated.html
+%%PORTDOCS%%share/doc/doxygen/examples/autolink/html/autolink_8cpp.html
+%%PORTDOCS%%share/doc/doxygen/examples/autolink/html/class_test-members.html
+%%PORTDOCS%%share/doc/doxygen/examples/autolink/html/class_test.html
+%%PORTDOCS%%share/doc/doxygen/examples/autolink/html/doxygen.css
+%%PORTDOCS%%share/doc/doxygen/examples/autolink/html/doxygen.gif
+%%PORTDOCS%%share/doc/doxygen/examples/autolink/html/files.html
+%%PORTDOCS%%share/doc/doxygen/examples/autolink/html/functions.html
+%%PORTDOCS%%share/doc/doxygen/examples/autolink/html/globals.html
+%%PORTDOCS%%share/doc/doxygen/examples/autolink/html/index.html
+%%PORTDOCS%%share/doc/doxygen/examples/class.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/class.h
+%%PORTDOCS%%share/doc/doxygen/examples/class/html/annotated.html
+%%PORTDOCS%%share/doc/doxygen/examples/class/html/class_8h-source.html
+%%PORTDOCS%%share/doc/doxygen/examples/class/html/class_test.html
+%%PORTDOCS%%share/doc/doxygen/examples/class/html/doxygen.css
+%%PORTDOCS%%share/doc/doxygen/examples/class/html/doxygen.gif
+%%PORTDOCS%%share/doc/doxygen/examples/class/html/files.html
+%%PORTDOCS%%share/doc/doxygen/examples/class/html/index.html
+%%PORTDOCS%%share/doc/doxygen/examples/define.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/define.h
+%%PORTDOCS%%share/doc/doxygen/examples/define/html/define_8h-source.html
+%%PORTDOCS%%share/doc/doxygen/examples/define/html/define_8h.html
+%%PORTDOCS%%share/doc/doxygen/examples/define/html/doxygen.css
+%%PORTDOCS%%share/doc/doxygen/examples/define/html/doxygen.gif
+%%PORTDOCS%%share/doc/doxygen/examples/define/html/files.html
+%%PORTDOCS%%share/doc/doxygen/examples/define/html/globals.html
+%%PORTDOCS%%share/doc/doxygen/examples/define/html/index.html
+%%PORTDOCS%%share/doc/doxygen/examples/diagrams.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/diagrams_a.h
+%%PORTDOCS%%share/doc/doxygen/examples/diagrams_b.h
+%%PORTDOCS%%share/doc/doxygen/examples/diagrams_c.h
+%%PORTDOCS%%share/doc/doxygen/examples/diagrams_d.h
+%%PORTDOCS%%share/doc/doxygen/examples/diagrams_e.h
+%%PORTDOCS%%share/doc/doxygen/examples/enum.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/enum.h
+%%PORTDOCS%%share/doc/doxygen/examples/enum/html/annotated.html
+%%PORTDOCS%%share/doc/doxygen/examples/enum/html/class_test-members.html
+%%PORTDOCS%%share/doc/doxygen/examples/enum/html/class_test.html
+%%PORTDOCS%%share/doc/doxygen/examples/enum/html/doxygen.css
+%%PORTDOCS%%share/doc/doxygen/examples/enum/html/doxygen.gif
+%%PORTDOCS%%share/doc/doxygen/examples/enum/html/enum_8h-source.html
+%%PORTDOCS%%share/doc/doxygen/examples/enum/html/files.html
+%%PORTDOCS%%share/doc/doxygen/examples/enum/html/functions.html
+%%PORTDOCS%%share/doc/doxygen/examples/enum/html/index.html
+%%PORTDOCS%%share/doc/doxygen/examples/example.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/example.cpp
+%%PORTDOCS%%share/doc/doxygen/examples/example.tag
+%%PORTDOCS%%share/doc/doxygen/examples/example/html/annotated.html
+%%PORTDOCS%%share/doc/doxygen/examples/example/html/class_test-members.html
+%%PORTDOCS%%share/doc/doxygen/examples/example/html/class_test.html
+%%PORTDOCS%%share/doc/doxygen/examples/example/html/doxygen.css
+%%PORTDOCS%%share/doc/doxygen/examples/example/html/doxygen.gif
+%%PORTDOCS%%share/doc/doxygen/examples/example/html/example__test_8cpp-example.html
+%%PORTDOCS%%share/doc/doxygen/examples/example/html/examples.html
+%%PORTDOCS%%share/doc/doxygen/examples/example/html/functions.html
+%%PORTDOCS%%share/doc/doxygen/examples/example/html/index.html
+%%PORTDOCS%%share/doc/doxygen/examples/example_test.cpp
+%%PORTDOCS%%share/doc/doxygen/examples/file.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/file.h
+%%PORTDOCS%%share/doc/doxygen/examples/file/html/doxygen.css
+%%PORTDOCS%%share/doc/doxygen/examples/file/html/doxygen.gif
+%%PORTDOCS%%share/doc/doxygen/examples/file/html/file_8h-source.html
+%%PORTDOCS%%share/doc/doxygen/examples/file/html/file_8h.html
+%%PORTDOCS%%share/doc/doxygen/examples/file/html/files.html
+%%PORTDOCS%%share/doc/doxygen/examples/file/html/globals.html
+%%PORTDOCS%%share/doc/doxygen/examples/file/html/index.html
+%%PORTDOCS%%share/doc/doxygen/examples/func.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/func.h
+%%PORTDOCS%%share/doc/doxygen/examples/func/html/annotated.html
+%%PORTDOCS%%share/doc/doxygen/examples/func/html/class_test-members.html
+%%PORTDOCS%%share/doc/doxygen/examples/func/html/class_test.html
+%%PORTDOCS%%share/doc/doxygen/examples/func/html/doxygen.css
+%%PORTDOCS%%share/doc/doxygen/examples/func/html/doxygen.gif
+%%PORTDOCS%%share/doc/doxygen/examples/func/html/files.html
+%%PORTDOCS%%share/doc/doxygen/examples/func/html/func_8h-source.html
+%%PORTDOCS%%share/doc/doxygen/examples/func/html/functions.html
+%%PORTDOCS%%share/doc/doxygen/examples/func/html/index.html
+%%PORTDOCS%%share/doc/doxygen/examples/group.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/group.cpp
+%%PORTDOCS%%share/doc/doxygen/examples/group/html/annotated.html
+%%PORTDOCS%%share/doc/doxygen/examples/group/html/class_c1.html
+%%PORTDOCS%%share/doc/doxygen/examples/group/html/class_c2.html
+%%PORTDOCS%%share/doc/doxygen/examples/group/html/class_c3.html
+%%PORTDOCS%%share/doc/doxygen/examples/group/html/class_c4.html
+%%PORTDOCS%%share/doc/doxygen/examples/group/html/class_c5.html
+%%PORTDOCS%%share/doc/doxygen/examples/group/html/doxygen.css
+%%PORTDOCS%%share/doc/doxygen/examples/group/html/doxygen.gif
+%%PORTDOCS%%share/doc/doxygen/examples/group/html/files.html
+%%PORTDOCS%%share/doc/doxygen/examples/group/html/globals.html
+%%PORTDOCS%%share/doc/doxygen/examples/group/html/group_8cpp.html
+%%PORTDOCS%%share/doc/doxygen/examples/group/html/group__group1.html
+%%PORTDOCS%%share/doc/doxygen/examples/group/html/group__group2.html
+%%PORTDOCS%%share/doc/doxygen/examples/group/html/group__group3.html
+%%PORTDOCS%%share/doc/doxygen/examples/group/html/group__group4.html
+%%PORTDOCS%%share/doc/doxygen/examples/group/html/group__group5.html
+%%PORTDOCS%%share/doc/doxygen/examples/group/html/index.html
+%%PORTDOCS%%share/doc/doxygen/examples/group/html/modules.html
+%%PORTDOCS%%share/doc/doxygen/examples/group/html/namespace_n1.html
+%%PORTDOCS%%share/doc/doxygen/examples/group/html/namespaces.html
+%%PORTDOCS%%share/doc/doxygen/examples/include.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/include.cpp
+%%PORTDOCS%%share/doc/doxygen/examples/include/html/annotated.html
+%%PORTDOCS%%share/doc/doxygen/examples/include/html/class_test-members.html
+%%PORTDOCS%%share/doc/doxygen/examples/include/html/class_test.html
+%%PORTDOCS%%share/doc/doxygen/examples/include/html/doxygen.css
+%%PORTDOCS%%share/doc/doxygen/examples/include/html/doxygen.gif
+%%PORTDOCS%%share/doc/doxygen/examples/include/html/example.html
+%%PORTDOCS%%share/doc/doxygen/examples/include/html/functions.html
+%%PORTDOCS%%share/doc/doxygen/examples/include/html/index.html
+%%PORTDOCS%%share/doc/doxygen/examples/include/html/pages.html
+%%PORTDOCS%%share/doc/doxygen/examples/jdstyle.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/jdstyle.cpp
+%%PORTDOCS%%share/doc/doxygen/examples/jdstyle/html/annotated.html
+%%PORTDOCS%%share/doc/doxygen/examples/jdstyle/html/class_test-members.html
+%%PORTDOCS%%share/doc/doxygen/examples/jdstyle/html/class_test.html
+%%PORTDOCS%%share/doc/doxygen/examples/jdstyle/html/doxygen.css
+%%PORTDOCS%%share/doc/doxygen/examples/jdstyle/html/doxygen.gif
+%%PORTDOCS%%share/doc/doxygen/examples/jdstyle/html/functions.html
+%%PORTDOCS%%share/doc/doxygen/examples/jdstyle/html/index.html
+%%PORTDOCS%%share/doc/doxygen/examples/memgrp.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/memgrp.cpp
+%%PORTDOCS%%share/doc/doxygen/examples/memgrp/html/annotated.html
+%%PORTDOCS%%share/doc/doxygen/examples/memgrp/html/class_test-members.html
+%%PORTDOCS%%share/doc/doxygen/examples/memgrp/html/class_test.html
+%%PORTDOCS%%share/doc/doxygen/examples/memgrp/html/doxygen.css
+%%PORTDOCS%%share/doc/doxygen/examples/memgrp/html/doxygen.gif
+%%PORTDOCS%%share/doc/doxygen/examples/memgrp/html/files.html
+%%PORTDOCS%%share/doc/doxygen/examples/memgrp/html/functions.html
+%%PORTDOCS%%share/doc/doxygen/examples/memgrp/html/globals.html
+%%PORTDOCS%%share/doc/doxygen/examples/memgrp/html/index.html
+%%PORTDOCS%%share/doc/doxygen/examples/memgrp/html/memgrp_8cpp.html
+%%PORTDOCS%%share/doc/doxygen/examples/overload.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/overload.cpp
+%%PORTDOCS%%share/doc/doxygen/examples/overload/html/annotated.html
+%%PORTDOCS%%share/doc/doxygen/examples/overload/html/class_test-members.html
+%%PORTDOCS%%share/doc/doxygen/examples/overload/html/class_test.html
+%%PORTDOCS%%share/doc/doxygen/examples/overload/html/doxygen.css
+%%PORTDOCS%%share/doc/doxygen/examples/overload/html/doxygen.gif
+%%PORTDOCS%%share/doc/doxygen/examples/overload/html/functions.html
+%%PORTDOCS%%share/doc/doxygen/examples/overload/html/index.html
+%%PORTDOCS%%share/doc/doxygen/examples/page.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/page.doc
+%%PORTDOCS%%share/doc/doxygen/examples/page/html/doxygen.css
+%%PORTDOCS%%share/doc/doxygen/examples/page/html/doxygen.gif
+%%PORTDOCS%%share/doc/doxygen/examples/page/html/index.html
+%%PORTDOCS%%share/doc/doxygen/examples/page/html/page1.html
+%%PORTDOCS%%share/doc/doxygen/examples/page/html/page2.html
+%%PORTDOCS%%share/doc/doxygen/examples/page/html/pages.html
+%%PORTDOCS%%share/doc/doxygen/examples/par.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/par.cpp
+%%PORTDOCS%%share/doc/doxygen/examples/par/html/annotated.html
+%%PORTDOCS%%share/doc/doxygen/examples/par/html/class_test.html
+%%PORTDOCS%%share/doc/doxygen/examples/par/html/doxygen.css
+%%PORTDOCS%%share/doc/doxygen/examples/par/html/doxygen.gif
+%%PORTDOCS%%share/doc/doxygen/examples/par/html/index.html
+%%PORTDOCS%%share/doc/doxygen/examples/qtstyle.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/qtstyle.cpp
+%%PORTDOCS%%share/doc/doxygen/examples/qtstyle/html/annotated.html
+%%PORTDOCS%%share/doc/doxygen/examples/qtstyle/html/class_test-members.html
+%%PORTDOCS%%share/doc/doxygen/examples/qtstyle/html/class_test.html
+%%PORTDOCS%%share/doc/doxygen/examples/qtstyle/html/doxygen.css
+%%PORTDOCS%%share/doc/doxygen/examples/qtstyle/html/doxygen.gif
+%%PORTDOCS%%share/doc/doxygen/examples/qtstyle/html/functions.html
+%%PORTDOCS%%share/doc/doxygen/examples/qtstyle/html/index.html
+%%PORTDOCS%%share/doc/doxygen/examples/relates.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/relates.cpp
+%%PORTDOCS%%share/doc/doxygen/examples/relates/html/annotated.html
+%%PORTDOCS%%share/doc/doxygen/examples/relates/html/class_string-members.html
+%%PORTDOCS%%share/doc/doxygen/examples/relates/html/class_string.html
+%%PORTDOCS%%share/doc/doxygen/examples/relates/html/doxygen.css
+%%PORTDOCS%%share/doc/doxygen/examples/relates/html/doxygen.gif
+%%PORTDOCS%%share/doc/doxygen/examples/relates/html/functions.html
+%%PORTDOCS%%share/doc/doxygen/examples/relates/html/index.html
+%%PORTDOCS%%share/doc/doxygen/examples/restypedef.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/restypedef.cpp
+%%PORTDOCS%%share/doc/doxygen/examples/restypedef/html/annotated.html
+%%PORTDOCS%%share/doc/doxygen/examples/restypedef/html/doxygen.css
+%%PORTDOCS%%share/doc/doxygen/examples/restypedef/html/doxygen.gif
+%%PORTDOCS%%share/doc/doxygen/examples/restypedef/html/files.html
+%%PORTDOCS%%share/doc/doxygen/examples/restypedef/html/functions.html
+%%PORTDOCS%%share/doc/doxygen/examples/restypedef/html/globals.html
+%%PORTDOCS%%share/doc/doxygen/examples/restypedef/html/index.html
+%%PORTDOCS%%share/doc/doxygen/examples/restypedef/html/restypedef_8cpp.html
+%%PORTDOCS%%share/doc/doxygen/examples/restypedef/html/struct_coord_struct-members.html
+%%PORTDOCS%%share/doc/doxygen/examples/restypedef/html/struct_coord_struct.html
+%%PORTDOCS%%share/doc/doxygen/examples/structcmd.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/structcmd.h
+%%PORTDOCS%%share/doc/doxygen/examples/structcmd/html/doxygen.css
+%%PORTDOCS%%share/doc/doxygen/examples/structcmd/html/doxygen.gif
+%%PORTDOCS%%share/doc/doxygen/examples/structcmd/html/files.html
+%%PORTDOCS%%share/doc/doxygen/examples/structcmd/html/globals.html
+%%PORTDOCS%%share/doc/doxygen/examples/structcmd/html/index.html
+%%PORTDOCS%%share/doc/doxygen/examples/structcmd/html/structcmd_8h-source.html
+%%PORTDOCS%%share/doc/doxygen/examples/structcmd/html/structcmd_8h.html
+%%PORTDOCS%%share/doc/doxygen/examples/tag.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/tag.cpp
+%%PORTDOCS%%share/doc/doxygen/examples/tag/html/annotated.html
+%%PORTDOCS%%share/doc/doxygen/examples/tag/html/class_tag-members.html
+%%PORTDOCS%%share/doc/doxygen/examples/tag/html/class_tag.gif
+%%PORTDOCS%%share/doc/doxygen/examples/tag/html/class_tag.html
+%%PORTDOCS%%share/doc/doxygen/examples/tag/html/doxygen.css
+%%PORTDOCS%%share/doc/doxygen/examples/tag/html/doxygen.gif
+%%PORTDOCS%%share/doc/doxygen/examples/tag/html/functions.html
+%%PORTDOCS%%share/doc/doxygen/examples/tag/html/hierarchy.html
+%%PORTDOCS%%share/doc/doxygen/examples/tag/html/index.html
+%%PORTDOCS%%share/doc/doxygen/examples/tag/html/installdox
+%%PORTDOCS%%share/doc/doxygen/examples/templ.cfg
+%%PORTDOCS%%share/doc/doxygen/examples/templ.cpp
+%%PORTDOCS%%share/doc/doxygen/examples/template/html/annotated.html
+%%PORTDOCS%%share/doc/doxygen/examples/template/html/class_test-members.html
+%%PORTDOCS%%share/doc/doxygen/examples/template/html/class_test.html
+%%PORTDOCS%%share/doc/doxygen/examples/template/html/class_test_3_01_t_01_5_4-members.html
+%%PORTDOCS%%share/doc/doxygen/examples/template/html/class_test_3_01_t_01_5_4.gif
+%%PORTDOCS%%share/doc/doxygen/examples/template/html/class_test_3_01_t_01_5_4.html
+%%PORTDOCS%%share/doc/doxygen/examples/template/html/class_test_3_01void_01_5_00_01200_01_4-members.html
+%%PORTDOCS%%share/doc/doxygen/examples/template/html/class_test_3_01void_01_5_00_01200_01_4.gif
+%%PORTDOCS%%share/doc/doxygen/examples/template/html/class_test_3_01void_01_5_00_01200_01_4.html
+%%PORTDOCS%%share/doc/doxygen/examples/template/html/doxygen.css
+%%PORTDOCS%%share/doc/doxygen/examples/template/html/doxygen.gif
+%%PORTDOCS%%share/doc/doxygen/examples/template/html/functions.html
+%%PORTDOCS%%share/doc/doxygen/examples/template/html/hierarchy.html
+%%PORTDOCS%%share/doc/doxygen/examples/template/html/index.html
%%PORTDOCS%%share/doc/doxygen/html/autolink.html
%%PORTDOCS%%share/doc/doxygen/html/commands.html
%%PORTDOCS%%share/doc/doxygen/html/config.html
@@ -45,4 +291,49 @@ bin/doxysearch
%%PORTDOCS%%share/doc/doxygen/html/starting.html
%%PORTDOCS%%share/doc/doxygen/html/trouble.html
%%PORTDOCS%%@dirrm share/doc/doxygen/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/template/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/template
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/tag/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/tag
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/structcmd/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/structcmd
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/restypedef/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/restypedef
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/relates/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/relates
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/qtstyle/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/qtstyle
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/par/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/par
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/page/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/page
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/overload/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/overload
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/memgrp/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/memgrp
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/jdstyle/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/jdstyle
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/include/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/include
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/group/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/group
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/func/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/func
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/file/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/file
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/example/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/example
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/enum/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/enum
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/define/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/define
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/class/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/class
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/autolink/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/autolink
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/author/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/author
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/afterdoc/html
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples/afterdoc
+%%PORTDOCS%%@dirrm share/doc/doxygen/examples
%%PORTDOCS%%@dirrm share/doc/doxygen