aboutsummaryrefslogtreecommitdiff
path: root/devel/doxygen
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2016-09-27 16:32:52 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2016-09-27 16:32:52 +0000
commitea16d28b49566b902ca19ac4e40552ca63d7299f (patch)
treea1f07443c751a445876c45f218e2c383aa0879dc /devel/doxygen
parent499919c7a862b71107d9120724b970ad1c222e63 (diff)
Notes
Diffstat (limited to 'devel/doxygen')
-rw-r--r--devel/doxygen/Makefile2
-rw-r--r--devel/doxygen/distinfo6
-rw-r--r--devel/doxygen/files/patch-md5-dot24
3 files changed, 16 insertions, 16 deletions
diff --git a/devel/doxygen/Makefile b/devel/doxygen/Makefile
index 152c6d42eefa..318245561c9b 100644
--- a/devel/doxygen/Makefile
+++ b/devel/doxygen/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= doxygen
-PORTVERSION= 1.8.11
+PORTVERSION= 1.8.12
PORTEPOCH= 2
CATEGORIES= devel
MASTER_SITES= ftp://ftp.stack.nl/pub/users/dimitri/ \
diff --git a/devel/doxygen/distinfo b/devel/doxygen/distinfo
index fb176dd322e7..fd21f8b75d43 100644
--- a/devel/doxygen/distinfo
+++ b/devel/doxygen/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1467043745
-SHA256 (doxygen-1.8.11.src.tar.gz) = 65d08b46e48bd97186aef562dc366681045b119e00f83c5b61d05d37ea154049
-SIZE (doxygen-1.8.11.src.tar.gz) = 4834291
+TIMESTAMP = 1474244407
+SHA256 (doxygen-1.8.12.src.tar.gz) = 792d4091cbdf228549ff2033dd71ff7ea5029c6b436317cc5ec866e71302df6c
+SIZE (doxygen-1.8.12.src.tar.gz) = 4880613
diff --git a/devel/doxygen/files/patch-md5-dot b/devel/doxygen/files/patch-md5-dot
index a88947d60036..b98d4e01f9b1 100644
--- a/devel/doxygen/files/patch-md5-dot
+++ b/devel/doxygen/files/patch-md5-dot
@@ -1,4 +1,4 @@
---- src/dot.cpp.orig 2015-12-28 19:46:20 UTC
+--- src/dot.cpp.orig 2016-05-10 19:51:52 UTC
+++ src/dot.cpp
@@ -39,6 +39,7 @@
#include "dirdef.h"
@@ -8,10 +8,10 @@
#include "md5.h"
#include "memberlist.h"
#include "groupdef.h"
-@@ -2305,10 +2306,8 @@ void DotGfxHierarchyTable::createGraph(D
+@@ -2271,10 +2272,8 @@ void DotGfxHierarchyTable::createGraph(D
+ }
}
writeGraphFooter(md5stream);
- resetReNumbering();
- uchar md5_sig[16];
QCString sigStr(33);
- MD5Buffer((const unsigned char *)theGraph.data(),theGraph.length(),md5_sig);
@@ -20,7 +20,7 @@
bool regenerate=FALSE;
if (checkAndUpdateMd5Signature(absBaseName,sigStr) ||
!checkDeliverables(absImgName,absMapName))
-@@ -3072,10 +3071,8 @@ QCString computeMd5Signature(DotNode *ro
+@@ -3039,10 +3038,8 @@ QCString computeMd5Signature(DotNode *ro
}
}
writeGraphFooter(md5stream);
@@ -29,10 +29,10 @@
- MD5Buffer((const unsigned char *)buf.data(),buf.length(),md5_sig);
- MD5SigToString(md5_sig,sigStr.rawData(),33);
+ MD5Data((const unsigned char *)buf.data(),buf.length(),sigStr.rawData());
- if (reNumber)
- {
- resetReNumbering();
-@@ -4009,10 +4006,8 @@ QCString DotDirDeps::writeGraph(FTextStr
+ graphStr=buf.data();
+ //printf("md5: %s | file: %s\n",sigStr,baseName.data());
+ return sigStr;
+@@ -3954,10 +3951,8 @@ QCString DotDirDeps::writeGraph(FTextStr
FTextStream md5stream(&theGraph);
//m_dir->writeDepGraph(md5stream);
writeDotDirDepGraph(md5stream,m_dir,linkRelations);
@@ -44,7 +44,7 @@
bool regenerate=FALSE;
if (checkAndUpdateMd5Signature(absBaseName,sigStr) ||
!checkDeliverables(graphFormat==GOF_BITMAP ? absImgName :
-@@ -4154,10 +4149,8 @@ void generateGraphLegend(const char *pat
+@@ -4099,10 +4094,8 @@ void generateGraphLegend(const char *pat
md5stream << " Node18 -> Node9 [dir=\"back\",color=\"darkorchid3\",fontsize=\"" << FONTSIZE << "\",style=\"dashed\",label=\"m_usedClass\",fontname=\"" << FONTNAME << "\"];\n";
md5stream << " Node18 [shape=\"box\",label=\"Used\",fontsize=\"" << FONTSIZE << "\",height=0.2,width=0.4,fontname=\"" << FONTNAME << "\",color=\"black\",URL=\"$classUsed" << Doxygen::htmlFileExtension << "\"];\n";
writeGraphFooter(md5stream);
@@ -56,15 +56,15 @@
QCString absBaseName = (QCString)path+"/graph_legend";
QCString absDotName = absBaseName+".dot";
QCString imgExt = getDotImageExtension();
-@@ -4557,10 +4550,8 @@ QCString DotGroupCollaboration::writeGra
+@@ -4507,10 +4500,8 @@ QCString DotGroupCollaboration::writeGra
+ }
writeGraphFooter(md5stream);
- resetReNumbering();
- uchar md5_sig[16];
QCString sigStr(33);
- MD5Buffer((const unsigned char *)theGraph.data(),theGraph.length(),md5_sig);
- MD5SigToString(md5_sig,sigStr.rawData(),33);
+ MD5Data((const unsigned char *)theGraph.data(),theGraph.length(),sigStr.rawData());
QCString imgExt = getDotImageExtension();
- QCString imgFmt = Config_getEnum("DOT_IMAGE_FORMAT");
+ QCString imgFmt = Config_getEnum(DOT_IMAGE_FORMAT);
QCString baseName = m_diskName;