aboutsummaryrefslogtreecommitdiff
path: root/devel/dparser
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-03-17 09:56:26 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-03-17 09:56:26 +0000
commite1fe6a3bea193161583841589bb8737b846a39c3 (patch)
tree1c0722c065b7ed07af3bd41f7b2d26b1c42b29ab /devel/dparser
parent8e9c3f643192138c186046d42f2ebff56594d96e (diff)
downloadports-e1fe6a3bea193161583841589bb8737b846a39c3.tar.gz
ports-e1fe6a3bea193161583841589bb8737b846a39c3.zip
Notes
Diffstat (limited to 'devel/dparser')
-rw-r--r--devel/dparser/Makefile4
-rw-r--r--devel/dparser/distinfo5
-rw-r--r--devel/dparser/files/patch-parse.c53
3 files changed, 57 insertions, 5 deletions
diff --git a/devel/dparser/Makefile b/devel/dparser/Makefile
index bd1785331a1b..7b7060479c5b 100644
--- a/devel/dparser/Makefile
+++ b/devel/dparser/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= dparser
-PORTVERSION= 1.13
+PORTVERSION= 1.14
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -38,7 +38,7 @@ LIBDPARSE= libdparse.a
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64"
-BROKEN= "Does not build on ia64"
+BROKEN= Does not build on ia64
.endif
do-install:
diff --git a/devel/dparser/distinfo b/devel/dparser/distinfo
index fa2e127a51ed..fce9ccd86d0f 100644
--- a/devel/dparser/distinfo
+++ b/devel/dparser/distinfo
@@ -1,3 +1,2 @@
-MD5 (d-1.13-src.tar.gz) = fe049ca0805c98e41673d481b55c2274
-SHA256 (d-1.13-src.tar.gz) = bbd6e8014be2e5ab64f883ce76d06541b87143b3ea9c4426c14807daf747d953
-SIZE (d-1.13-src.tar.gz) = 200239
+MD5 (d-1.14-src.tar.gz) = 05069515deb5f9f470455845963c5c08
+SIZE (d-1.14-src.tar.gz) = 199284
diff --git a/devel/dparser/files/patch-parse.c b/devel/dparser/files/patch-parse.c
new file mode 100644
index 000000000000..788745b7d8de
--- /dev/null
+++ b/devel/dparser/files/patch-parse.c
@@ -0,0 +1,53 @@
+--- parse.c.orig Fri Feb 24 05:25:00 2006
++++ parse.c Fri Mar 3 02:04:47 2006
+@@ -834,6 +834,7 @@
+ cmp_priorities(PNode *x, PNode *y) {
+ StackPNode psx, psy;
+ StackInt isx, isy;
++ int r;
+
+ stack_clear(&psx); stack_clear(&psy); stack_clear(&isx); stack_clear(&isy);
+ get_exp_one(x, &psx, &isx);
+@@ -841,7 +842,7 @@
+ get_unshared_priorities(&psx, &psy, &isx, &isy);
+ intsort(isx.start, stack_depth(&isx));
+ intsort(isy.start, stack_depth(&isy));
+- int r = compare_priorities(isx.start, stack_depth(&isx),
++ r = compare_priorities(isx.start, stack_depth(&isx),
+ isy.start, stack_depth(&isy));
+ stack_free(&psx); stack_free(&psy); stack_free(&isx); stack_free(&isy);
+ return r;
+@@ -949,12 +950,12 @@
+ static int
+ cmp_greedyness(PNode *x, PNode *y) {
+ VecPNode pvx, pvy;
++ int ix = 0, iy = 0;
+ vec_clear(&pvx); vec_clear(&pvy);
+ get_unshared_pnodes(x, y, &pvx, &pvy);
+ set_to_vec(&pvx); set_to_vec(&pvy);
+ qsort(pvx.v, pvx.n, sizeof(PNode *), greedycmp);
+ qsort(pvy.v, pvy.n, sizeof(PNode *), greedycmp);
+- int ix = 0, iy = 0;
+ while (1) {
+ if (pvx.n <= ix || pvy.n <= iy)
+ return 0;
+@@ -1202,8 +1203,8 @@
+ static void
+ set_add_znode_hash(VecZNode *v, ZNode *z) {
+ VecZNode vv;
+- vec_clear(&vv);
+ int i, j, n = v->n;
++ vec_clear(&vv);
+ if (n) {
+ uint h = ((uintptr_t)z->pn) % n;
+ for (i = h, j = 0;
+@@ -1237,8 +1238,8 @@
+ static void
+ set_add_znode(VecZNode *v, ZNode *z) {
+ VecZNode vv;
+- vec_clear(&vv);
+ int i, n = v->n;
++ vec_clear(&vv);
+ if (n < INTEGRAL_VEC_SIZE) {
+ vec_add(v, z);
+ return;