aboutsummaryrefslogtreecommitdiff
path: root/devel/dprog/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-04-06 01:31:21 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-04-06 01:31:21 +0000
commit4e92e6194fa0fd47c49314976c015ce655e12ccc (patch)
treedfb412a9a11ee2762f40818cddc8e59b105bc83e /devel/dprog/Makefile
parent6284fe0fa82c50a3b2f6ec3be2a71a0b44907518 (diff)
Notes
Diffstat (limited to 'devel/dprog/Makefile')
-rw-r--r--devel/dprog/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/dprog/Makefile b/devel/dprog/Makefile
new file mode 100644
index 000000000000..a192485c0360
--- /dev/null
+++ b/devel/dprog/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# Ports collection makefile for: dprog
+# Date created: Apr 6, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= dprog
+PORTVERSION= 0.3.1
+CATEGORIES= devel
+MASTER_SITES= http://www.daimi.au.dk/~mailund/dprog/download/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A language for specifying dynamic programming algorithms
+
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+PLIST_FILES= bin/dprog include/cxx_dprog.hh lib/libcxx_dprog.a
+
+.include <bsd.port.mk>