aboutsummaryrefslogtreecommitdiff
path: root/devel/dragon
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-10-29 13:31:41 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-10-29 13:31:41 +0000
commit86cb3f82371a0fb24f335bfb276481d79e16bcc4 (patch)
tree8ac9a593fdfd2a67cdbec5d1d9a2b49cea2d1a86 /devel/dragon
parent2cebfd5aedd2a54301797f463a7d47676acb7d3f (diff)
downloadports-86cb3f82371a0fb24f335bfb276481d79e16bcc4.tar.gz
ports-86cb3f82371a0fb24f335bfb276481d79e16bcc4.zip
Notes
Diffstat (limited to 'devel/dragon')
-rw-r--r--devel/dragon/Makefile23
-rw-r--r--devel/dragon/distinfo3
-rw-r--r--devel/dragon/pkg-descr16
3 files changed, 42 insertions, 0 deletions
diff --git a/devel/dragon/Makefile b/devel/dragon/Makefile
new file mode 100644
index 000000000000..c9990d630da3
--- /dev/null
+++ b/devel/dragon/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: dragon
+# Date created: 2010-09-17
+# Whom: Kurt Jaeger <fbsd-ports@opsec.eu>
+#
+# $FreeBSD$
+
+PORTNAME= dragon
+PORTVERSION= 1.3.7
+CATEGORIES= devel
+MASTER_SITES= http://www.lemke-it.com/
+DISTNAME= dragon-${PORTVERSION}
+
+MAINTAINER= fbsd-ports@opsec.eu
+COMMENT= Combined C++ scanner/parser generator for LR compliant grammars
+
+LIB_DEPENDS= lfc.1:${PORTSDIR}/devel/lfc
+
+LICENSE= GPLv2
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+PLIST_FILES= bin/dragon
+
+.include <bsd.port.mk>
diff --git a/devel/dragon/distinfo b/devel/dragon/distinfo
new file mode 100644
index 000000000000..7902c90723d0
--- /dev/null
+++ b/devel/dragon/distinfo
@@ -0,0 +1,3 @@
+MD5 (dragon-1.3.7.tar.gz) = 142500f27c91ae1739ec87ebe6262886
+SHA256 (dragon-1.3.7.tar.gz) = a7f505624985ffa249f1f123b57e9c70d44d06f16117a2b84d7e2b1093c8ecf2
+SIZE (dragon-1.3.7.tar.gz) = 123758
diff --git a/devel/dragon/pkg-descr b/devel/dragon/pkg-descr
new file mode 100644
index 000000000000..6f7772c73771
--- /dev/null
+++ b/devel/dragon/pkg-descr
@@ -0,0 +1,16 @@
+Combined scanner/parser generator for LR compliant grammar definitions.
+
+The generated C++ parser class is used as a super class from which a parser
+implementation class must be derived. The implementation class implements the
+scanner feed methods but also all required semantic action method. dragon has
+been used for several large projects with complex grammar definitions (about
+200 productions/ 80 tokens ). Since for those grammar defintions, the analyse
+phase to build up the parse table is quite CPU intensive, it is recommended to
+use state of the art hardware. dragon requires the base package to get compiled
+but also for the compilation of the generated C++ code.
+
+It can be used for databases/cego and probably other applications.
+
+Many more details are available at:
+
+WWW: http://www.lemke-it.com/