aboutsummaryrefslogtreecommitdiff
path: root/devel/ds2
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2015-11-04 11:30:33 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2015-11-04 11:30:33 +0000
commit6b219e5c8144d3c926c4eb38d4768e38c2cef1c7 (patch)
tree07e3b1b241d2ea55ef350f64191c93cbbddb4870 /devel/ds2
parentcc759ec80b62dc1dd8dedbdd8445e5035da18589 (diff)
downloadports-6b219e5c8144d3c926c4eb38d4768e38c2cef1c7.tar.gz
ports-6b219e5c8144d3c926c4eb38d4768e38c2cef1c7.zip
Notes
Diffstat (limited to 'devel/ds2')
-rw-r--r--devel/ds2/Makefile32
-rw-r--r--devel/ds2/distinfo2
-rw-r--r--devel/ds2/pkg-descr4
3 files changed, 38 insertions, 0 deletions
diff --git a/devel/ds2/Makefile b/devel/ds2/Makefile
new file mode 100644
index 000000000000..207a611f07bf
--- /dev/null
+++ b/devel/ds2/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= ds2
+PORTVERSION= 20151028
+CATEGORIES= devel
+
+MAINTAINER= wg@FreeBSD.org
+COMMENT= Debug server for lldb
+
+LICENSE= NCSA
+LICENSE_NAME= University of Illinois/NCSA Open Source License
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+USE_GITHUB= yes
+GH_ACCOUNT= facebook
+GH_TAGNAME= 52c45f3
+
+USES= cmake compiler
+
+PLIST_FILES= bin/ds2
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ds2 ${STAGEDIR}${PREFIX}/bin/
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1002000 || ${COMPILER_TYPE} == "gcc"
+IGNORE= builds only on greater than 10.1 and with clang
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/ds2/distinfo b/devel/ds2/distinfo
new file mode 100644
index 000000000000..91e0882fb83b
--- /dev/null
+++ b/devel/ds2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (facebook-ds2-20151028-52c45f3_GH0.tar.gz) = 9f14200a2cedb946429021cec37337442d02158ca25c530cca15f8a42fb6d9fa
+SIZE (facebook-ds2-20151028-52c45f3_GH0.tar.gz) = 218024
diff --git a/devel/ds2/pkg-descr b/devel/ds2/pkg-descr
new file mode 100644
index 000000000000..8329c23b9532
--- /dev/null
+++ b/devel/ds2/pkg-descr
@@ -0,0 +1,4 @@
+ds2 is a debug server designed to be used with LLDB to perform remote debugging
+of Linux, Android, FreeBSD and Windows targets.
+
+WWW: https://github.com/facebook/ds2