aboutsummaryrefslogtreecommitdiff
path: root/devel/dsss
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-06-29 14:08:29 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-06-29 14:08:29 +0000
commitfe3fcc25eef3599db01db1a87dac8dae97a1b4a4 (patch)
treeac42597bb3e34db08d1fefa6a56003acb9f5433f /devel/dsss
parent4247854b551dea4f3cdff5cfe081c4b40e34fd11 (diff)
downloadports-fe3fcc25eef3599db01db1a87dac8dae97a1b4a4.tar.gz
ports-fe3fcc25eef3599db01db1a87dac8dae97a1b4a4.zip
Notes
Diffstat (limited to 'devel/dsss')
-rw-r--r--devel/dsss/Makefile40
-rw-r--r--devel/dsss/distinfo3
-rw-r--r--devel/dsss/pkg-descr8
-rw-r--r--devel/dsss/pkg-plist53
4 files changed, 104 insertions, 0 deletions
diff --git a/devel/dsss/Makefile b/devel/dsss/Makefile
new file mode 100644
index 000000000000..03cde3b44661
--- /dev/null
+++ b/devel/dsss/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: dsss
+# Date created: 14 Jun 2008
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dsss
+PORTVERSION= 0.75
+CATEGORIES= devel
+MASTER_SITES= http://svn.dsource.org/projects/dsss/downloads/${PORTVERSION}/ \
+ http://www.amdmi3.ru/distfiles/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= D Shared Software System
+
+BUILD_DEPENDS= gdc:${PORTSDIR}/lang/gdc
+
+USE_BZIP2= yes
+MAKEFILE= Makefile.gdc.posix
+
+MAKE_ENV= CXX="${CXX}" NATIVECXX="${CXX}"
+
+PORTDOCS= *
+
+MAN1= dsss.1 rebuild.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|share/man|man|' \
+ ${WRKSRC}/dsss.conf
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's|install docs.*share/doc/dsss ;||' \
+ ${WRKSRC}/dsss.conf
+.endif
+.for var in CXX NATIVECXX CXXFLAGS PREFIX
+ @${REINPLACE_CMD} -e '/^${var}=/ d' ${WRKSRC}/${MAKEFILE} \
+ ${WRKSRC}/rebuild/Makefile
+.endfor
+
+.include <bsd.port.mk>
diff --git a/devel/dsss/distinfo b/devel/dsss/distinfo
new file mode 100644
index 000000000000..9d9563cbb376
--- /dev/null
+++ b/devel/dsss/distinfo
@@ -0,0 +1,3 @@
+MD5 (dsss-0.75.tar.bz2) = 7cf66b6e33503da8600926f5e5ac2f1b
+SHA256 (dsss-0.75.tar.bz2) = a0620c1452a1f16e6108a7107e9b8f11c683670a799e15e6f09696908c36e46a
+SIZE (dsss-0.75.tar.bz2) = 922792
diff --git a/devel/dsss/pkg-descr b/devel/dsss/pkg-descr
new file mode 100644
index 000000000000..f733f783409f
--- /dev/null
+++ b/devel/dsss/pkg-descr
@@ -0,0 +1,8 @@
+DSSS, the D Shared Software System, builds upon rebuild and intends
+to create a standardized system for building, installing, configuring,
+acquiring and using D software, licensed as Free and Open Source
+Software under the MIT license. One notable component of it is its
+net module, which provides an analogue to Perl's CPAN or Ruby's
+Gems for the D programming language.
+
+WWW: http://www.dsource.org/projects/dsss/
diff --git a/devel/dsss/pkg-plist b/devel/dsss/pkg-plist
new file mode 100644
index 000000000000..1c67af207fcf
--- /dev/null
+++ b/devel/dsss/pkg-plist
@@ -0,0 +1,53 @@
+bin/dsss
+bin/rebuild
+bin/rebuild_choosedc
+bin/rerun
+etc/dsss/list.list
+etc/rebuild/default
+etc/rebuild/dmd-posix
+etc/rebuild/dmd-posix-tango
+etc/rebuild/dmd-win
+etc/rebuild/dmd-win-tango
+etc/rebuild/gdc-posix
+etc/rebuild/gdc-posix-tango
+etc/rebuild/gdc-win
+etc/rebuild/gdc-win-tango
+etc/rebuild/native
+etc/rebuild/phobos
+etc/rebuild/tango
+include/d/hcf/env.d
+include/d/hcf/path.d
+include/d/hcf/process.d
+include/d/sss/build.d
+include/d/sss/clean.d
+include/d/sss/conf.d
+include/d/sss/genconfig.d
+include/d/sss/install.d
+include/d/sss/net.d
+include/d/sss/platform.d
+include/d/sss/stub.d
+include/d/sss/uninstall.d
+include/d/util/booltype.d
+include/d/util/fdt.d
+include/d/util/file2.d
+include/d/util/fileex.d
+include/d/util/linetoken.d
+include/d/util/pathex.d
+include/d/util/series.d
+include/d/util/str.d
+lib/dymoduleinit.d
+%%DATADIR%%/candydoc.tar.gz
+%%DATADIR%%/dsss_lib_test.d
+%%DATADIR%%/manifest/dsss.manifest
+%%DATADIR%%/sources/EMPTY
+share/rebuild/testtango.d
+@dirrm share/rebuild
+@dirrm %%DATADIR%%/sources
+@dirrm %%DATADIR%%/manifest
+@dirrm %%DATADIR%%
+@dirrm include/d/util
+@dirrm include/d/sss
+@dirrm include/d/hcf
+@dirrmtry include/d
+@dirrm etc/rebuild
+@dirrm etc/dsss