aboutsummaryrefslogtreecommitdiff
path: root/devel/dulwich/Makefile
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-10-14 12:04:42 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-10-14 12:04:42 +0000
commitc56465530fd1615d8f13820ba6445c992c1ae0c7 (patch)
treeb110756ad2c4f6ab002ada25c3bfb808a3258517 /devel/dulwich/Makefile
parent75b14249551cf722b66418c62175a365e9c29269 (diff)
downloadports-c56465530fd1615d8f13820ba6445c992c1ae0c7.tar.gz
ports-c56465530fd1615d8f13820ba6445c992c1ae0c7.zip
Notes
Diffstat (limited to 'devel/dulwich/Makefile')
-rw-r--r--devel/dulwich/Makefile32
1 files changed, 19 insertions, 13 deletions
diff --git a/devel/dulwich/Makefile b/devel/dulwich/Makefile
index 5fa215239367..bbee95cc9121 100644
--- a/devel/dulwich/Makefile
+++ b/devel/dulwich/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= dulwich
-PORTVERSION= 0.9.0
+PORTVERSION= 0.9.1
CATEGORIES= devel python
MASTER_SITES= http://www.samba.org/~jelmer/${PORTNAME}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,31 +13,37 @@ COMMENT= Pure-Python implementation of the Git file formats and protocols
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
+PORTDOCS= NEWS README introduction.txt object-store.txt protocol.txt \
+ remote.txt repo.txt tag.txt
+PORTEXAMPLES= clone.py diff.py
-PORTDOCS= AUTHORS HACKING NEWS README introduction.txt \
- object-store.txt protocol.txt remote.txt repo.txt tag.txt
-
-USE_PYTHON= -2.7
+USE_PYTHON= 2
USE_PYDISTUTILS=yes
+PYDISTUTILS_AUTOPLIST= yes
-OPTIONSFILE= ${PORT_DBDIR}/${PORTNAME}/options
-OPTIONS_DEFINE= DOCS
-OPTIONS_DEFAULT=DOCS
+OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_DEFAULT=DOCS EXAMPLES
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
${REINPLACE_CMD} -e 's|PYTHON = python|PYTHON = ${PYTHON_CMD}|g' \
${WRKSRC}/Makefile
${REINPLACE_CMD} -e 's|/usr/bin/python|${PYTHON_CMD}|g' \
- ${WRKSRC}/setup.py
+ ${WRKSRC}/setup.py ${WRKSRC}/examples/*.py
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${CP} ${WRKSRC}/docs/*.txt ${WRKSRC}/docs/tutorial/*.txt ${WRKSRC}
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+ ${CP} ${WRKSRC}/docs/*.txt ${WRKSRC}/docs/tutorial/*.txt ${WRKSRC}/
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/)
+.endif
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${CP} ${WRKSRC}/examples/*.py ${WRKSRC}/
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC} && ${INSTALL_SCRIPT} ${PORTEXAMPLES} \
+ ${STAGEDIR}${EXAMPLESDIR}/)
.endif
.include <bsd.port.mk>