aboutsummaryrefslogtreecommitdiff
path: root/devel/e00compr
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-18 00:04:19 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-18 00:04:19 +0000
commit623bf7b0596d2b242a7dbf8558fa8deaa2a8f7b9 (patch)
tree4dfb1870fae25679d4d5db314c7e40e3914d40d8 /devel/e00compr
parent3cb8ed77a3896308fdf4e8b6a0411d8b49228d65 (diff)
downloadports-623bf7b0596d2b242a7dbf8558fa8deaa2a8f7b9.tar.gz
ports-623bf7b0596d2b242a7dbf8558fa8deaa2a8f7b9.zip
Notes
Diffstat (limited to 'devel/e00compr')
-rw-r--r--devel/e00compr/Makefile34
-rw-r--r--devel/e00compr/distinfo3
-rw-r--r--devel/e00compr/pkg-descr7
3 files changed, 44 insertions, 0 deletions
diff --git a/devel/e00compr/Makefile b/devel/e00compr/Makefile
new file mode 100644
index 000000000000..5b7f646f27ab
--- /dev/null
+++ b/devel/e00compr/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: e00compr
+# Date created: May 04 , 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= e00compr
+PORTVERSION= 1.0.0
+CATEGORIES= devel
+MASTER_SITES= http://avce00.maptools.org/dl/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A Library to Read/Write Compressed E00 Files
+
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}
+PLIST_FILES= bin/e00conv include/e00compr.h \
+ lib/e00compr.a
+PORTDOCS= e00compr.html
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/e00conv ${PREFIX}/bin/e00conv
+ ${INSTALL_DATA} ${WRKSRC}/e00compr.h ${PREFIX}/include/e00compr.h
+ ${INSTALL_DATA} ${WRKSRC}/e00compr.a ${PREFIX}/lib/e00compr.a
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/e00compr.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/e00compr/distinfo b/devel/e00compr/distinfo
new file mode 100644
index 000000000000..df86e84ac0a4
--- /dev/null
+++ b/devel/e00compr/distinfo
@@ -0,0 +1,3 @@
+MD5 (e00compr-1.0.0.tar.gz) = d0b084609401190399e110231b0083fd
+SHA256 (e00compr-1.0.0.tar.gz) = 7a2e441732ec33ff997525b1f9df2ad18ffdf299694eb4ac1db1b48a467a1027
+SIZE (e00compr-1.0.0.tar.gz) = 35306
diff --git a/devel/e00compr/pkg-descr b/devel/e00compr/pkg-descr
new file mode 100644
index 000000000000..3df518411727
--- /dev/null
+++ b/devel/e00compr/pkg-descr
@@ -0,0 +1,7 @@
+E00Compr is an Open Source ANSI-C library to compress and uncompress
+Arc/Info Export (E00) files. It can be easily plugged into existing E00
+translators to add support for compressed E00 files simply by replacing
+the existing translator's read/write function by the E00ReadNextLine()
+and E00WriteNextLine() functions provided by the library.
+
+WWW: http://avce00.maptools.org/e00compr/