aboutsummaryrefslogtreecommitdiff
path: root/devel/e00compr
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-20 23:47:48 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-20 23:47:48 +0000
commit1ebe49cb658e4fc28e2ecdc4e35ac3274d5c3107 (patch)
tree5d7fea696b0d05ad5726066192100222caa8c0d5 /devel/e00compr
parent3558ea425d48ddbd10edbcfa5097347eb5961cc4 (diff)
downloadports-1ebe49cb658e4fc28e2ecdc4e35ac3274d5c3107.tar.gz
ports-1ebe49cb658e4fc28e2ecdc4e35ac3274d5c3107.zip
Notes
Diffstat (limited to 'devel/e00compr')
-rw-r--r--devel/e00compr/Makefile25
1 files changed, 9 insertions, 16 deletions
diff --git a/devel/e00compr/Makefile b/devel/e00compr/Makefile
index e9b509776b09..049e6641562b 100644
--- a/devel/e00compr/Makefile
+++ b/devel/e00compr/Makefile
@@ -9,27 +9,20 @@ MASTER_SITES= http://avce00.maptools.org/dl/
MAINTAINER= wen@FreeBSD.org
COMMENT= Library to Read/Write Compressed E00 Files
-USE_GMAKE= yes
+OPTIONS_DEFINE= DOCS
+
+USES= gmake
WRKSRC= ${WRKDIR}/${DISTNAME}
PLIST_FILES= bin/e00conv include/e00compr.h \
lib/e00compr.a
PORTDOCS= e00compr.html
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-post-extract:
- ${REINPLACE_CMD} -e 's#gcc#${CC}#g' ${WRKSRC}/Makefile
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/e00conv ${PREFIX}/bin/e00conv
- ${INSTALL_DATA} ${WRKSRC}/e00compr.h ${PREFIX}/include/e00compr.h
- ${INSTALL_DATA} ${WRKSRC}/e00compr.a ${PREFIX}/lib/e00compr.a
-
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/e00compr.html ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/e00conv ${STAGEDIR}${PREFIX}/bin/e00conv
+ ${INSTALL_DATA} ${WRKSRC}/e00compr.h ${STAGEDIR}${PREFIX}/include/e00compr.h
+ ${INSTALL_DATA} ${WRKSRC}/e00compr.a ${STAGEDIR}${PREFIX}/lib/e00compr.a
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/e00compr.html ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>