aboutsummaryrefslogtreecommitdiff
path: root/devel/e4graph/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-07 16:44:56 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-07 16:44:56 +0000
commit66b7802bfa6dd722a075b47cb11162bf6876b841 (patch)
treef1b79038da7ae968bda84b23c83c09f2f8f057bd /devel/e4graph/Makefile
parentc64d835b37268a9b1ac07766f3778c2ff45d270f (diff)
downloadports-66b7802bfa6dd722a075b47cb11162bf6876b841.tar.gz
ports-66b7802bfa6dd722a075b47cb11162bf6876b841.zip
Notes
Diffstat (limited to 'devel/e4graph/Makefile')
-rw-r--r--devel/e4graph/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/devel/e4graph/Makefile b/devel/e4graph/Makefile
index 98e4ff806e61..b005720fcfbe 100644
--- a/devel/e4graph/Makefile
+++ b/devel/e4graph/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= e4graph
-PORTVERSION= 1.0a9
-PORTREVISION= 1
+PORTVERSION= 1.0a11
CATEGORIES= devel tcl84
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,10 +16,9 @@ EXTRACT_SUFX= .src.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= A C++ library that persistently stores graph like data
-BUILD_DEPENDS= ${LOCALBASE}/lib/libmk4.so:${PORTSDIR}/databases/metakit
-LIB_DEPENDS= tcl${TCLVND}:${PORTSDIR}/lang/tcl${TCLVND} \
+LIB_DEPENDS= mk4.0:${PORTSDIR}/databases/metakit \
+ tcl${TCLVND}:${PORTSDIR}/lang/tcl${TCLVND} \
expat.4:${PORTSDIR}/textproc/expat2
-RUN_DEPENDS= ${BUILD_DEPENDS}
WRKSRC= ${WRKDIR}/${DISTNAME}/all
@@ -50,4 +48,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|=-O$$|="$${CFLAGS}"|g ; \
s|gcc -shared|$$(CC) -shared|g' ${WRKSRC}/configure
+post-install:
+.for file in testcore testcores
+ @${STRIP_CMD} ${PREFIX}/bin/${file}
+.endfor
+
.include <bsd.port.mk>