aboutsummaryrefslogtreecommitdiff
path: root/devel/e_dbus
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
committerStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
commit4e6b9d37ad988e5ce212eb64d3da6c89f036995b (patch)
treec034200ad770d5a81c162443b728bd36b7987a9c /devel/e_dbus
parent32d827c027cde0f59dfae87babbc1499241115ab (diff)
downloadports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.tar.gz
ports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.zip
Notes
Diffstat (limited to 'devel/e_dbus')
-rw-r--r--devel/e_dbus/Makefile52
-rw-r--r--devel/e_dbus/distinfo5
-rw-r--r--devel/e_dbus/pkg-descr2
-rw-r--r--devel/e_dbus/pkg-plist39
4 files changed, 61 insertions, 37 deletions
diff --git a/devel/e_dbus/Makefile b/devel/e_dbus/Makefile
index 0856f347e867..a931aa17404e 100644
--- a/devel/e_dbus/Makefile
+++ b/devel/e_dbus/Makefile
@@ -6,26 +6,32 @@
#
PORTNAME= e_dbus
-PORTVERSION= 20080223
-PORTREVISION= 2
-CATEGORIES= devel
-MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
- http://download.enlightenment.org/snapshots/2008-01-25/
+DISTVERSION= 1.0.0.beta
+PORTEPOCH= 1
+CATEGORIES= devel enlightenment
+MASTER_SITES= http://download.enlightenment.org/releases/ \
+ http://files.roorback.net/e17/2010-10-03/base/
MAINTAINER= stas@FreeBSD.org
COMMENT= EFL DBUS connectivity library
LIB_DEPENDS= dbus-1.3:${PORTSDIR}/devel/dbus
-GNU_CONFIGURE= yes
+LICENSE= BSD
+DIST_SUBDIR= e17
USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_EFL= eina ecore libtool_hack librt_hack
USE_GNOME= gnomehack gnometarget pkgconfig
-USE_EFL= ecore
USE_LDCONFIG= yes
-OPTIONS= EHAL "Build E HAL module" on \
- ENM "Build E NM module" on \
- ENOT "Build E notify module" on
+CONFIGURE_ARGS= --disable-ebluez # Linux specific ??
+
+OPTIONS= EHAL "Build E HAL module" on \
+ EUKIT "Build E upower module" on \
+ ECONNM "Build E connman module" on \
+ EOFONO "Build E oFono module" on \
+ ENOT "Build E notify module" on
.include <bsd.port.pre.mk>
@@ -37,12 +43,28 @@ CONFIGURE_ARGS+= --disable-ehal
PLIST_SUB+= EHAL="@comment "
.endif
-.if !defined(WITHOUT_ENM)
-CONFIGURE_ARGS+= --enable-enm
-PLIST_SUB+= ENM=""
+.if !defined(WITHOUT_EUKIT)
+CONFIGURE_ARGS+= --enable-eukit
+PLIST_SUB+= EUKIT=""
+.else
+CONFIGURE_ARGS+= --disable-eukit
+PLIST_SUB+= EUKIT="@comment "
+.endif
+
+.if !defined(WITHOUT_ECONNM)
+CONFIGURE_ARGS+= --enable-econnman
+PLIST_SUB+= ECONNM=""
+.else
+CONFIGURE_ARGS+= --disable-econnman
+PLIST_SUB+= ECONNM="@comment "
+.endif
+
+.if !defined(WITHOUT_EOFONO)
+CONFIGURE_ARGS+= --enable-eofono
+PLIST_SUB+= EOFONO=""
.else
-CONFIGURE_ARGS+= --disable-enm
-PLIST_SUB+= ENM="@comment "
+CONFIGURE_ARGS+= --disable-eofono
+PLIST_SUB+= EOFONO="@comment "
.endif
.if !defined(WITHOUT_ENOT)
diff --git a/devel/e_dbus/distinfo b/devel/e_dbus/distinfo
index 486c69fb2ee8..559646f643ad 100644
--- a/devel/e_dbus/distinfo
+++ b/devel/e_dbus/distinfo
@@ -1,3 +1,2 @@
-MD5 (e_dbus-20080223.tar.bz2) = d709ffed87f71253a62cda1484b0aa64
-SHA256 (e_dbus-20080223.tar.bz2) = f27382a51c16f7d10b3e2757c4b8c3a483b3afc137cafae4321252b3d4cf59c0
-SIZE (e_dbus-20080223.tar.bz2) = 252568
+SHA256 (e17/e_dbus-1.0.0.beta.tar.bz2) = b6eff6419b0ad5e76a47705fd29128e96bc59a9ed5d18b36e0a55a5520806d76
+SIZE (e17/e_dbus-1.0.0.beta.tar.bz2) = 390574
diff --git a/devel/e_dbus/pkg-descr b/devel/e_dbus/pkg-descr
index 141e4ab49806..0c9865dc7820 100644
--- a/devel/e_dbus/pkg-descr
+++ b/devel/e_dbus/pkg-descr
@@ -1,3 +1,3 @@
Enlightenment DBUS compatibility layer.
-WWW: http://www.enlightenment.org/
+WWW: http://docs.enlightenment.org/api/e_dbus/html/
diff --git a/devel/e_dbus/pkg-plist b/devel/e_dbus/pkg-plist
index 5699855209ab..dae1f604ee20 100644
--- a/devel/e_dbus/pkg-plist
+++ b/devel/e_dbus/pkg-plist
@@ -1,31 +1,34 @@
-%%EHAL%%bin/e_dbus_hal
-%%ENM%%bin/e_dbus_nm
+%%ENOT%%bin/e-notify-send
+%%ECONNM%%bin/e_dbus_connman_test
%%ENOT%%bin/e_dbus_notification_daemon
%%ENOT%%bin/e_dbus_notify
+%%EOFONO%%bin/e_dbus_ofono_test
bin/e_dbus_test
bin/e_dbus_test_client
-include/E_DBus.h
-%%EHAL%%include/E_Hal.h
-%%ENM%%include/E_Nm.h
-%%ENOT%%include/E_Notification_Daemon.h
-%%ENOT%%include/E_Notify.h
-lib/libedbus.a
-lib/libedbus.la
+%%EUKIT%%bin/e_dbus_ukit_test
+%%ECONNM%%include/e_dbus-1/E_Connman.h
+include/e_dbus-1/E_DBus.h
+%%EHAL%%include/e_dbus-1/E_Hal.h
+%%ENOT%%include/e_dbus-1/E_Notification_Daemon.h
+%%ENOT%%include/e_dbus-1/E_Notify.h
+%%EOFONO%%include/e_dbus-1/E_Ofono.h
+%%EUKIT%%include/e_dbus-1/E_Ukit.h
+%%ECONNM%%lib/libeconnman.so
+%%ECONNM%%lib/libeconnman.so.1
lib/libedbus.so
lib/libedbus.so.1
-%%EHAL%%lib/libehal.a
-%%EHAL%%lib/libehal.la
%%EHAL%%lib/libehal.so
%%EHAL%%lib/libehal.so.1
-%%ENM%%lib/libenm.a
-%%ENM%%lib/libenm.la
-%%ENM%%lib/libenm.so
-%%ENM%%lib/libenm.so.1
-%%ENOT%%lib/libenotify.a
-%%ENOT%%lib/libenotify.la
%%ENOT%%lib/libenotify.so
%%ENOT%%lib/libenotify.so.1
+%%EOFONO%%lib/libeofono.so
+%%EOFONO%%lib/libeofono.so.1
+%%EUKIT%%lib/libeukit.so
+%%EUKIT%%lib/libeukit.so.1
+%%ECONNM%%libdata/pkgconfig/econnman.pc
libdata/pkgconfig/edbus.pc
%%EHAL%%libdata/pkgconfig/ehal.pc
-%%ENM%%libdata/pkgconfig/enm.pc
%%ENOT%%libdata/pkgconfig/enotify.pc
+%%EOFONO%%libdata/pkgconfig/eofono.pc
+%%EUKIT%%libdata/pkgconfig/eukit.pc
+@dirrm include/e_dbus-1