aboutsummaryrefslogtreecommitdiff
path: root/devel/easygit/Makefile
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2009-03-11 10:31:49 +0000
committerLars Thegler <lth@FreeBSD.org>2009-03-11 10:31:49 +0000
commit657736865445093c6d023fdca4fd0844903520c5 (patch)
tree02ee05b1ada0ad8449b42280e2418aef7b368a8b /devel/easygit/Makefile
parent5f468fb8efd8943f56ea7965dee008c1e132dea0 (diff)
Notes
Diffstat (limited to 'devel/easygit/Makefile')
-rw-r--r--devel/easygit/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/easygit/Makefile b/devel/easygit/Makefile
new file mode 100644
index 000000000000..d657bc964e01
--- /dev/null
+++ b/devel/easygit/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: devel/easygit
+# Date created: 11 March 2009
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= easygit
+PORTVERSION= 0.98
+CATEGORIES= devel
+MASTER_SITES= http://www.gnome.org/~newren/eg/download/${PORTVERSION}/
+DISTNAME= eg
+EXTRACT_SUFX= # none
+EXTRACT_ONLY= # none
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Easy wrapper for git
+
+RUN_DEPENDS= git:${PORTSDIR}/devel/git
+
+DIST_SUBDIR= eg/${PORTVERSION}_${PORTREVISION}
+USE_PERL5_RUN= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+PLIST_FILES= bin/eg bin/easygit
+
+do-install:
+ ${INSTALL_SCRIPT} ${_DISTDIR}/eg ${PREFIX}/bin/
+ ${LN} -s ${PREFIX}/bin/eg ${PREFIX}/bin/easygit
+
+.include <bsd.port.mk>