aboutsummaryrefslogtreecommitdiff
path: root/devel/ecb/Makefile
diff options
context:
space:
mode:
authorYoichi NAKAYAMA <yoichi@FreeBSD.org>2002-08-14 06:45:07 +0000
committerYoichi NAKAYAMA <yoichi@FreeBSD.org>2002-08-14 06:45:07 +0000
commitec95d356cf4d978b126f52c8cffe2a4d8d1ab23a (patch)
treeb7d3806f25a1d29aeb418112b7b062a39810ea84 /devel/ecb/Makefile
parente4fa4352d4cd4c65962b7a3260cfbc510be1c6d1 (diff)
downloadports-ec95d356cf4d978b126f52c8cffe2a4d8d1ab23a.tar.gz
ports-ec95d356cf4d978b126f52c8cffe2a4d8d1ab23a.zip
Notes
Diffstat (limited to 'devel/ecb/Makefile')
-rw-r--r--devel/ecb/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/devel/ecb/Makefile b/devel/ecb/Makefile
index 63332892103a..81ab8de34a70 100644
--- a/devel/ecb/Makefile
+++ b/devel/ecb/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= ecb
-PORTVERSION= 1.70
+PORTVERSION= 1.80
CATEGORIES= devel elisp
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ecb
PKGNAMESUFFIX= -${EMACS_PORT_NAME}
-MAINTAINER= fuyuki@mj.0038.net
+MAINTAINER= fuyuki@hadaly.org
EMACS_PORT_NAME?= emacs21
@@ -26,13 +26,21 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
LISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME}
+USE_REINPLACE= yes
USE_GMAKE= yes
+post-patch:
+ ${REINPLACE_CMD} -e 's/.$$//' \
+ -e 's/GNU Emacs Lisp/The Emacs editor and associated tools/' \
+ ${WRKSRC}/ecb.texi
+
do-install:
${MKDIR} ${LISPDIR}
.for i in *.el *.elc
${INSTALL_DATA} ${WRKSRC}/${i} ${LISPDIR}
.endfor
+ ${INSTALL_DATA} ${WRKSRC}/ecb.info ${PREFIX}/info
+ install-info ${PREFIX}/info/ecb.info ${PREFIX}/info/dir
post-install:
.if !defined(NOPORTDOCS)