aboutsummaryrefslogtreecommitdiff
path: root/devel/ecgi
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-05-02 11:57:10 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-05-02 11:57:10 +0000
commit8ec78d0c2ee1d5164fabd8b585d7257ce480584f (patch)
treed31bb76cffe852406a40e412f493e31cba321371 /devel/ecgi
parente7703d82f567763cb3364f5bcd99d9daf401346c (diff)
downloadports-8ec78d0c2ee1d5164fabd8b585d7257ce480584f.tar.gz
ports-8ec78d0c2ee1d5164fabd8b585d7257ce480584f.zip
Notes
Diffstat (limited to 'devel/ecgi')
-rw-r--r--devel/ecgi/Makefile45
-rw-r--r--devel/ecgi/distinfo3
-rw-r--r--devel/ecgi/files/patch-Makefile75
-rw-r--r--devel/ecgi/files/patch-html2h::Makefile21
-rw-r--r--devel/ecgi/files/patch-html2h::html2h.c34
-rw-r--r--devel/ecgi/files/patch-src::ecgitk.c11
-rw-r--r--devel/ecgi/pkg-descr9
-rw-r--r--devel/ecgi/pkg-plist9
8 files changed, 0 insertions, 207 deletions
diff --git a/devel/ecgi/Makefile b/devel/ecgi/Makefile
deleted file mode 100644
index 33e0b48ddf6a..000000000000
--- a/devel/ecgi/Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
-# New ports collection makefile for: ecgi
-# Date created: 13 February 2001
-# Whom: George Reid <greid@ukug.uk.freebsd.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= ecgi
-PORTVERSION= 0.6.2
-PORTREVISION= 2
-CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_DEBIAN}
-MASTER_SITE_SUBDIR= pool/main/libe/libecgi
-DISTNAME= lib${PORTNAME}_${PORTVERSION}.orig
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A library for the creation of CGI-based Web applications
-
-DEPRECATED= Upstream disapear and distfile is no more available
-EXPIRATION_DATE= 2011-05-01
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
-USE_GMAKE= yes
-USE_LDCONFIG= yes
-
-HEADER_FILES= ecgi.h ecgitk.h include/memfile.h
-
-pre-patch:
- @${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>,' ${WRKSRC}/src/memfile.c
-
-do-install:
- ${INSTALL_DATA} ${WRKSRC}/libecgi.a ${PREFIX}/lib
- ${INSTALL_PROGRAM} ${WRKSRC}/libecgi.so ${PREFIX}/lib
- ${INSTALL_PROGRAM} ${WRKSRC}/html2h/html2h ${PREFIX}/bin
- @${MKDIR} ${PREFIX}/include/ecgi
-.for file in ${HEADER_FILES}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/include/ecgi
-.endfor
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/ecgitut.txt ${DOCSDIR}
-.endif
-
-.include <bsd.port.mk>
diff --git a/devel/ecgi/distinfo b/devel/ecgi/distinfo
deleted file mode 100644
index dbfd6aab47d1..000000000000
--- a/devel/ecgi/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (libecgi_0.6.2.orig.tar.gz) = 1d2b17b1e0540b34f704ffedb9d154e5
-SHA256 (libecgi_0.6.2.orig.tar.gz) = ee481ac0aa30106b03d285200b810dc3e1b44b7c399505de6b85c04ec85220a9
-SIZE (libecgi_0.6.2.orig.tar.gz) = 265252
diff --git a/devel/ecgi/files/patch-Makefile b/devel/ecgi/files/patch-Makefile
deleted file mode 100644
index c1e03f2223e0..000000000000
--- a/devel/ecgi/files/patch-Makefile
+++ /dev/null
@@ -1,75 +0,0 @@
---- Makefile.orig Tue Feb 13 14:02:11 2001
-+++ Makefile Mon Mar 22 13:47:28 2004
-@@ -1,14 +1,14 @@
- SHAREDOPT = -shared
--LIBDIR = /usr/lib
--INCDIR = /usr/include
-+LIBDIR = $(PREFIX)/usr/lib
-+INCDIR = $(PREFIX)/include
- AR = ar
--CC = gcc
-+CC?= gcc
- INCS = -Iinclude/ -I.
--FLAGS = -Wall
-+CFLAGS += -Wall
-
- all: obj/ecgi.o obj/ecgitk.o libecgi.a
-- make -C html2h/
-- make libecgi.so
-+ $(MAKE) -C html2h/
-+ $(MAKE) libecgi.so
-
- shared: libecgi.so
- cp libecgi.so /usr/lib
-@@ -18,33 +18,42 @@
- ar rs libecgi.a obj/ecgi.o obj/memfile.o obj/ecgitk.o
- printf "\n\n***congratulations - compilation worked***\n*** run 'make install' now ***\n\n"
-
--libecgi.so: obj/ecgi.o obj/ecgitk.o
-- gcc $(SHAREDOPT) obj/ecgi.o obj/memfile.o obj/ecgitk.o -o libecgi.so
-+libecgi.so: obj/ecgi.So obj/ecgitk.So obj/memfile.So
-+ $(CC) $(SHAREDOPT) obj/ecgi.So obj/memfile.So obj/ecgitk.So -o libecgi.so
-
- install:
- cp libecgi.a $(LIBDIR)
- cp ecgi.h $(INCDIR)
- cp include/memfile.h $(INCDIR)
- cp ecgitk.h $(INCDIR)
-- make -C html2h/ install
-+ $(MAKE) -C html2h/ install
- cp libecgi.so $(LIBDIR)
-
- tests: all
-- $(CC) tests/test.c -o tests/test.cgi $(INCS) $(FLAGS) libecgi.a
-- $(CC) tests/testload.c -o tests/testload libecgi.a $(INCS) $(FLAGS)
-+ $(CC) tests/test.c -o tests/test.cgi $(INCS) $(CFLAGS) libecgi.a
-+ $(CC) tests/testload.c -o tests/testload libecgi.a $(INCS) $(CFLAGS)
-
- obj/ecgi.o: src/ecgi.c ecgi.h obj/memfile.o
-- $(CC) -c src/ecgi.c $(INCS) $(FLAGS) -o obj/ecgi.o
-+ $(CC) -c src/ecgi.c $(INCS) $(CFLAGS) -o obj/ecgi.o
-
- obj/memfile.o: src/memfile.c include/memfile.h
-- $(CC) -o obj/memfile.o -c src/memfile.c $(INCS) $(FLAGS)
-+ $(CC) -o obj/memfile.o -c src/memfile.c $(INCS) $(CFLAGS)
-
- obj/ecgitk.o: src/ecgitk.c ecgitk.h
-- $(CC) -c src/ecgitk.c $(INCS) $(FLAGS) -o obj/ecgitk.o
-+ $(CC) -c src/ecgitk.c $(INCS) $(CFLAGS) -o obj/ecgitk.o
-+
-+obj/ecgi.So: src/ecgi.c ecgi.h obj/memfile.o
-+ $(CC) -c src/ecgi.c $(INCS) $(CFLAGS) -fPIC -o obj/ecgi.So
-+
-+obj/memfile.So: src/memfile.c include/memfile.h
-+ $(CC) -o obj/memfile.So -c src/memfile.c -fPIC $(INCS) $(CFLAGS)
-+
-+obj/ecgitk.So: src/ecgitk.c ecgitk.h
-+ $(CC) -c src/ecgitk.c $(INCS) $(CFLAGS) -fPIC -o obj/ecgitk.So
-
- clean:
- rm -f obj/* *.a *.so -f tests/test.cgi tests/testload
-- make -C html2h/ clean
-+ $(MAKE) -C html2h/ clean
-
- zip: clean
- rm -f ../ecgi-0.6.2.zip
diff --git a/devel/ecgi/files/patch-html2h::Makefile b/devel/ecgi/files/patch-html2h::Makefile
deleted file mode 100644
index 7ec659184ed7..000000000000
--- a/devel/ecgi/files/patch-html2h::Makefile
+++ /dev/null
@@ -1,21 +0,0 @@
---- html2h/Makefile Tue Feb 13 23:46:49 2001
-+++ html2h/Makefile Tue Feb 13 23:49:09 2001
-@@ -1,14 +1,14 @@
--CC = gcc
-+CC?= gcc
- INCS = -I../include/ -I.
--FLAGS = -Wall
-+CFLAGS += -Wall
-
- all: html2h
-
- html2h: html2h.c html2h.h
-- $(CC) html2h.c -o html2h $(INCS) $(FLAGS) ../obj/memfile.o
-+ $(CC) html2h.c -o html2h $(INCS) $(CFLAGS) ../obj/memfile.o
-
- install: all
- cp html2h /usr/bin
-
- clean:
-- rm -f html2h
-+ rm -f html2h
diff --git a/devel/ecgi/files/patch-html2h::html2h.c b/devel/ecgi/files/patch-html2h::html2h.c
deleted file mode 100644
index 9be0ec523486..000000000000
--- a/devel/ecgi/files/patch-html2h::html2h.c
+++ /dev/null
@@ -1,34 +0,0 @@
---- html2h/html2h.c.orig Sat Jul 19 02:31:37 2003
-+++ html2h/html2h.c Sat Jul 19 02:32:42 2003
-@@ -6,15 +6,15 @@
-
- void usage()
- {
-- printf("
--html2h v0.1
--usage:
-- html2h input.html [output.h]
--
-- if output is not set, input.h will be generated and overwritten!
--
-- debug messages are written to stderr!
--
-+ printf("\
-+html2h v0.1\n\
-+usage:\n\
-+ html2h input.html [output.h]\n\
-+\n\
-+ if output is not set, input.h will be generated and overwritten!\n\
-+\n\
-+ debug messages are written to stderr!\n\
-+\n\
- ");
-
- exit(0);
-@@ -415,4 +415,4 @@
- {
- fprintf(stderr, "%s%s\n", msg, comment);
- exit(1);
--}
-\ No newline at end of file
-+}
diff --git a/devel/ecgi/files/patch-src::ecgitk.c b/devel/ecgi/files/patch-src::ecgitk.c
deleted file mode 100644
index 8edef5c5735d..000000000000
--- a/devel/ecgi/files/patch-src::ecgitk.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/ecgitk.c.orig Tue Feb 13 21:09:37 2001
-+++ src/ecgitk.c Sat Sep 14 01:22:11 2002
-@@ -23,7 +23,7 @@
- {
- char buf[4096];
- int used;
-- va_list *ap;
-+ va_list ap;
-
- va_start(ap, (void*)format);
- used=vsnprintf(buf, 4095, format, ap);
diff --git a/devel/ecgi/pkg-descr b/devel/ecgi/pkg-descr
deleted file mode 100644
index 82689dc911ac..000000000000
--- a/devel/ecgi/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-ecgi (easy CGI Libary) is an ANSI C library for the creation of
-CGI-based Web applications. It transparently supports the CGI methods
-GET and POST and also multipart/form-data file uploads. The user
-interface is designed as easy as possible and maintains full
-compatibility to cgic 0.5.
-
-It also contains a library independent introduction to CGI programming
-with C, a .html to .h HTML template preprocessor, and fast,
-block-allocating memory files.
diff --git a/devel/ecgi/pkg-plist b/devel/ecgi/pkg-plist
deleted file mode 100644
index baada68c858c..000000000000
--- a/devel/ecgi/pkg-plist
+++ /dev/null
@@ -1,9 +0,0 @@
-bin/html2h
-lib/libecgi.a
-lib/libecgi.so
-include/ecgi/ecgi.h
-include/ecgi/ecgitk.h
-include/ecgi/memfile.h
-%%PORTDOCS%%share/doc/ecgi/ecgitut.txt
-%%PORTDOCS%%@dirrm share/doc/ecgi
-@dirrm include/ecgi