aboutsummaryrefslogtreecommitdiff
path: root/devel/ecore-file
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2008-03-11 21:13:53 +0000
committerStanislav Sedov <stas@FreeBSD.org>2008-03-11 21:13:53 +0000
commit9a2e4c8b780fc607dc4b4adabefb354c84401a96 (patch)
treef59767aed29b447d3d80ab987e898598663c27e3 /devel/ecore-file
parent621c804e48a9fdddd6a00d78585fa8cb20c8460e (diff)
downloadports-9a2e4c8b780fc607dc4b4adabefb354c84401a96.tar.gz
ports-9a2e4c8b780fc607dc4b4adabefb354c84401a96.zip
Notes
Diffstat (limited to 'devel/ecore-file')
-rw-r--r--devel/ecore-file/Makefile64
-rw-r--r--devel/ecore-file/distinfo3
-rw-r--r--devel/ecore-file/pkg-descr5
-rw-r--r--devel/ecore-file/pkg-plist6
4 files changed, 78 insertions, 0 deletions
diff --git a/devel/ecore-file/Makefile b/devel/ecore-file/Makefile
new file mode 100644
index 000000000000..49dbff8abac7
--- /dev/null
+++ b/devel/ecore-file/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: ecore-file
+# Date created: 17 September 2007
+# Whom: Stanislav Sedov <stas@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= file
+PORTVERSION= 0.9.9.042
+PORTREVISION= 0
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
+ http://download.enlightenment.org/snapshots/2008-01-25/
+PKGNAMEPREFIX= ecore-
+DISTNAME= ecore-${PORTVERSION}
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Enlightenment core abstraction library (file module)
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GNOME= gnomehack pkgconfig gnometarget
+USE_LDCONFIG= yes
+USE_GETOPT_LONG=yes
+USE_EFL= ecore
+BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_file
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+CONFIGURE_ARGS= --disable-ecore-con \
+ --disable-ecore-config \
+ --disable-ecore-desktop \
+ --disable-ecore-directfb \
+ --disable-ecore-evas \
+ --enable-ecore-file \
+ --disable-ecore-ipc \
+ --disable-ecore-job \
+ --disable-ecore-sdl \
+ --disable-ecore-txt \
+ --disable-ecore-x \
+ --disable-ecore-imf \
+ --disable-ecore-imf_evas
+
+OPTIONS= CURL "Enable Curl support" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_CURL)
+CONFIGURE_ARGS+= --enable-curl
+LIB_DEPENDS+= curl.4:${PORTSDIR}/ftp/curl
+.else
+CONFIGURE_ARGS+= --disable-curl
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -E -e \
+ 's,\$$\(top_builddir\)/src/lib/ecore/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore/libecore\.la,-lecore,'\
+ ${BUILD_WRKSRC}/Makefile.in
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/ecore-file.pc \
+ ${PREFIX}/libdata/pkgconfig/
+
+.include <bsd.port.post.mk>
diff --git a/devel/ecore-file/distinfo b/devel/ecore-file/distinfo
new file mode 100644
index 000000000000..4672f6a1c167
--- /dev/null
+++ b/devel/ecore-file/distinfo
@@ -0,0 +1,3 @@
+MD5 (ecore-0.9.9.042.tar.bz2) = a66df2b5f0b1a6abc47bb50bf2b26846
+SHA256 (ecore-0.9.9.042.tar.bz2) = 26486fd2c80e4000b673f81ce637aa50c17c767e4c2af8f56de5d110e387d136
+SIZE (ecore-0.9.9.042.tar.bz2) = 5285732
diff --git a/devel/ecore-file/pkg-descr b/devel/ecore-file/pkg-descr
new file mode 100644
index 000000000000..2559668d0e57
--- /dev/null
+++ b/devel/ecore-file/pkg-descr
@@ -0,0 +1,5 @@
+A core event abstracter layer and X abstraction layer that makes doing
+selections, Xdnd, general X stuff, and event loops, timeouts and idle handlers
+fast, optimised, and convenient.
+
+WWW: http://enlightenment.sourceforge.net/Libraries/Ecore/
diff --git a/devel/ecore-file/pkg-plist b/devel/ecore-file/pkg-plist
new file mode 100644
index 000000000000..f007fefe0c41
--- /dev/null
+++ b/devel/ecore-file/pkg-plist
@@ -0,0 +1,6 @@
+include/Ecore_File.h
+lib/libecore_file.a
+lib/libecore_file.la
+lib/libecore_file.so
+lib/libecore_file.so.9
+libdata/pkgconfig/ecore-file.pc