aboutsummaryrefslogtreecommitdiff
path: root/devel/ecore-ipc
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
committerStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
commit4e6b9d37ad988e5ce212eb64d3da6c89f036995b (patch)
treec034200ad770d5a81c162443b728bd36b7987a9c /devel/ecore-ipc
parent32d827c027cde0f59dfae87babbc1499241115ab (diff)
downloadports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.tar.gz
ports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.zip
Notes
Diffstat (limited to 'devel/ecore-ipc')
-rw-r--r--devel/ecore-ipc/Makefile44
-rw-r--r--devel/ecore-ipc/distinfo5
-rw-r--r--devel/ecore-ipc/files/patch-configure89
-rw-r--r--devel/ecore-ipc/pkg-plist7
4 files changed, 23 insertions, 122 deletions
diff --git a/devel/ecore-ipc/Makefile b/devel/ecore-ipc/Makefile
index 7d14d0932480..7257fb8d7b53 100644
--- a/devel/ecore-ipc/Makefile
+++ b/devel/ecore-ipc/Makefile
@@ -6,43 +6,30 @@
#
PORTNAME= ipc
-PORTVERSION= 0.9.9.042
-PORTREVISION= 2
-CATEGORIES= devel
-MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
- http://download.enlightenment.org/snapshots/2008-01-25/
+DISTVERSION= 1.0.0.beta
+CATEGORIES= devel enlightenment
+MASTER_SITES= http://download.enlightenment.org/releases/ \
+ http://files.roorback.net/e17/2010-10-03/base/
PKGNAMEPREFIX= ecore-
-DISTNAME= ecore-${PORTVERSION}
+DISTNAME= ecore-${DISTVERSION}
MAINTAINER= stas@FreeBSD.org
COMMENT= Enlightenment core abstraction library (ipc module)
-GNU_CONFIGURE= yes
+LICENSE= BSD
+DIST_SUBDIR= e17
USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_EFL= ecore libtool_hack
+USE_EFL_ECORE= con
USE_GNOME= gnomehack pkgconfig gnometarget
USE_LDCONFIG= yes
-USE_EFL= ecore
-USE_EFL_ECORE= con
BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_ipc
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-CONFIGURE_ARGS= --enable-ecore-con \
- --disable-ecore-config \
- --disable-ecore-desktop \
- --disable-ecore-directfb \
- --disable-ecore-evas \
- --disable-ecore-file \
- --enable-ecore-ipc \
- --disable-ecore-job \
- --disable-ecore-sdl \
- --disable-ecore-txt \
- --disable-ecore-x \
- --disable-ecore-imf \
- --disable-ecore-imf_evas
+OPTIONS= SSL "Enable SSL support" on
-OPTIONS= SSL "Enable SSL support" on
-
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if !defined(WITHOUT_SSL)
CONFIGURE_ARGS+= --enable-openssl
@@ -50,6 +37,11 @@ CONFIGURE_ARGS+= --enable-openssl
CONFIGURE_ARGS+= --disable-openssl
.endif
+.include <../ecore-main/Makefile.inc>
+
+CONFIGURE_ARGS+= --enable-ecore-con \
+ --enable-ecore-ipc
+
post-patch:
@${REINPLACE_CMD} -E \
-e 's,\$$\(top_builddir\)/src/lib/ecore/\.libs,${LOCALBASE}/lib,'\
@@ -62,4 +54,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/ecore-ipc.pc \
${PREFIX}/libdata/pkgconfig/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/ecore-ipc/distinfo b/devel/ecore-ipc/distinfo
index 4672f6a1c167..36d07e85437a 100644
--- a/devel/ecore-ipc/distinfo
+++ b/devel/ecore-ipc/distinfo
@@ -1,3 +1,2 @@
-MD5 (ecore-0.9.9.042.tar.bz2) = a66df2b5f0b1a6abc47bb50bf2b26846
-SHA256 (ecore-0.9.9.042.tar.bz2) = 26486fd2c80e4000b673f81ce637aa50c17c767e4c2af8f56de5d110e387d136
-SIZE (ecore-0.9.9.042.tar.bz2) = 5285732
+SHA256 (e17/ecore-1.0.0.beta.tar.bz2) = 9fd367f9ff10568082e65c1def46e64fb96b359221e0d6aea11c6c3f6bd5282f
+SIZE (e17/ecore-1.0.0.beta.tar.bz2) = 916635
diff --git a/devel/ecore-ipc/files/patch-configure b/devel/ecore-ipc/files/patch-configure
deleted file mode 100644
index 9887d0720831..000000000000
--- a/devel/ecore-ipc/files/patch-configure
+++ /dev/null
@@ -1,89 +0,0 @@
---- configure.orig 2008-03-17 11:36:38.000000000 +0300
-+++ configure 2008-03-17 11:38:49.000000000 +0300
-@@ -20552,70 +20552,9 @@
- { echo "$as_me:$LINENO: checking for SSL" >&5
- echo $ECHO_N "checking for SSL... $ECHO_C" >&6; }
-
--if test -n "$PKG_CONFIG"; then
-- if test -n "$SSL_CFLAGS"; then
-- pkg_cv_SSL_CFLAGS="$SSL_CFLAGS"
-- else
-- if test -n "$PKG_CONFIG" && \
-- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"openssl\"") >&5
-- ($PKG_CONFIG --exists --print-errors "openssl") 2>&5
-- ac_status=$?
-- echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); }; then
-- pkg_cv_SSL_CFLAGS=`$PKG_CONFIG --cflags "openssl" 2>/dev/null`
--else
-- pkg_failed=yes
--fi
-- fi
--else
-- pkg_failed=untried
--fi
--if test -n "$PKG_CONFIG"; then
-- if test -n "$SSL_LIBS"; then
-- pkg_cv_SSL_LIBS="$SSL_LIBS"
-- else
-- if test -n "$PKG_CONFIG" && \
-- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"openssl\"") >&5
-- ($PKG_CONFIG --exists --print-errors "openssl") 2>&5
-- ac_status=$?
-- echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); }; then
-- pkg_cv_SSL_LIBS=`$PKG_CONFIG --libs "openssl" 2>/dev/null`
--else
-- pkg_failed=yes
--fi
-- fi
--else
-- pkg_failed=untried
--fi
--
--
--
--if test $pkg_failed = yes; then
--
--if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
-- _pkg_short_errors_supported=yes
--else
-- _pkg_short_errors_supported=no
--fi
-- if test $_pkg_short_errors_supported = yes; then
-- SSL_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "openssl"`
-- else
-- SSL_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "openssl"`
-- fi
-- # Put the nasty error message in config.log where it belongs
-- echo "$SSL_PKG_ERRORS" >&5
--
-- { echo "$as_me:$LINENO: result: no" >&5
--echo "${ECHO_T}no" >&6; }
-- have_openssl="no"
-
--elif test $pkg_failed = untried; then
-- have_openssl="no"
--
--else
-- SSL_CFLAGS=$pkg_cv_SSL_CFLAGS
-- SSL_LIBS=$pkg_cv_SSL_LIBS
-+ SSL_CFLAGS=""
-+ SSL_LIBS="-lssl -lcrypto"
- { echo "$as_me:$LINENO: result: yes" >&5
- echo "${ECHO_T}yes" >&6; }
-
-@@ -20623,13 +20562,9 @@
- cat >>confdefs.h <<\_ACEOF
- #define USE_OPENSSL 1
- _ACEOF
--
-- requirements_ecore_con="$requirements_ecore_con openssl"
- # no need to add it to req_ecore_ipc, since they
- # depends on ecore_con anyway.
- have_openssl="yes"
--
--fi
- fi
-
- want_curl="yes"
diff --git a/devel/ecore-ipc/pkg-plist b/devel/ecore-ipc/pkg-plist
index 3607cfe8c6b6..684339caa68e 100644
--- a/devel/ecore-ipc/pkg-plist
+++ b/devel/ecore-ipc/pkg-plist
@@ -1,6 +1,5 @@
-include/Ecore_Ipc.h
-lib/libecore_ipc.a
-lib/libecore_ipc.la
+include/ecore-1/Ecore_Ipc.h
lib/libecore_ipc.so
-lib/libecore_ipc.so.9
+lib/libecore_ipc.so.1
libdata/pkgconfig/ecore-ipc.pc
+@dirrmtry include/ecore-1