aboutsummaryrefslogtreecommitdiff
path: root/devel/ecore-main
diff options
context:
space:
mode:
authorGrzegorz Blach <gblach@FreeBSD.org>2012-12-22 20:54:59 +0000
committerGrzegorz Blach <gblach@FreeBSD.org>2012-12-22 20:54:59 +0000
commit2d250bb95eac4419c2b2a81d30d1629c50a4ba4f (patch)
tree9c4bc08591050b7b536082be6db8392c913f8089 /devel/ecore-main
parent3f57bf2285e342135340477d9404790fda157f15 (diff)
downloadports-2d250bb95eac4419c2b2a81d30d1629c50a4ba4f.tar.gz
ports-2d250bb95eac4419c2b2a81d30d1629c50a4ba4f.zip
Notes
Diffstat (limited to 'devel/ecore-main')
-rw-r--r--devel/ecore-main/Makefile21
-rw-r--r--devel/ecore-main/Makefile.inc2
-rw-r--r--devel/ecore-main/distinfo4
-rw-r--r--devel/ecore-main/pkg-plist7
4 files changed, 20 insertions, 14 deletions
diff --git a/devel/ecore-main/Makefile b/devel/ecore-main/Makefile
index 4f7a8bf62f84..b1ee7da2bcea 100644
--- a/devel/ecore-main/Makefile
+++ b/devel/ecore-main/Makefile
@@ -2,12 +2,12 @@
# $FreeBSD$
PORTNAME= main
-DISTVERSION= 1.1.0
+PORTVERSION= 1.7.4
CATEGORIES= devel enlightenment
MASTER_SITES= http://download.enlightenment.org/releases/ \
- http://files.roorback.net/e17/2011-12-02/base/
+ LOCAL/gblach/e17/
PKGNAMEPREFIX= ecore-
-DISTNAME= ecore-${DISTVERSION}
+DISTNAME= ${PKGNAMEPREFIX}${PORTVERSION}
MAINTAINER= gblach@FreeBSD.org
COMMENT= Enlightenment core abstraction library (main library)
@@ -25,20 +25,21 @@ USE_LDCONFIG= yes
EXAMPLESDIR= ${PREFIX}/share/examples/ecore
.include "Makefile.inc"
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
-CONFIGURE_ARGS+= --enable-nls
+CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
.else
-CONFIGURE_ARGS+= --disable-nls
+CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if !defined(NOPORTEXAMPLES)
-CONFIGURE_ARGS+= --enable-install-examples
+.if ${PORT_OPTIONS:MEXAMPLES}
+CONFIGURE_ARGS+=--enable-install-examples
.else
-CONFIGURE_ARGS+= --disable-install-examples
+CONFIGURE_ARGS+=--disable-install-examples
.endif
post-patch:
@@ -46,7 +47,7 @@ post-patch:
${WRKSRC}/src/examples/Makefile.in
post-install:
-.if defined(NOPORTEXAMPLES)
+.if empty(PORT_OPTIONS:MEXAMPLES)
@${RMDIR} ${EXAMPLESDIR}
.endif
diff --git a/devel/ecore-main/Makefile.inc b/devel/ecore-main/Makefile.inc
index acd6e9a32173..fe9648a1be29 100644
--- a/devel/ecore-main/Makefile.inc
+++ b/devel/ecore-main/Makefile.inc
@@ -15,3 +15,5 @@ CONFIGURE_ARGS= --disable-ecore-con \
post-patch: ecore_drop_librt
ecore_drop_librt:
@${REINPLACE_CMD} -E -e 's,(rt_libs=).*,\1,g' ${WRKSRC}/configure
+
+PATCHDIR= "../../devel/ecore-main/files"
diff --git a/devel/ecore-main/distinfo b/devel/ecore-main/distinfo
index 30f1faeb45b9..e4794250dd2e 100644
--- a/devel/ecore-main/distinfo
+++ b/devel/ecore-main/distinfo
@@ -1,2 +1,2 @@
-SHA256 (e17/ecore-1.1.0.tar.bz2) = c701a31941e178babad577ede886a98cf472352e5a73ee4717c0ffdc980152cc
-SIZE (e17/ecore-1.1.0.tar.bz2) = 3217298
+SHA256 (e17/ecore-1.7.4.tar.bz2) = 4fa52dece3cfeeb61c89038391c5c25ff31911a6dd187229f8ddb0a1bd61a03d
+SIZE (e17/ecore-1.7.4.tar.bz2) = 3421866
diff --git a/devel/ecore-main/pkg-plist b/devel/ecore-main/pkg-plist
index b3c94dcbdb7c..318aea4ac243 100644
--- a/devel/ecore-main/pkg-plist
+++ b/devel/ecore-main/pkg-plist
@@ -1,7 +1,7 @@
include/ecore-1/Ecore.h
include/ecore-1/Ecore_Getopt.h
lib/libecore.so
-lib/libecore.so.2
+lib/libecore.so.8
libdata/pkgconfig/ecore.pc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ecore_animator_example.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ecore_client_bench.c
@@ -21,7 +21,10 @@ libdata/pkgconfig/ecore.pc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ecore_evas_ews_example.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ecore_evas_object_example.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ecore_evas_window_sizes_example.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ecore_event_example.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ecore_event_example_01.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ecore_event_example_02.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ecore_exe_example.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ecore_exe_example_child.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ecore_fd_handler_example.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ecore_fd_handler_gnutls_example.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ecore_file_download_example.c