aboutsummaryrefslogtreecommitdiff
path: root/devel/ecore
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2008-03-11 21:13:53 +0000
committerStanislav Sedov <stas@FreeBSD.org>2008-03-11 21:13:53 +0000
commit9a2e4c8b780fc607dc4b4adabefb354c84401a96 (patch)
treef59767aed29b447d3d80ab987e898598663c27e3 /devel/ecore
parent621c804e48a9fdddd6a00d78585fa8cb20c8460e (diff)
downloadports-9a2e4c8b780fc607dc4b4adabefb354c84401a96.tar.gz
ports-9a2e4c8b780fc607dc4b4adabefb354c84401a96.zip
Notes
Diffstat (limited to 'devel/ecore')
-rw-r--r--devel/ecore/Makefile52
-rw-r--r--devel/ecore/pkg-descr5
2 files changed, 57 insertions, 0 deletions
diff --git a/devel/ecore/Makefile b/devel/ecore/Makefile
new file mode 100644
index 000000000000..1b5dbf9e204d
--- /dev/null
+++ b/devel/ecore/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: ecore
+# Date created: 22 September 2007
+# Whom: Stanislav Sedov <stas@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ecore
+PORTVERSION= 0.9.9.042
+PORTREVISION= 0
+PORTEPOCH= 2
+CATEGORIES= devel
+MASTER_SITES= # none
+DISTFILES= # none
+EXTRACT_ONLY= # none
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Enlightenment core abstraction library (meta port)
+
+NO_BUILD= yes
+USE_EFL= ecore
+
+ECORE_MODULES= con config desktop evas file ipc job sdl txt x11 imf imf_evas
+ECORE_sdl_off= yes
+
+.for NODE in ${ECORE_MODULES}
+OPTIONS+= ${NODE:U} "Install ${NODE} ecore module"
+. if !defined(ECORE_${NODE}_off)
+OPTIONS+= on
+. else
+OPTIONS+= off
+. endif
+.endfor
+
+.include <bsd.port.pre.mk>
+
+.for NODE in ${ECORE_MODULES}
+. if !defined(ECORE_${NODE}_off)
+. if !defined(WITHOUT_${NODE:U})
+USE_EFL_ECORE+= ${NODE}
+. endif
+. else
+. if defined(WITH_${NODE:U})
+USE_EFL_ECORE+= ${NODE}
+. endif
+. endif
+.endfor
+
+do-install:
+ ${DO_NADA}
+
+.include <bsd.port.post.mk>
diff --git a/devel/ecore/pkg-descr b/devel/ecore/pkg-descr
new file mode 100644
index 000000000000..2559668d0e57
--- /dev/null
+++ b/devel/ecore/pkg-descr
@@ -0,0 +1,5 @@
+A core event abstracter layer and X abstraction layer that makes doing
+selections, Xdnd, general X stuff, and event loops, timeouts and idle handlers
+fast, optimised, and convenient.
+
+WWW: http://enlightenment.sourceforge.net/Libraries/Ecore/