aboutsummaryrefslogtreecommitdiff
path: root/devel/efl/Makefile
diff options
context:
space:
mode:
authorGrzegorz Blach <gblach@FreeBSD.org>2014-12-30 22:54:24 +0000
committerGrzegorz Blach <gblach@FreeBSD.org>2014-12-30 22:54:24 +0000
commiteb5093ea5dffe7a7295881f24a778746fda58835 (patch)
treefb38a59919723c6d9a92eee3e2484dcd18502dcd /devel/efl/Makefile
parentab81d99b3122d1c99876a1e91acfe22613502985 (diff)
downloadports-eb5093ea5dffe7a7295881f24a778746fda58835.tar.gz
ports-eb5093ea5dffe7a7295881f24a778746fda58835.zip
Notes
Diffstat (limited to 'devel/efl/Makefile')
-rw-r--r--devel/efl/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/devel/efl/Makefile b/devel/efl/Makefile
index 528a374ebb6b..8c53007cbdd3 100644
--- a/devel/efl/Makefile
+++ b/devel/efl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= efl
PORTVERSION= 1.12.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel enlightenment
MASTER_SITES= http://download.enlightenment.org/rel/libs/${PORTNAME}/
@@ -20,7 +20,6 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
libdbus-1.so:${PORTSDIR}/devel/dbus \
- libluajit-5.1.so:${PORTSDIR}/lang/luajit \
libsndfile.so:${PORTSDIR}/audio/libsndfile
DIST_SUBDIR= enlightenment
@@ -136,6 +135,15 @@ CONFIGURE_ARGS+= --disable-ibus --with-glib=no
CONFIGURE_ARGS+= --with-opengl=none
.endif
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+USES+= lua
+CONFIGURE_ARGS+= --enable-lua-old
+PLIST_SUB+= ELUA="@comment "
+.else
+LIB_DEPENDS+= libluajit-5.1.so:${PORTSDIR}/lang/luajit
+PLIST_SUB+= ELUA=""
+.endif
+
pre-patch:
@${REINPLACE_CMD} -e \
's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \