aboutsummaryrefslogtreecommitdiff
path: root/devel/elfio/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-21 21:12:37 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-21 21:12:37 +0000
commit66be31631a729ed9974f4a426d59ec6f0f78b016 (patch)
treeb6b4242c02ed10e71cdde656e6160257e42d0a7d /devel/elfio/Makefile
parenta03ba739b7e112dfe6bee5620b31ab05def63294 (diff)
Notes
Diffstat (limited to 'devel/elfio/Makefile')
-rw-r--r--devel/elfio/Makefile29
1 files changed, 24 insertions, 5 deletions
diff --git a/devel/elfio/Makefile b/devel/elfio/Makefile
index 5a24890dd965..c7c58a74d785 100644
--- a/devel/elfio/Makefile
+++ b/devel/elfio/Makefile
@@ -6,17 +6,31 @@
# $FreeBSD$
#
-PORTNAME= ELFIO
+PORTNAME= elfio
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME:L}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME:U}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ssedov@mbsd.msk.ru
COMMENT= C++ library for reading and generating files in the ELF binary format
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GNOME= gnometarget
+
+OPTIONS= EXAMPLES "Install sample programms" on
+
+PORTDOCS= *
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_EXAMPLES)
+PLIST_SUB+= EXAMPLES=""
+.else
+PLIST_SUB+= EXAMPLES="@comment "
+.endif
post-install:
.if !defined(NOPORTDOCS)
@@ -28,5 +42,10 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}
.endfor
.endif
+.if !defined(WITHOUT_EXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${FIND} ${WRKSRC}/Examples/ -name "*.cpp" -exec ${INSTALL_DATA} {} \
+ ${EXAMPLESDIR}/ \;
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>