aboutsummaryrefslogtreecommitdiff
path: root/devel/elfio
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-01-01 22:09:42 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-01-01 22:09:42 +0000
commitb0f78227fce9664f15f9d0373f81aeacef136249 (patch)
tree3061eed7d9b3d8f62c07bc888f264bc6df6f9f51 /devel/elfio
parent52b4e5923208c9ad5c47a07d0af6bff7d04279a6 (diff)
downloadports-b0f78227fce9664f15f9d0373f81aeacef136249.tar.gz
ports-b0f78227fce9664f15f9d0373f81aeacef136249.zip
Notes
Diffstat (limited to 'devel/elfio')
-rw-r--r--devel/elfio/Makefile27
-rw-r--r--devel/elfio/distinfo2
-rw-r--r--devel/elfio/files/patch-ELFIImpl.cpp23
-rw-r--r--devel/elfio/pkg-comment2
-rw-r--r--devel/elfio/pkg-descr7
-rw-r--r--devel/elfio/pkg-plist14
6 files changed, 38 insertions, 37 deletions
diff --git a/devel/elfio/Makefile b/devel/elfio/Makefile
index e98d0c63710a..bf6abf87c6cd 100644
--- a/devel/elfio/Makefile
+++ b/devel/elfio/Makefile
@@ -6,23 +6,28 @@
# $FreeBSD$
#
-PORTNAME= elfio
-PORTVERSION= 0.2.7
+PORTNAME= ELFIO
+PORTVERSION= 1.0.0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITE_SUBDIR= ${PORTNAME:L}
MAINTAINER= ports@FreeBSD.org
-WRKSRC= ${WRKDIR}/ELFIO/ELFIO
-MAKEFILE= makefile
-USE_REINPLACE= yes
-ALL_TARGET= # empty
+GNU_CONFIGURE= yes
-post-patch:
- @${REINPLACE_CMD} -e "s,^CXXFLAGS,#CXXFLAGS,g" ${WRKSRC}/makefile
+DOCS= AUTHORS COPYING ChangeLog README
+DOCS2= elf11g.zip tutorial.docbook tutorial.pdf
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/libELFIO.a ${PREFIX}/lib
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.for file in ${DOCS2}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>
diff --git a/devel/elfio/distinfo b/devel/elfio/distinfo
index 3cc9c0bbbd86..9c3a40f632bb 100644
--- a/devel/elfio/distinfo
+++ b/devel/elfio/distinfo
@@ -1 +1 @@
-MD5 (elfio-0.2.7.tar.gz) = 1ea90e74ef2d54cb83fa9fe9fbaf7455
+MD5 (ELFIO-1.0.0.tar.gz) = e0711e99574e811d2e1c255e6eedb714
diff --git a/devel/elfio/files/patch-ELFIImpl.cpp b/devel/elfio/files/patch-ELFIImpl.cpp
deleted file mode 100644
index a2fada586fac..000000000000
--- a/devel/elfio/files/patch-ELFIImpl.cpp
+++ /dev/null
@@ -1,23 +0,0 @@
-
-$FreeBSD$
-
---- ELFIImpl.cpp.orig Wed Dec 18 01:52:15 2002
-+++ ELFIImpl.cpp Wed Dec 18 01:53:31 2002
-@@ -100,7 +100,7 @@
- #ifdef _MSC_VER
- unsigned int buflen = std::_MIN( sizeof( Elf32_Shdr ), (unsigned int)nEntrySize );
- #else
-- unsigned int buflen = std::min( sizeof( Elf32_Shdr ), (unsigned int)nEntrySize );
-+ unsigned int buflen = std::min( sizeof( Elf32_Shdr ), (size_t)nEntrySize );
- #endif
-
- for ( int i = 0; i < nNum; ++i ) {
-@@ -127,7 +127,7 @@
- #ifdef _MSC_VER
- int buflen = std::_MIN( sizeof( Elf32_Phdr ), (unsigned int)nEntrySize );
- #else
-- int buflen = std::min( sizeof( Elf32_Phdr ), (unsigned int)nEntrySize );
-+ int buflen = std::min( sizeof( Elf32_Phdr ), (size_t)nEntrySize );
- #endif
-
- for ( int i = 0; i < nNum; ++i ) {
diff --git a/devel/elfio/pkg-comment b/devel/elfio/pkg-comment
index 0baeb152f0b6..26c5044a34b6 100644
--- a/devel/elfio/pkg-comment
+++ b/devel/elfio/pkg-comment
@@ -1 +1 @@
-ELF (Executable and Linkable Format) reader and producer
+C++ library for reading and generating files in the ELF binary format
diff --git a/devel/elfio/pkg-descr b/devel/elfio/pkg-descr
index ea91de4bd683..83bd9e0f1f0e 100644
--- a/devel/elfio/pkg-descr
+++ b/devel/elfio/pkg-descr
@@ -1 +1,6 @@
-ELFIO - ELF (Executable and Linkable Format) reader and producer
+ELFIO is a C++ library for reading and generating files in the ELF binary
+format. This library is unique and not based on any other product. It is also
+platform independent. The library uses standard ANSI C++ constructions and
+runs on a wide variety of architectures.
+
+WWW: http://sourceforge.net/projects/elfio/
diff --git a/devel/elfio/pkg-plist b/devel/elfio/pkg-plist
index 51dc5bdea03d..f5aece737df4 100644
--- a/devel/elfio/pkg-plist
+++ b/devel/elfio/pkg-plist
@@ -1 +1,15 @@
+@comment $FreeBSD$
+bin/ELFDump
+include/ELFI.h
+include/ELFIO.h
+include/ELFO.h
+include/ELFTypes.h
lib/libELFIO.a
+%%PORTDOCS%%share/doc/ELFIO/AUTHORS
+%%PORTDOCS%%share/doc/ELFIO/COPYING
+%%PORTDOCS%%share/doc/ELFIO/ChangeLog
+%%PORTDOCS%%share/doc/ELFIO/README
+%%PORTDOCS%%share/doc/ELFIO/elf11g.zip
+%%PORTDOCS%%share/doc/ELFIO/tutorial.docbook
+%%PORTDOCS%%share/doc/ELFIO/tutorial.pdf
+%%PORTDOCS%%@dirrm share/doc/ELFIO