aboutsummaryrefslogtreecommitdiff
path: root/devel/elfsh/files
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-08-16 06:06:14 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-08-16 06:06:14 +0000
commitbd7d1808e5fd3ca9d538bfcc7f044d0dfd221262 (patch)
tree39ea1f978de763e347973351de1b629c7fd15a9b /devel/elfsh/files
parentf85d822d33b0cf9128b74c8608853a6e878543aa (diff)
downloadports-bd7d1808e5fd3ca9d538bfcc7f044d0dfd221262.tar.gz
ports-bd7d1808e5fd3ca9d538bfcc7f044d0dfd221262.zip
Notes
Diffstat (limited to 'devel/elfsh/files')
-rw-r--r--devel/elfsh/files/patch-Makefile17
-rw-r--r--devel/elfsh/files/patch-elfsh::Makefile11
-rw-r--r--devel/elfsh/files/patch-libelfsh::Makefile12
-rw-r--r--devel/elfsh/files/patch-libhash::Makefile11
-rw-r--r--devel/elfsh/files/patch-modules-modflow::Makefile11
-rw-r--r--devel/elfsh/files/patch-modules::Makefile13
-rw-r--r--devel/elfsh/files/patch-vm::Makefile31
7 files changed, 89 insertions, 17 deletions
diff --git a/devel/elfsh/files/patch-Makefile b/devel/elfsh/files/patch-Makefile
new file mode 100644
index 000000000000..1ae8ffd23bc2
--- /dev/null
+++ b/devel/elfsh/files/patch-Makefile
@@ -0,0 +1,17 @@
+--- Makefile Wed Aug 13 16:31:55 2003
++++ Makefile.patch Sat Aug 16 02:11:52 2003
+@@ -7,10 +7,10 @@
+
+ RM = rm -f
+ ETAGS = etags
+-MODPATH = /usr/share/elfsh/
+-BINPATH = /usr/bin
+-LIBPATH = /usr/lib/
+-INCPATH = /usr/include/
++MODPATH = $(PREFIX)/share/elfsh/
++BINPATH = $(PREFIX)/bin
++LIBPATH = $(PREFIX)/lib/
++INCPATH = $(PREFIX)/include/
+
+ all :
+ @echo 'Builting libelfsh...'
diff --git a/devel/elfsh/files/patch-elfsh::Makefile b/devel/elfsh/files/patch-elfsh::Makefile
deleted file mode 100644
index 6ec586d4501c..000000000000
--- a/devel/elfsh/files/patch-elfsh::Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- elfsh/Makefile.orig Mon Jun 23 17:33:38 2003
-+++ elfsh/Makefile Mon Jun 23 17:35:00 2003
-@@ -12,7 +12,7 @@
- CC = gcc
- NAME = elfsh
- LDFLAGS = -L../libelfsh/ -lelfsh
--CFLAGS = -Wall -Iinclude -I../libelfsh/include -g3 -O2
-+CFLAGS += -Wall -Iinclude -I../libelfsh/include
- RM = rm -f
- NAME = elfsh
-
diff --git a/devel/elfsh/files/patch-libelfsh::Makefile b/devel/elfsh/files/patch-libelfsh::Makefile
index 87cccf531c1d..4b85e869bd57 100644
--- a/devel/elfsh/files/patch-libelfsh::Makefile
+++ b/devel/elfsh/files/patch-libelfsh::Makefile
@@ -1,11 +1,11 @@
---- libelfsh/Makefile.orig Mon Jun 23 17:36:25 2003
-+++ libelfsh/Makefile Mon Jun 23 17:37:33 2003
+--- libelfsh/Makefile Wed Aug 13 16:31:55 2003
++++ libelfsh/Makefile.patch Sat Aug 16 01:48:30 2003
@@ -8,7 +8,7 @@
CC = gcc
RM = rm -f
AR = ar rc
--CFLAGS = -Iinclude -Wall -g3 -O2
-+CFLAGS += -Iinclude -Wall -fpic
+-CFLAGS = -rdynamic -Iinclude -Wall -fPIC -g3 -O2 -DELFSH_INTERN
++CFLAGS += -rdynamic -Iinclude -Wall -fPIC -g3 -DELFSH_INTERN
SRC = dynamic.c dynsym.c elf.c fixup.c got.c hash.c \
- interp.c pht.c plt.c section.c sht.c error.c \
- stab.c symbol.c notes.c reloc.c functions.c \
+ interp.c pht.c plt.c section.c sht.c error.c stab.c \
+ symbol.c notes.c reloc.c blocks.c ctors.c dtors.c \
diff --git a/devel/elfsh/files/patch-libhash::Makefile b/devel/elfsh/files/patch-libhash::Makefile
new file mode 100644
index 000000000000..daea1d2e8202
--- /dev/null
+++ b/devel/elfsh/files/patch-libhash::Makefile
@@ -0,0 +1,11 @@
+--- libhash/Makefile Wed Aug 13 16:31:55 2003
++++ libhash/Makefile.patch Sat Aug 16 01:52:22 2003
+@@ -7,7 +7,7 @@
+
+ SRC = hash.c
+ OBJ = hash.o
+-CFLAGS = -Wall -g3 -Iinclude -I../libelfsh/include/ -I../elfsh/include/ -DELFSH_INTERN
++CFLAGS += -Wall -g3 -Iinclude -I../libelfsh/include/ -I../elfsh/include/ -DELFSH_INTERN
+ CC = gcc
+ AR = ar rc
+ RANLIB = ranlib
diff --git a/devel/elfsh/files/patch-modules-modflow::Makefile b/devel/elfsh/files/patch-modules-modflow::Makefile
new file mode 100644
index 000000000000..8b14dbff1b4a
--- /dev/null
+++ b/devel/elfsh/files/patch-modules-modflow::Makefile
@@ -0,0 +1,11 @@
+--- modules/modflow/Makefile Sat Aug 16 01:52:00 2003
++++ modules/modflow/Makefile.patch Sat Aug 16 01:51:51 2003
+@@ -17,7 +17,7 @@
+
+ NAME = modflow.so
+
+-CFLAGS = -Wall -Werror -ggdb -I../../vm/include \
++CFLAGS += -Wall -Werror -ggdb -I../../vm/include \
+ -I../../libelfsh/include -I../../libhash/include \
+ -fPIC -rdynamic -DELFSH_INTERN
+
diff --git a/devel/elfsh/files/patch-modules::Makefile b/devel/elfsh/files/patch-modules::Makefile
new file mode 100644
index 000000000000..d253ddee0bcf
--- /dev/null
+++ b/devel/elfsh/files/patch-modules::Makefile
@@ -0,0 +1,13 @@
+--- modules/Makefile Wed Aug 13 16:31:56 2003
++++ modules/Makefile.patch Sat Aug 16 01:51:05 2003
+@@ -18,8 +18,8 @@
+ OBJ3 = $(SRC3:.c=.o)
+ NAM3 = modremap.so
+
+-CFLAGS = -I../vm/include/ -I../libhash/include/ -I../libelfsh/include/ \
+- -Wall -g3 -O2 -fPIC -rdynamic -DELFSH_INTERN
++CFLAGS += -I../vm/include/ -I../libhash/include/ -I../libelfsh/include/ \
++ -Wall -g3 -fPIC -rdynamic -DELFSH_INTERN
+ CC = gcc
+
+ all : test remap #flow
diff --git a/devel/elfsh/files/patch-vm::Makefile b/devel/elfsh/files/patch-vm::Makefile
new file mode 100644
index 000000000000..9ba55340f34d
--- /dev/null
+++ b/devel/elfsh/files/patch-vm::Makefile
@@ -0,0 +1,31 @@
+--- vm/Makefile Fri Aug 15 17:58:34 2003
++++ vm/Makefile.patch Sat Aug 16 02:26:48 2003
+@@ -19,9 +19,6 @@
+ RM = rm -f
+ NAME = elfsh
+
+-DLOPT_freebsd4.4 =
+-DLOPT_linux-gnu = -ldl
+-DLOPT_solaris = -ldl
+ #EXTRAOPT = -lefence
+
+ # Uncomment that to use libasm
+@@ -29,14 +26,14 @@
+ #LDASMOPT = -lasm
+
+ # Uncommant that to use libreadline
+-#READLNOPT = -DUSE_READLN
+-#LDREADLNOPT = -lreadline -ltermcap
++READLNOPT = -DUSE_READLN
++LDREADLNOPT = -lreadline -ltermcap
+
+-CFLAGS = -rdynamic -fPIC -g3 -O2 -Wall -Iinclude \
++CFLAGS += -rdynamic -fPIC -g3 -Wall -Iinclude \
+ -I../libhash/include/ -I../libelfsh/include/ \
+ -DELFSH_INTERN $(ASMOPT) $(READLNOPT)
+ LDFLAGS = -L../libelfsh/ -lelfsh -L../libhash/ -lhashelfsh \
+- -rdynamic -g3 -ldl $(LDASMOPT) $(LDREADLNOPT) \
++ -rdynamic -g3 $(LDASMOPT) $(LDREADLNOPT) \
+ $(EXTRAOPT)
+
+