aboutsummaryrefslogtreecommitdiff
path: root/devel/elfsh
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-08-23 16:49:47 +0000
committerJohn Marino <marino@FreeBSD.org>2016-08-23 16:49:47 +0000
commit6aca1a12ff150be986e9409d6b7d8fcfa205fef8 (patch)
treefd95b80b9528253dcb21353bf41fdae43f30bba8 /devel/elfsh
parentce4178000f00b4c025a06e9e110e5be6139df886 (diff)
Notes
Diffstat (limited to 'devel/elfsh')
-rw-r--r--devel/elfsh/Makefile7
-rw-r--r--devel/elfsh/files/patch-libelfsh_include_libelfsh-compat.h20
-rw-r--r--devel/elfsh/files/patch-libelfsh_plt.c11
-rw-r--r--devel/elfsh/files/patch-libelfsh_relinject.c11
-rw-r--r--devel/elfsh/files/patch-testsuite_sct__fillbss__injection_section__inject.c11
-rw-r--r--devel/elfsh/files/patch-testsuite_sct__index__injection_section__inject.c11
-rw-r--r--devel/elfsh/files/patch-vm__Makefile2
7 files changed, 69 insertions, 4 deletions
diff --git a/devel/elfsh/Makefile b/devel/elfsh/Makefile
index c8e007ae4529..4a1949233232 100644
--- a/devel/elfsh/Makefile
+++ b/devel/elfsh/Makefile
@@ -3,7 +3,7 @@
PORTNAME= elfsh
PORTVERSION= 0.51b3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= http://elfsh.asgardlabs.org/files/
DISTNAME= elfsh-0.51b3-portable
@@ -11,12 +11,13 @@ DISTNAME= elfsh-0.51b3-portable
MAINTAINER= ports@FreeBSD.org
COMMENT= Attractive toolkit for the analysis of ELF object files
-USES= gmake readline tar:tgz
+USES= gmake ncurses readline tar:tgz
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
pre-install:
- @(cd ${WRKSRC} && ${STRIP_CMD} vm/elfsh libelfsh/libelfsh.so modules/*.so)
+ @(cd ${WRKSRC} && \
+ ${STRIP_CMD} vm/elfsh libelfsh/libelfsh.so modules/*.so)
.include <bsd.port.mk>
diff --git a/devel/elfsh/files/patch-libelfsh_include_libelfsh-compat.h b/devel/elfsh/files/patch-libelfsh_include_libelfsh-compat.h
new file mode 100644
index 000000000000..f6348407ae4b
--- /dev/null
+++ b/devel/elfsh/files/patch-libelfsh_include_libelfsh-compat.h
@@ -0,0 +1,20 @@
+--- libelfsh/include/libelfsh-compat.h.orig 2003-08-21 01:11:03 UTC
++++ libelfsh/include/libelfsh-compat.h
+@@ -10,7 +10,7 @@
+
+ #if defined(__linux__)
+ #include <endian.h>
+-#elif defined(__FreeBSD__) || defined (__OpenBSD__) || defined(__NetBSD__)
++#elif defined(__FreeBSD__) || defined (__OpenBSD__) || defined(__NetBSD__) || defined(__DragonFly__)
+ #include <machine/endian.h>
+ #elif defined(sun)
+ #define __LITTLE_ENDIAN 1234
+@@ -38,7 +38,7 @@
+ /* Portability Stuffs */
+ #if defined(__OpenBSD__) || defined(__NetBSD__)
+ #include <sys/exec_elf.h>
+-#elif defined(__linux__) || defined(__FreeBSD__) || defined(sun)
++#elif defined(__linux__) || defined(__FreeBSD__) || defined(sun) || defined(__DragonFly__)
+ #include <elf.h>
+ #endif
+
diff --git a/devel/elfsh/files/patch-libelfsh_plt.c b/devel/elfsh/files/patch-libelfsh_plt.c
new file mode 100644
index 000000000000..36226d776ba4
--- /dev/null
+++ b/devel/elfsh/files/patch-libelfsh_plt.c
@@ -0,0 +1,11 @@
+--- libelfsh/plt.c.orig 2003-08-21 01:11:03 UTC
++++ libelfsh/plt.c
+@@ -47,7 +47,7 @@ int elfsh_copy_plt(elfshobj_t *file)
+ 0, 0, plt->shdr->sh_size, 0, 0, 0, 0);
+
+ /* FreeBSD is incompatible with pre-interp injection */
+-#ifdef __FreeBSD__
++#if defined __FreeBSD__ || defined __DragonFly__
+ mode = ELFSH_DATA_INJECTION;
+ #else
+ mode = ELFSH_CODE_INJECTION;
diff --git a/devel/elfsh/files/patch-libelfsh_relinject.c b/devel/elfsh/files/patch-libelfsh_relinject.c
new file mode 100644
index 000000000000..0d05eec7ef9e
--- /dev/null
+++ b/devel/elfsh/files/patch-libelfsh_relinject.c
@@ -0,0 +1,11 @@
+--- libelfsh/relinject.c.orig 2003-08-21 01:33:53 UTC
++++ libelfsh/relinject.c
+@@ -347,7 +347,7 @@ static int elfsh_inject_etrel_section(el
+ writable = elfsh_get_section_writableflag(sect->shdr);
+
+ /* FreeBSD is incompatible with pre-interp injection */
+-#ifdef __FreeBSD__
++#if defined __FreeBSD__ || defined __DragonFly__
+ mode = ELFSH_DATA_INJECTION;
+ #else
+ mode = (writable ? ELFSH_DATA_INJECTION : ELFSH_CODE_INJECTION);
diff --git a/devel/elfsh/files/patch-testsuite_sct__fillbss__injection_section__inject.c b/devel/elfsh/files/patch-testsuite_sct__fillbss__injection_section__inject.c
new file mode 100644
index 000000000000..2e859905f034
--- /dev/null
+++ b/devel/elfsh/files/patch-testsuite_sct__fillbss__injection_section__inject.c
@@ -0,0 +1,11 @@
+--- testsuite/sct_fillbss_injection/section_inject.c.orig 2003-08-21 01:11:03 UTC
++++ testsuite/sct_fillbss_injection/section_inject.c
+@@ -23,7 +23,7 @@ char sc[] =
+ "\x42\x0b\xcd\x80"
+ "\x31\xC0\x40\xcd\x80";
+
+-#elif defined(__NetBSD__) || defined(__OpenBSD__) || defined(__FreeBSD__)
++#elif defined(__NetBSD__) || defined(__OpenBSD__) || defined(__FreeBSD__) || defined(__DragonFly__)
+
+ char sc[] =
+ "\xeb\x22" /* jmp end */
diff --git a/devel/elfsh/files/patch-testsuite_sct__index__injection_section__inject.c b/devel/elfsh/files/patch-testsuite_sct__index__injection_section__inject.c
new file mode 100644
index 000000000000..ddd10bed21fa
--- /dev/null
+++ b/devel/elfsh/files/patch-testsuite_sct__index__injection_section__inject.c
@@ -0,0 +1,11 @@
+--- testsuite/sct_index_injection/section_inject.c.orig 2003-08-21 01:11:03 UTC
++++ testsuite/sct_index_injection/section_inject.c
+@@ -18,7 +18,7 @@ char sc[] =
+ "\x62\x69\x89\xe3\x52\x53\x89\xe1\x8D\x42\x0b"
+ "\xcd\x80\x31\xC0\x40\xcd\x80";
+
+-#elif defined(__NetBSD__) || defined(__OpenBSD__) || defined(__FreeBSD__)
++#elif defined(__NetBSD__) || defined(__OpenBSD__) || defined(__FreeBSD__) || defined(__DragonFly__)
+
+ char sc[] =
+ "\xeb\x22" /* jmp end */
diff --git a/devel/elfsh/files/patch-vm__Makefile b/devel/elfsh/files/patch-vm__Makefile
index e163d6c2e2c5..294d95beaaee 100644
--- a/devel/elfsh/files/patch-vm__Makefile
+++ b/devel/elfsh/files/patch-vm__Makefile
@@ -7,7 +7,7 @@
-#READLNOPT = -DUSE_READLN
-#LDREADLNOPT = -lreadline -ltermcap
+READLNOPT = -DUSE_READLN
-+LDREADLNOPT = -lreadline -ltermcap
++LDREADLNOPT = -lreadline -lncurses
# End of configurable Makefile