aboutsummaryrefslogtreecommitdiff
path: root/devel/elfsh
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2011-11-03 08:14:02 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2011-11-03 08:14:02 +0000
commit85a01079351a36cbc652f5e4369c1513587af076 (patch)
tree7d7b686127654dc1816b8dd307efad26d62e6923 /devel/elfsh
parent1aa95ce71fb1345be9a1917be4137aad4b2c5ade (diff)
downloadports-85a01079351a36cbc652f5e4369c1513587af076.tar.gz
ports-85a01079351a36cbc652f5e4369c1513587af076.zip
Notes
Diffstat (limited to 'devel/elfsh')
-rw-r--r--devel/elfsh/files/patch-libelfsh::Makefile12
-rw-r--r--devel/elfsh/files/patch-libhash::Makefile10
-rw-r--r--devel/elfsh/files/patch-modules::Makefile10
-rw-r--r--devel/elfsh/files/patch-vm::Makefile11
4 files changed, 28 insertions, 15 deletions
diff --git a/devel/elfsh/files/patch-libelfsh::Makefile b/devel/elfsh/files/patch-libelfsh::Makefile
index 4b85e869bd57..d4fbc43b566b 100644
--- a/devel/elfsh/files/patch-libelfsh::Makefile
+++ b/devel/elfsh/files/patch-libelfsh::Makefile
@@ -1,7 +1,11 @@
---- libelfsh/Makefile Wed Aug 13 16:31:55 2003
-+++ libelfsh/Makefile.patch Sat Aug 16 01:48:30 2003
-@@ -8,7 +8,7 @@
- CC = gcc
+--- libelfsh/Makefile.orig 2003-08-21 09:11:03.000000000 +0800
++++ libelfsh/Makefile 2011-10-03 16:33:33.000000000 +0800
+@@ -5,10 +5,10 @@
+ ## Last update Tue Jun 3 09:30:50 2003 mayhem
+ ##
+
+-CC = gcc
++CC ?= gcc
RM = rm -f
AR = ar rc
-CFLAGS = -rdynamic -Iinclude -Wall -fPIC -g3 -O2 -DELFSH_INTERN
diff --git a/devel/elfsh/files/patch-libhash::Makefile b/devel/elfsh/files/patch-libhash::Makefile
index daea1d2e8202..c928d0690ffd 100644
--- a/devel/elfsh/files/patch-libhash::Makefile
+++ b/devel/elfsh/files/patch-libhash::Makefile
@@ -1,11 +1,13 @@
---- libhash/Makefile Wed Aug 13 16:31:55 2003
-+++ libhash/Makefile.patch Sat Aug 16 01:52:22 2003
-@@ -7,7 +7,7 @@
+--- libhash/Makefile.orig 2003-08-21 09:11:03.000000000 +0800
++++ libhash/Makefile 2011-10-03 16:33:58.000000000 +0800
+@@ -7,8 +7,8 @@
SRC = hash.c
OBJ = hash.o
-CFLAGS = -Wall -g3 -Iinclude -I../libelfsh/include/ -I../elfsh/include/ -DELFSH_INTERN
+-CC = gcc
+CFLAGS += -Wall -g3 -Iinclude -I../libelfsh/include/ -I../elfsh/include/ -DELFSH_INTERN
- CC = gcc
++CC ?= gcc
AR = ar rc
RANLIB = ranlib
+ NAME = libhashelfsh
diff --git a/devel/elfsh/files/patch-modules::Makefile b/devel/elfsh/files/patch-modules::Makefile
index d253ddee0bcf..052a30c81230 100644
--- a/devel/elfsh/files/patch-modules::Makefile
+++ b/devel/elfsh/files/patch-modules::Makefile
@@ -1,13 +1,15 @@
---- modules/Makefile Wed Aug 13 16:31:56 2003
-+++ modules/Makefile.patch Sat Aug 16 01:51:05 2003
-@@ -18,8 +18,8 @@
+--- modules/Makefile.orig 2003-08-21 09:11:03.000000000 +0800
++++ modules/Makefile 2011-10-03 16:34:46.000000000 +0800
+@@ -18,9 +18,9 @@ SRC3 = modremap.c
OBJ3 = $(SRC3:.c=.o)
NAM3 = modremap.so
-CFLAGS = -I../vm/include/ -I../libhash/include/ -I../libelfsh/include/ \
- -Wall -g3 -O2 -fPIC -rdynamic -DELFSH_INTERN
+-CC = gcc
+CFLAGS += -I../vm/include/ -I../libhash/include/ -I../libelfsh/include/ \
+ -Wall -g3 -fPIC -rdynamic -DELFSH_INTERN
- CC = gcc
++CC ?= gcc
all : test remap #flow
+
diff --git a/devel/elfsh/files/patch-vm::Makefile b/devel/elfsh/files/patch-vm::Makefile
index 78da8d9c6f4e..30e1c39b8295 100644
--- a/devel/elfsh/files/patch-vm::Makefile
+++ b/devel/elfsh/files/patch-vm::Makefile
@@ -1,5 +1,5 @@
---- vm/Makefile Thu Aug 21 04:23:17 2003
-+++ vm/Makefile.patch Thu Sep 25 00:26:25 2003
+--- vm/Makefile.orig 2003-08-21 09:23:17.000000000 +0800
++++ vm/Makefile 2011-10-03 16:34:23.000000000 +0800
@@ -19,8 +19,8 @@
#LDASMOPT = -lasm
@@ -11,7 +11,12 @@
# End of configurable Makefile
-@@ -40,7 +40,7 @@
+@@ -36,11 +36,11 @@ SRC = grammar.c disasm.c dyn.c hdr.c m
+ OBJ = $(SRC:.c=.o)
+ SRC_DYN = elfsh_etdyn.c
+ OBJ_DYN = $(SRC_DYN:.c=.o)
+-CC = gcc
++CC ?= gcc
RM = rm -f
NAME = elfsh